Skip to content
Permalink
Branch: master
Commits on May 24, 2019
  1. Merge pull request #176 from YoeDistro/kraj/master

    cbrake committed May 24, 2019
    Layer Updates:  sources/meta-intel sources/meta-openembedded sources/…
  2. Layer Updates: sources/meta-intel sources/meta-openembedded sources/m…

    kraj committed May 24, 2019
    …eta-yoe
    
    * sources/meta-intel 6633f870...35555fb5 (2):
      > intel-microcode: fix upstream release checking
      > linux-intel_4.19: update to v4.19.40
    
    * sources/meta-openembedded f3018013ff...321a62261d (23):
      > ne10, libopus: add armv7ve override as well
      > apache2: add all extra/*.conf to conffiles
      > lcov: Upgrade 1.11 -> 1.14
      > modemmanager: Update to 1.10.0
      > Remove ipsec-tools and umip
      > dvb-apps: Remove workaround patch for ancient target compilers
      > Remove start-stop-daemon
      > pm-graph: add recipe
      > mdns: update to 878.200.35
      > nbd: update to 3.19
      > mtr: update to 0.92
      > php-7: mark two tests as expected to fail
      > ipcalc: update to 2.2.3
      > atftp: update to 0.7.2
      > Upgraded python-pysnmp from version 4.3.5. to 4.4.9.
      > rp-pppoe: update to 3.13
      > openocd: Fix build on x86_64
      > libnfc: Fix build with musl
      > polkit: fix CVE-2019-6133
      > python-obd: Uprade from 0.7.0 to 0.7.1
      > python-ldap: update to 3.2.0
      > opensaf: update to 5.19.03
      > igmpproxy: remove 0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch and _GNU_SOURCE
    
    * sources/meta-yoe 7b45fba...e890ed3 (1):
      > Merge pull request #31 from YoeDistro/yoe/mut
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 23, 2019
  1. Merge pull request #175 from YoeDistro/kraj/master

    cbrake committed May 23, 2019
    Update layers
Commits on May 22, 2019
  1. Layer Updates: sources/meta-browser sources/meta-freescale sources/me…

    kraj committed May 22, 2019
    …ta-freescale-3rdparty sources/meta-intel sources/meta-riscv sources/meta-ti sources/openembedded-core
    
    * sources/meta-browser aa3649e...6386d9a (2):
      > chromium-ozone-wayland: Fix V4L2 VDA CanCreateEGLImageFrom()
      > chromium: Update to 74.0.3729.157.
    
    * sources/meta-freescale abfc7b1e...179c81a7 (4):
      > linux-fslc-lts-4.19: initial add
      > qca-tools: Disable for musl hosts
      > imx-atf: Upgrade version from 1.5 to 2.0
      > imx-sc-firmware: Upgrade version from 0.9 to 1.2
    
    * sources/meta-freescale-3rdparty 40a05f3...ca9029c (7):
      > imx6qdl-variscite-som: use linux-fslc-lts-4.19 when selecting mainline
      > add support for linux-fslc-lts-4.19
      > init-ifupdown: ccimx6ulsbcpro: Add Wi-Fi interfaces to the interfaces file
      > init-ifupdown: ccimx6ulsbcexpress: Add wi-Fi interfaces to interfaces file
      > linux-fslc: ccimx6som: Add support for wireless module variants
      > udev-rules-digi: Add udev rules for Digi International SOMs
      > ccimx6ulsom: Add wireless driver and firmware files
    
    * sources/meta-intel 886d2063...6633f870 (1):
      > intel-microcode: upgrade to 20190514a
    
    * sources/meta-riscv 4dd427a...4157f3e (2):
      > gdb: Remove the RISC-V GDB
      > layer.conf: Mark master warrior and newer compatible only
    
    * sources/meta-ti 49a622ef...b8965c33 (1):
      > u-boot-ti-staging: update to ti2019.01-rc5 tag
    
    * sources/openembedded-core 066fa83eea...335f891c55 (45):
      > iproute2: Remove bogus workaround patch for musl
      > kexec-tools: refresh patches with devtool
      > perl/modules: Add various missing ptest perl module dependencies
      > m4: Add coreutils and diffutils dependency for ptest
      > libpcre: Add make dependency for ptest
      > openssh: Add sudo dependency for ptest
      > bash: Fix bash-ptest dependencies
      > perl-rdepends: Add missing module dependencies
      > btrfs-tools: update to 5.1
      > epiphany: update to 3.32.2
      > webkitgtk: update to 2.24.2
      > usbutils: upgrade 010->012
      > freetype: upgrade 2.9.1 -> 2.10.0
      > acpica: upgrade 20190405 -> 20190509
      > gst-examples: upgrade to 1.16.0
      > bash-completion: upgrade 2.8 -> 2.9
      > python3-pbr: upgrade 5.1.3 -> 5.2.0
      > linux-firmware: upgrade to latest revision
      > x264: upgrade to latest revision
      > libsoup-2.4: upgrade 2.66.1 -> 2.66.2
      > glib-networking: upgrade 2.60.1 -> 2.60.2
      > at-spi2-atk: upgrade 2.30.0 -> 2.32.0
      > at-spi2-core: upgrade 2.30.0 -> 2.32.1
      > pkgconf: upgrade 1.6.0 -> 1.6.1
      > python3-pip: upgrade 19.0.3 -> 19.1.1
      > libxcrypt: upgrade 4.4.4 -> 4.4.6
      > lz4: upgrade 1.9.0 -> 1.9.1
      > alsa-lib: upgrade 1.1.8 -> 1.1.9
      > alsa-utils: upgrade 1.1.8 -> 1.1.9
      > alsa-plugins: upgrade 1.1.8 -> 1.1.9
      > gawk: upgrade 4.2.1 -> 5.0.0
      > systemtap: upgrade 4.0 -> 4.1
      > go: update 1.12.1->1.12.5
      > nss: upgrade 3.43 -> 3.44
      > python3-mako: upgrade 1.0.9 -> 1.0.10
      > atk: upgrade 2.30.0 -> 2.32.0
      > bison: upgrade 3.1 -> 3.3.2
      > adwaita-icon-theme: upgrade 3.30.1 -> 3.32.0
      > libdazzle: upgrade 3.32.1 -> 3.32.2
      > createrepo-c: upgrade 0.12.2 -> 0.14.0
      > libmodulemd: fix erroneous linking against v2 library when v1 was requested
      > libmodulemd: upgrade 2.2.3 -> 2.4.0
      > librepo: upgrade 1.9.6 -> 1.10.2
      > ofono: Fix another race condition during the build
      > ofono: Use external ell instead of an internal copy
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 21, 2019
  1. Layer Updates: sources/bitbake sources/meta-intel sources/meta-openem…

    kraj committed May 21, 2019
    …bedded sources/openembedded-core
    
    * sources/bitbake fd27ab60...3d319c79 (2):
      > bitbake: fetch2/npm: fix npw view parsing
      > svn.py: Stop SVN from directly pulling from an external layer w/o fetcher
    
    * sources/meta-intel 8cd484ab...886d2063 (1):
      > lttng-modules: add bbappend
    
    * sources/meta-openembedded 1ecd8b4364...f3018013ff (24):
      > opencv: use the same package name in PACKAGES and RDEPENDS
      > toybox: Re-order inherit location so we can override do_configure
      > triggerhappy: fix issues
      > python-cassandra-driver.inc: fix DEPENDS
      > wireguard: Upgrade 20190123 -> 20190406
      > mscgen: fix SRC_URI for multilib
      > ell: remove recipe
      > Add irda-utils
      > umip: make MACHINE_ARCH
      > oprofile: make MACHINE_ARCH
      > ndctl: make MACHINE_ARCH and ignore from libblockdev
      > gtkwave: add distro_features_check
      > python-pysocks: upgrade 1.6.8 -> 1.7.0
      > python-pip: upgrade 19.1 -> 19.1.1
      > python-mako:upgrade 1.0.9 -> 1.0.10
      > python-wrapt: upgrade 1.10.11 -> 1.11.1
      > python-urllib3: upgrade 1.23 -> 1.25.2
      > python-typing: upgrade 3.6.4 -> 3.6.6
      > python-six: upgrade 1.11.0 -> 1.12.0
      > xl2tpd: update to 1.3.14
      > pure-ftpd: update to 1.0.47
      > znc: update to 1.7.3
      > openocd: Upgrade to latest git version
      > python-pyparsing: upgrade 2.2.0 -> 2.4.0
    
    * sources/openembedded-core 8a6ef2044c...066fa83eea (20):
      > libxfont2: set CVE_PRODUCT
      > python: add a fix for CVE-2019-9948 and CVE-2019-9636
      > valgrind: add 'file' to ptest depends
      > valgrind: Make ptest timestamps copasetic
      > libpcre2: upgrade 10.32 -> 10.33
      > socat: Remove workaround for musl issue now fixed upstream
      > insane: add sanity checks to SRC_URI
      > icu: Remove workaround for musl issue fixed upstream 2 years ago
      > gnu-config: Update to latest SHA
      > gdb: Upgrade from 8.2.1 to 8.3
      > libnss-mdns: Stop trying to build for musl
      > python-numpy: Avoid installing copy of f2py script
      > vim: Rework things so vim adds features not vim-tiny removes
      > vim: split the common part into vim.inc
      > systemd: Some upstreamable musl patches have been upstreamed
      > nss-myhostname: Stop trying to build for musl
      > util-linux: Add missing ptest dependencies
      > npm: remove some temporary build files
      > npm: fix node and npm default directory conflict
      > npm: get npm package name from npm pack
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  2. Layer Updates: sources/meta-browser sources/meta-intel

    kraj committed May 21, 2019
    * sources/meta-browser ee30061...aa3649e (1):
      > chromium: Refresh musl related patches
    
    * sources/meta-intel c80d7ac0...8cd484ab (1):
      > README: Updated Tested Hardware
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 20, 2019
  1. Merge pull request #174 from YoeDistro/kraj/master

    cbrake committed May 20, 2019
    Update master
  2. Layer Updates: sources/meta-freescale sources/meta-qt5 sources/meta-v…

    kraj committed May 20, 2019
    …ariscite-fslc
    
    * sources/meta-freescale 57562d1c...abfc7b1e (2):
      > imx-boot: drop dependency to u-boot
      > imx-usb-loader: Update to 29fa8ab revision
    
    * sources/meta-qt5 c7e0ba5...60e61ea (6):
      > qt3d-runtime: update to v2.3
      > qtbase: add no-opengl to PACKAGECONFIG_GL when opengl isn't in DISTRO_FEATURES
      > qtbase: add accessibility from PACKAGECONFIG_KDE to PACKAGECONFIG_DEFAULT
      > qtbase: add libxext dependency for xcb PACKAGECONFIG
      > python-pyqt5: Update to version 5.12.1.
      > python-pyqt: Fix annoying problems.
    
    * sources/meta-variscite-fslc cd33ae9...1f2e707 (1):
      > linux-variscite: Updated to latest revision
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 19, 2019
  1. Layer Updates: sources/meta-atmel

    kraj committed May 19, 2019
    * sources/meta-atmel 7934878...031f2ef (11):
      > u-boot-at91: update kernel bootargs with rng_core param
      > linux-at91: add linux-at91-4.19 recipe
      > linux-at91: remove 4.9 version
      > u-boot-at91: add 2019.04 version
      > uboot-at91: remove older versions
      > at91bootstrap: remove older versions
      > at91bootstrap: add 3.8.13 recipe
      > Merge pull request #130 from texierp/fixes/u-boot-env
      > atmel-qt-demo-init: do not use generic license file
      > Merge pull request #129 from YoeDistro/yoe/mut
      > Merge pull request #128 from danielbatw/update_latest
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 18, 2019
  1. Layer Updates: sources/bitbake sources/meta-browser sources/meta-free…

    kraj committed May 18, 2019
    …scale sources/meta-intel sources/meta-odroid sources/meta-openembedded sources/meta-qcom sources/meta-qt5 sources/meta-riscv sources/meta-ti sources/meta-variscite-fslc sources/openembedded-core
    
    * sources/bitbake 9b4a9e54...fd27ab60 (2):
      > gitsm: Fix a bug where the wrong path was used for the submodule init
      > bitbake-user-manual: Added npm to other fetcher list.
    
    * sources/meta-browser 1f363e2...ee30061 (2):
      > chromium-ozone-wayland: Fix usage without zwp_linux_dmabuf and NGMB.
      > chromium: Fix arm64 build.
    
    * sources/meta-freescale 3dc8f2fe...57562d1c (11):
      > imx-gst1.0-plugin: Upgrade version from 4.4.2 to 4.4.5
      > gstreamer1.0-plugins-bad: Switch to MM_04.04.05_1902_L4.14.98_GA branch
      > gstreamer1.0-plugins-good: Switch to MM_04.04.05_1902_L4.14.98_GA branch
      > gstreamer1.0-plugins-base: Switch to MM_04.04.05_1902_L4.14.98_GA branch
      > gstreamer1.0: Switch to MM_04.04.05_1902_L4.14.98_GA branch
      > imx-vpuwrap: Upgrade version from 4.4.2 to 4.4.5
      > imx-parser: Upgrade version from 4.4.2 to 4.4.5
      > imx-codec: Upgrade version from 4.4.2 to 4.4.5
      > imx-vpu-hantro: Upgrade version from 1.8.0 to 1.11.0
      > utilities.inc: fix return None type error
      > u-boot-imx: Upgrade version 2017.03 to 2018.03
    
    * sources/meta-intel 8630938e...c80d7ac0 (7):
      > intel-graphics-compiler: add
      > clang: build Intel common-clang and spirv
      > build linux_linker from common clang
      > linux-intel-dev: add recipe
      > itt: add recipe
      > README: remove reference to bitbake version
      > linux-intel-rt/4.19: update meta SRCREVs to v4.19.31
    
    * sources/meta-odroid 03ee6ff...e4bce8c (11):
      > linux-stable/4.19: update to 4.19.40
      > linux-stable/5.0: update to 5.0.13
      > meson64-common.cfg: remove config not needed anymore
      > linux-stable/4.19: update to 4.19.37
      > linux-stable/5.0: update to 5.0.10
      > odroid-kmeta: update fragments.
      > linux-stable/4.19: update to 4.19.36
      > linux-stable/5.0: update to 5.0.9
      > linux-stable: set audit level to 2
      > linux-stable/5.0: fixup kernel fragments
      > linux-stable/4.19: update kernel fragments
    
    * sources/meta-openembedded 7142f09407...1ecd8b4364 (32):
      > cannelloni: move from meta-oe to meta-networking
      > python-rfc3987: upgrade 1.3.7 -> 1.3.8
      > python-pyperclip: upgrade 1.6.2 -> 1.7.0
      > aufs-util: prevent native aufs-util depending on target kernel
      > libdbi-perl: prevent native libdbi-perl depending on target perl
      > efivar: prevent native efivar depending on target kernel
      > rdfind: Upgrade 1.3.4 -> 1.4.1
      > geos: Upgrade 3.4.2 -> 3.4.3
      > openvpn: update to 2.4.7
      > libvncserver: set PV in the recipe
      > jsoncpp: add native BBCLASSEXTEND
      > conntrack-tools: update to 1.4.5
      > catch2: Upgrade 2.6.1 -> 2.7.2
      > openwbem: Remove stale files of recipe removed 2 years ago
      > ode: Remove stale file of recipe removed 2 years ago
      > liboop: Upgrade 1.0 -> 1.0.1
      > inotify-tools: Upgrade 3.14 -> 3.20.1
      > daemonize: Upgrade 1.7.7 -> 1.7.8
      > ccid: Upgrade 1.4.24 -> 1.4.30
      > augeas: Upgrade 1.11.0 -> 1.12.0
      > fvwm: Upgrade 2.6.7 -> 2.6.8
      > glm: Upgrade 0.9.9.3 -> 0.9.9.5
      > openwsman: Upgrade 2.6.8 -> 2.6.9
      > libqb: Upgrade 1.0.3 -> 1.0.5
      > libcec: Upgrade 4.0.2 -> 4.0.4
      > fluentbit: Upgrade 0.12.1 -> 0.12.19
      > cloud9: Remove stale files of recipe removed 2 years ago
      > rocksdb: Upgrade 5.18.2 -> 5.18.3
      > postgresql: Upgrade 11.2 -> 11.3
      > bpftool: remove LIC_FILES_CHKSUM
      > mozjs: Make mozjs support arm32BE.
      > libnetfilter-conntrack: update to 1.0.7
    
    * sources/meta-qcom d7a873a...d5801c5 (1):
      > qcom-sdm845.inc: use arch-armv8a tune instead of arch-armv8
    
    * sources/meta-qt5 f4531ec...c7e0ba5 (2):
      > qtwebengine: arm: use OE specified -mcpu option
      > qtbase-tools: Fix error during pkg_postinst
    
    * sources/meta-riscv e3e7f75...4dd427a (1):
      > linux-mainline: Fix kernel version checks
    
    * sources/meta-ti db08a45c...49a622ef (8):
      > kselftests: enable ptp/testptp target
      > linux-ti-staging: update the RT kernel tag for ti2019.01-rc4
      > linux-ti-staging: update to ti2019.01-rc4 tag
      > u-boot-ti-staging: update to ti2019.01-rc4 tag
      > beaglebone-capes: Update checksums for LICENSE
      > gdbc6x: bump SRCREV for build fix
      > dsptop: bump SRCREV for build fix
      > arm-trusted-firmware: depend on openssl-native for signing purposes
    
    * sources/meta-variscite-fslc 1843197...cd33ae9 (2):
      > linux-variscite: Update to latest revision
      > fsl-image-gui: Remove packagegroup-fsl-tools-gpu
    
    * sources/openembedded-core 244f2e5fb5...8a6ef2044c (70):
      > ofono: upgrade 1.25 -> 1.29
      > mesa: fix imx gallium driver PACKAGECONFIG option
      > qemux86: use a Core 2 Duo CPU instead of the original circa-1993 Pentium
      > packagegroup-cross-canadian: repackage when TUNE_ARCH changes
      > systemd: Disable idn properly for musl instead of NI_IDN workarounds
      > glib-2.0: add missing libgcc dependency to glib-2.0-ptest
      > tcmode-default.inc: use the same TUNE_PKGARCH variable as PN set in go-cross
      > apr/apr-util: Add ptest dependency on libgcc
      > gettext/flex/m4/bzip2/gzip/parted/slang/attr: Add make to -ptest packages
      > musl: Add TEMP_FAILURE_RETRY from glibc
      > grub-efi-cfg, systemd-boot-cfg: use MACHINE_ARCH
      > mdadm: install the systemd service through Makefile
      > sysstat: Add PACKAGECONFIG[cron] for '--enable-install-cron' option
      > libtest-needs-perl: upgrade 0.002005 -> 0.002006
      > epiphany: Do not bypass initialization of variable with __attribute__((cleanup))
      > mmc-utils: Fix build with clang
      > dhcp: fix a NSUPDATE compiling issue
      > kernel.bbclass: adjust a condition checking
      > mesa: Convert recipe to use meson build system
      > libinput: Upgrade 1.13.1 -> 1.13.2
      > glib-2.0: fix last failing ptest
      > ptest: Add RDEPENDS frpm PN-ptest to PN package
      > dbus-test: Improve ptest dependencies dependencies
      > valgrind: fix call/cachegrind ptests
      > valgrind: adjust test filters and expected output
      > valgrind: update the ptest subdirs list
      > valgrind: Include debugging symbols in ptests
      > valgrind: fix vg_regtest return code
      > core-image-sato-sdk-ptest: Tweak size to stay within 4GB limit
      > perf: make sure that the tools/include/uapi/asm-generic directory exists
      > distutils: Tidy and simplify for readability
      > Remove irda-utils and the irda feature
      > wic/bootimg-efi: replace hardcoded volume name with label
      > packagegroup-self-hosted: drop epiphany
      > ell: update to 0.20
      > oeqa/targetcontrol.py: fix qemuparams not work in runqemu with launch_cmd
      > openssl: Remove openssl10
      > oeqa/target/ssh: Replace suggogatepass with ignoring errors
      > weston-init: Fix WESTON_USER typo
      > groff: imporve musl support
      > webkitgtk: fix compile error for arm64
      > openssh: Avoid PROVIDES warning from rng-tools dependency
      > ghostscript: 9.26 -> 9.27
      > libxml2: upgrade 2.9.8 -> 2.9.9
      > groff: upgrade 1.22.3 -> 1.22.4
      > subversion: upgrade 1.11.1 -> 1.12.0
      > gpgme: upgrade 1.12.0 -> 1.13.0
      > ncurses: fix incorrect UPSTREAM_CHECK_GITTAGREGEX
      > bash: upgrade 4.4.18 -> 5.0
      > man-db: upgrade 2.8.4 -> 2.8.5
      > man-pages: upgrade 4.16 -> 5.01
      > apr: upgrade 1.6.5 -> 1.7.0
      > base-passwd: Add kvm group
      > glib-2.0: add missing locales for the tests
      > glib-2.0: fix locale handling
      > run-postinsts: Fix full execution of scripts at first boot
      > procps: update legacy sysctl.conf to fix rp_filter sysctl issue
      > oeqa/selftest: Automate manual pybootchart tests
      > openssh: recommend rng-tools with sshd
      > lttng-modules: upgrade 2.10.8 -> 2.10.9
      > bitbake.conf: set NO_RECOMMENDATIONS with weak assignment
      > ccache: upgrade 3.6 -> 3.7.1
      > weston-init: Add support for non-root start
      > weston-init: Fix tab indentation
      > systemd: Bump up SRCREV to systemd-stable top to include the fix for shutdown now hang
      > gcc-9: Add recipes for gcc 9.1 release
      > libgfortan: Package target gcc include directory to fix
      > tcmode-default: Add PREFERRED_VERSION for libgfortran
      > oeqa/concurrenttest: Patch subunit module to handle classSetup failures
      > oeqa/runner: Fix subunit setupClass/setupModule failure handling
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 11, 2019
  1. Layer Updates: sources/meta-openembedded

    kraj committed May 11, 2019
    * sources/meta-openembedded 7832621d1c...7142f09407 (33):
      > cpupower: remove LIC_FILES_CHKSUM
      > Remove me as maintainer
      > dovecot: Upgrade 2.2.36 -> 2.2.36.3
      > pptp-linux: Upgrade 1.9.0 -> 1.10.0
      > postfix: Upgrade 3.4.1 -> 3.4.5
      > dnrd: Remove stale files of recipe removed 2 years ago
      > python-pymongo: upgrade 3.7.2 -> 3.8.0
      > python-psutil: upgrade 5.6.1 -> 5.6.2
      > python-pbr: upgrade 5.1.3 -> 5.2.0
      > python-mock: upgrade 2.0.0 -> 3.0.5
      > python-cython: upgrade 0.29.6 -> 0.29.7
      > Remove liboil
      > vlc: Remove workaround and patches for problems fixed upstream
      > schroedinger: Remove the obsolete DEPENDS on liboil
      > dvb-apps: Remove dvb-fe-xc5000c-4.1.30.7.fw
      > caps: Upgrade 0.9.24 -> 0.9.26
      > python-alembic: upgrade 1.0.9 -> 1.0.10
      > libnet-dns-perl: upgrade 1.19 -> 1.20
      > samba: update to 4.8.11
      > glade3: move to to meta-xfce
      > libxfce4ui: Add PACKAGECONFIG 'gladeui2' for glade (gtk3) support
      > xfce4-session: remove strange entry in FILES_${PN}
      > xfce4-session: get rid of machine-host
      > opensaf: update to 5.19.01
      > networkd-dispatcher: update to 2.0.1
      > libnetfilter-queue: fix update to 1.0.3
      > wv: upgrade 1.2.4 -> 1.2.9
      > sshfs-fuse: upgrade 2.8 -> 2.10
      > imagemagick: update from 7.0.8-35 to 7.0.8-43
      > doxygen: replace ninja 1.9.0 fix with official one
      > gd: set CVE_PRODUCT
      > ipsec-tools: fix CVE tag in patch
      > netkit-rsh: add tag to CVE patch
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 10, 2019
  1. Layer Updates: sources/meta-intel sources/meta-qcom

    kraj committed May 10, 2019
    * sources/meta-intel 9eb61e56...8630938e (1):
      > Revert "linux-intel-rt/4.19: update to v4.19.31"
    
    * sources/meta-qcom 70703d8...d7a873a (1):
      > machine/*/dragonbard-845c: Set ext4 rootfs image to 4096 block size
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  2. Merge pull request #173 from YoeDistro/kraj/master

    cbrake committed May 10, 2019
    Update layers
  3. Layer Updates: sources/meta-browser sources/meta-freescale sources/me…

    kraj committed May 10, 2019
    …ta-qcom sources/openembedded-core
    
    * sources/meta-browser cd88d7b...1f363e2 (1):
      > chromium: Update to 74.0.3729.131
    
    * sources/meta-freescale 4d53f874...3dc8f2fe (1):
      > imx-base: make sure sha384sum is available for all i.MX 8 variants
    
    * sources/meta-qcom 9aa3565...70703d8 (2):
      > meta-qcom: Add linux-linaro-qcomlt_5.1.bb kernel for DB845c
      > conf/machine: Add initial machine definitions for db845c
    
    * sources/openembedded-core 728c6c43de...244f2e5fb5 (17):
      > icu: Added armeb support.
      > systemd: move "machines" symlinks to systemd-container
      > systemd: Use PACKAGECONFIG definition to depend on libnss-myhostname
      > shadow: Backport last change reproducibility
      > uboot-sign: Fix u-boot-nodtb symlinks
      > patch: add minver and maxver parameters
      > gdb: Fix aarch64 build with musl
      > perl: update to 5.28.2
      > meson: update to 0.50.1
      > oeqa/sdk: use bash to execute SDK test commands
      > systemd: Restore mask and preset targets, fix instance creation
      > systemd-systemctl: Restore support for enable command
      > systemd: Default to non-stateless images
      > sysstat: inherit upstream-version-is-even
      > oeqa/core/runner: Handle unexpectedSucesses
      > meta/lib+scripts: Convert to SPDX license headers
      > oeqa: Drop OETestID
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 9, 2019
  1. Layer Updates: sources/meta-freescale sources/meta-ti sources/openemb…

    kraj committed May 9, 2019
    …edded-core
    
    * sources/meta-freescale a2f54239...4d53f874 (1):
      > utilities.inc: split by any number of whitespaces
    
    * sources/meta-ti 29219faf...db08a45c (7):
      > arm-trusted-firmare: sign ATF image for am65xx HS
      > recipes: convert existing uses of am65xx-evm to am65xx SOC family
      > conf/machine: introduce am65xx SOC family and new am65xx-hs-evm
      > arm-trusted-firmware: update to ti2019.01-rc3 tag
      > linux-ti-staging: update to ti2019.01-rc3 tag
      > u-boot-ti-staging: update to ti2019.01-rc3 tag
      > ti-sgx-ddk-km: bump SRCREV to pick up toolchain enhancement
    
    * sources/openembedded-core 07bc5a5367...728c6c43de (24):
      > coreutils: Fix patch upstream status field
      > target-sdk-provides-dummy: resolve sstate conflict
      > python3: fix do_install fail for parallel buiild
      > systemd: Backport patch to fix build with gcc9
      > bitbake.conf: use https instead of http
      > wpa-supplicant: update to 2.8
      > msmtp: update to 1.8.4
      > mtools: update to 4.0.23
      > coreutils: update to 8.31
      > kmscube: update to latest revision
      > sqlite3: update to 3.28.0
      > libxcb: remove workaround patch for a bug that was fixed in gcc 5 in 2015
      > cogl: remove -Werror=maybe-uninitialized workaround
      > cogl: upgrade 1.22.2 -> 1.22.4
      > mmc-utils: update to the latest upstream code
      > resulttool: Add option to dump all ptest logs
      > bison: upgrade 3.0.4 -> 3.1
      > socat: upgrade 1.7.3.2 -> 1.7.3.3
      > grub: Use -Wno-error instead of doing this on a per-warning basis
      > gnu-efi: Remove support patch for gcc < 4.7
      > scripts/pybootchart/draw: Fix some bounding problems
      > scripts/pybootchart/draw: Clarify some variable names
      > scripts/pybootchart: Port to python3
      > scripts/pybootchart: Fix mixed indentation
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  2. Merge pull request #172 from YoeDistro/kraj/master

    cbrake committed May 9, 2019
    Layer Updates:  sources/meta-intel sources/openembedded-core
Commits on May 8, 2019
  1. Layer Updates: sources/meta-intel sources/openembedded-core

    kraj committed May 8, 2019
    * sources/meta-intel 40225d8c...9eb61e56 (1):
      > linux-intel-rt/4.19: update to v4.19.31
    
    * sources/openembedded-core 078950f6ff...07bc5a5367 (17):
      > openssh/systemd/python/qemu: Fix patch Upstream-Status
      > acpica: use update-alternatives for acpidump
      > squashfs-tools: set CVE_PRODUCT
      > flac: also add flac to CVE_PRODUCT
      > systemd: Add -Wno-error=format-overflow to fix build with gcc9
      > gcc-target: Do not set --with-sysroot and gxx-include-dir paths
      > cml1.bbclass: fix undefined behavior
      > distutils: Run python from the PATH in the -native case as well
      > recipetool: fix unbound variable when fixed SRCREV can't be found
      > go: Exclude vcs files when installing deps
      > python3: Add ntpath.py to python core
      > patchelf: Upgrade 0.9 -> 0.10
      > cpio/tar/native.bbclass: move rmt to sbindir and add a prefix to avoid native clashing
      > ghostscript: set CVE_PRODUCT
      > file: Stop adding -std=c99 to CFLAGS
      > libxcrypt: Stop adding -std=gnu99 to CPPFLAGS
      > nss: cleanup recipe to match OE style
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 7, 2019
  1. Merge pull request #171 from YoeDistro/kraj/master

    cbrake committed May 7, 2019
    Layer Updates:  sources/bitbake sources/meta-freescale sources/meta-i…
  2. Layer Updates: sources/bitbake sources/meta-freescale sources/meta-in…

    kraj committed May 7, 2019
    …tel sources/meta-openembedded sources/meta-riscv sources/meta-ti sources/openembedded-core
    
    * sources/bitbake 93e94c06...9b4a9e54 (4):
      > HEADER: Drop it
      > bitbake: Strip old editor directives from file headers
      > bitbake: Drop duplicate license boilerplace text
      > bitbake: Add initial pass of SPDX license headers to source code
    
    * sources/meta-freescale 02eb08c1...a2f54239 (5):
      > qtwayland: drop xcomposite-egl, xcomposite-glx packageconfig for mx8
      > imx8mmevk.conf, imx8mqevk.conf: drop adding m4 demos do the boot partition
      > imx8qmmek: fix files in the boot partition
      > libdrm: prevent warning on mx8
      > imx-base: make gstreamer1.0 packages socarch specific for all imx soc
    
    * sources/meta-intel b412c960...40225d8c (5):
      > intel-mediasdk: upgrade 18.4.1 -> 19.1.0
      > gmmlib: upgrade 18.4.1 -> 19.1.2
      > intel-media-driver: upgrade 18.4.1 -> 19.1.0
      > conf: use zlib-intel by default for target builds
      > zlib-intel: add zlib fork with IA-specific optimisations
    
    * sources/meta-openembedded 50108c18e5...7832621d1c (53):
      > ebtables: add UPSTREAM_CHECK_URI
      > ypbind-mt: update to 2.6
      > mongodb: Fix build with gcc
      > xfce4-terminal: add vte-prompt to RRECOMMENDS
      > libwnck3: upgrade 3.30.0 and move to meson build
      > desktop-file-utils: remove - a more recent version is in oe-core
      > xfce4-notifyd: upgrade 0.4.3 -> 0.4.4
      > xfce4-datetime-plugin: upgrade 0.7.0 -> 0.7.1
      > xfce4-places-plugin: upgrade 1.7.0 -> 1.8.0
      > exo: upgrade 0.12.4 -> 0.12.5
      > fontforge: upgrade 20170731 -> 20190413
      > itstool: rework - it went out too early
      > gtksourceview-classic-light: extend to gtksourceview4
      > gtksourceview4: initial add 4.2.0
      > meta-xfce: add meta-networking to layer depends
      > packagegroup-meta-networking: replace DISTRO_FEATURE by DISTRO_FEATURES
      > xfce4-cpufreq-plugin: Fix memory leak and reduce CPU load
      > pmtools: use update-alternatives for acpidump
      > php: correct httpd path
      > evince: add patch to fix build with recent gobject-introspection
      > efivars: Drop workaround patch for host gcc < 4.7
      > arno-iptables-firewall: update to 2.0.3
      > ser2net: upgrade to version 3.5.1
      > vlc: rework qt PACKAGECONFIG
      > cannelloni: new package, CAN to ethernet proxy
      > libnfc: Initial recipe for Near Field Communication library.
      > bdwgc: upgrade 7.6.12 -> 8.0.4
      > meta-filesystems: drop bitbake from README
      > python-requests: Set CVE_PRODUCT
      > python3-pillow: Set CVE_PRODUCT
      > python-urllib3: Set CVE_PRODUCT
      > python3-raven: add version 6.10.0
      > python3-sentry-sdk: add version 0.7.14
      > libcdio: update to version 2.1.0
      > python3-tinyrecord: add version 0.1.5
      > python3-websocket-client: add version 0.56.0
      > python3-supervisor: add version 4.0.2
      > python3-aiohttp: add version 3.5.4
      > libmodbus: add documentation PACKAGECONFIG
      > cpupower: Inherit bash completion class
      > zbar: fix SRC_URI for multilib
      > miniupnpd: fix SRC_URI for multilib
      > opusfile: fix SRC_URI for multilib
      > esound: fix SRC_URI for multilib
      > gnome-desktop3: set correct meson gtk doc option
      > xfce4-vala: auto-detect vala api version
      > phpmyadmin: upgrade 4.8.3 -> 4.8.5
      > openhpi: update openhpi-fix-testfail-errors.patch
      > postgresql: fix compile error
      > php: upgrade 7.3.2 -> 7.3.4
      > python-pyasn1: upgrade 0.4.4 -> 0.4.5
      > samba: add PACKAGECONFIG for libunwind
      > python-pip: upgrade 18.0 -> 19.1
    
    * sources/meta-riscv 9e78155...e3e7f75 (2):
      > linux: Update to 5.1 stable
      > u-boot: Check if ${UBOOT_ENV}.txt exists before using it
    
    * sources/meta-ti 484c2d0d...29219faf (1):
      > ti-sgx-ddk-um: bump SRCREV to pick up wsegl fix
    
    * sources/openembedded-core e79f0db074...078950f6ff (13):
      > gtk-icon-cache: clean up DEPENDS
      > license_image: Use new oe.path.copyhardlink() helper
      > oe.path: Add copyhardlink() helper function
      > mdadm: Disable Werror
      > wic: add global debug option
      > wic: change expand behaviour to match docs
      > ell: add recipe
      > packagegroup-core-full-cmdline: remove zlib
      > libsolv: update to 0.7.4
      > xorg-lib: drop native overrides for REQUIRED_DISTRO_FEATURES
      > m4: update patch status
      > initrdscripts: merge multiple "mkdir" calls
      > useradd-staticids: print exception after parse_args() error
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 3, 2019
  1. Merge pull request #170 from YoeDistro/kraj/master

    cbrake committed May 3, 2019
    Layer Updates:  sources/meta-browser sources/meta-intel sources/meta-…
  2. Layer Updates: sources/meta-browser sources/meta-intel sources/meta-q…

    kraj committed May 3, 2019
    …t5 sources/openembedded-core
    
    * sources/meta-browser 164e929...cd88d7b (1):
      > chromium-ozone-wayland: Stop depending on the system's wayland-scanner binary
    
    * sources/meta-intel 7573548c...b412c960 (2):
      > README: update for warrior release requirements
      > linux-yocto-rt/5.0: add bbappend
    
    * sources/meta-qt5 8586caf...f4531ec (1):
      > qtwebengine: restore the fix for build with clang/libc++ on aarch64/arm
    
    * sources/openembedded-core 17e8751037...e79f0db074 (17):
      > uboot-sign: Fix build when UBOOT_DTB_BINARY is empty
      > opkg: fix ptest packaging when OPKGLIBDIR == libdir
      > image: call systemctl preset-all for images
      > systemctl-native: Rewrite in Python supporting preset-all and mask
      > systemd: create preset files instead of installing in image
      > systemd-conf: simplify creation of machine-specific configuration
      > systemd: do not create machine-id
      > systemd: don't build firstboot by default
      > populate_sdk_base: provide options to set sdk type
      > dbus: fix ptest failure
      > qemu: Upgrade from 3.1.0 to 4.0.0
      > bitbake.conf: Account for older versions of bitbake
      > elfutils: Fix ptest compile failures on musl
      > elfutils: ptest fixes
      > mpg123: port to use libsdl2
      > vim: Update to 8.1.1240
      > vim: Rework to not rely on relative directories
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 2, 2019
  1. Merge pull request #169 from YoeDistro/kraj/master

    cbrake committed May 2, 2019
    Layer Updates:  sources/bitbake sources/meta-openembedded sources/met…
  2. gitmodules: Do not sue shallow clones by default

    kraj committed May 2, 2019
    Command "git submodule update --init --recursive --remote sources/bitbake" returned status code 1:
    
    stderr: fatal: Needed a single revision
    Unable to find current origin/yoe/mut revision in submodule path 'sources/bitbake'
    
    CI loop fails occasionally with such errors
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  3. Layer Updates: sources/bitbake sources/meta-openembedded sources/meta…

    kraj committed May 2, 2019
    …-ti sources/openembedded-core
    
    * sources/bitbake 3f2c2eb2...93e94c06 (8):
      > build: Disable warning about dependent tasks for now
      > build: Ensure warning for invalid task dependencies is useful
      > knotty: Implement console 'keepalive' output
      > knotty: Pretty print task elapsed time
      > build: Add verbnote to shell log commands
      > tests/parse.py: Add testcase for addtask and deltask
      > build.py: check dependendent task for addtask
      > BBHandler: Fix addtask and deltask
    
    * sources/meta-openembedded d42cce95a8...50108c18e5 (57):
      > libdbd-mysql-perl: Upgrade to 4.050
      > libnetfilter-queue: update to 1.0.3
      > cpprest: update to 2.10.13, drop 32bit build fix upstream
      > v4l-utils: upgrade 1.16.0 -> 1.16.5
      > libdev-checklib-perl: add new recipe
      > rrdtool: Upgrade to 1.7.1
      > libopus: use armv7a, aarch64 overrides when adding ne10 dependency
      > apache2: add back patch for set perlbin
      > nftables: add UPSTREAM_CHECK_URI
      > nfacct: add UPSTREAM_CHECK_URI
      > nuttcp: update to 8.2.2
      > traceroute: add UPSTREAM_CHECK_URI
      > vblade: add UPSTREAM_CHECK_URI
      > uftp: update to 4.9.9
      > wpan-tools: update to 0.9
      > networkmanager-openvpn: update to 1.8.10
      > ne10: set NE10_TARGET_ARCH with an override instead of anonymous python
      > ledmon: Mark as incompatible on musl instead of adding bogus patch
      > Revert "ell: remove recipe"
      > ntp: upgrade 4.2.8p12 -> 4.2.8p13
      > python-decorator: upgrade 4.3.0 -> 4.4.0
      > python-zopeinterface: upgrade 4.5.0 -> 4.6.0
      > python-twisted: upgrade 18.4.0 -> 19.2.0
      > python-hyperlink: upgrade 18.0.0 -> 19.0.0
      > python-cffi: upgrade 1.12.2 -> 1.12.3
      > python-alembic: upgrade 1.0.0 -> 1.0.9
      > hwdata: Upgrade to 0.322
      > hostapd: Upgrade to 2.8
      > nano: update to 4.1
      > indent: Upgrade to 2.2.12
      > fluidsynth: upgrade 2.0.4 -> 2.0.5
      > nghttp2: update to 1.38
      > python-lxml: upgrade 4.3.1 -> 4.3.3
      > python-jinja2: upgrade 2.10 -> 2.10.1
      > python-editor: upgrade 1.0.3 -> 1.0.4
      > python-cython: upgrade 0.28.5 -> 0.29.6
      > apache2: Correct packaging of build and doc related files
      > apache2: Correct appending to SYSROOT_PREPROCESS_FUNCS
      > openbox: Add python-shell as a runtime dependency
      > squid: Link with libatomic on mips/ppc
      > python-pbr: upgrade 4.2.0 -> 5.1.3
      > samba: rework localstatedir package split
      > samba: install bundled libs into seperate packages
      > fltk: upgrade 1.3.4-2 -> 1.3.5
      > xfconf: fix 'Failed to get connection to xfconfd' during do_rootfs
      > python-stevedore: upgrade 1.29.0 -> 1.30.1
      > python-pytz: upgrade 2018.5 -> 2019.1
      > python-pyopenssl: upgrade 18.0.0 -> 19.0.0
      > openhpi: fix failure of ptest case ohpi_035
      > python-pymongo: upgrade 3.7.1 -> 3.7.2
      > python-py: upgrade 1.6.0 -> 1.8.0
      > drbd-utils: fix file conflict with base-files
      > drbd: fix compile errors
      > python-psutil: upgrade 5.4.6 -> 5.6.1
      > python-paste: upgrade 3.0.6 -> 3.0.8
      > python-msgpack: upgrade 0.6.0 -> 0.6.1
      > python-mako: upgrade 1.0.7 -> 1.0.9
    
    * sources/meta-ti f218dd2a...484c2d0d (6):
      > am65xx-evm: workaround for YOCTO #13280 bug
      > linux-ti-staging: update to ti2019.01-rc2 tag
      > u-boot-ti-staging: update to ti2019.01-rc2 tag
      > gdbc6x: update with gcc8 warning suppression
      > prueth-fw-bin: update 5.1.0.7 -> 5.3.0.5
      > ti-cgt-arm-native: Upgrade to 18.12.1.LTS
    
    * sources/openembedded-core ecba50f871...17e8751037 (17):
      > oeqa/ssh: Avoid unicode decode exceptions
      > qemux86: Allow higher tunes
      > qemu: split out vte into seperate PACKAGECONFIG
      > maintainers.inc: take over as perl maintainer
      > python3-pycairo: update to 1.18.1
      > linux-yocto/5.0: update TCP patch to mainline version
      > staging: add ${datadir}/gtk-doc/html to the sysroot blacklist
      > nettle: fix ptest failure
      > nettle: fix the Segmentation fault
      > libsdl: set CVE_PRODUCT
      > piglit: support build piglit without x11
      > waffle: supprt build waffle without x11
      > dropbear: set CVE_PRODUCT
      > openssh: fix CVE-2018-20685, CVE-2019-6109, CVE-2019-6111
      > binutils: fix CVE-2019-9074 CVE-2019-9075 CVE-2019-9076 CVE-2019-9077
      > gdb: fix CVE-2017-9778
      > gcc: fix CVE-2018-18484
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 29, 2019
  1. Merge pull request #168 from YoeDistro/kraj/master

    cbrake committed Apr 29, 2019
    Layer Updates:  sources/bitbake sources/meta-96boards sources/meta-fr…
  2. Layer Updates: sources/bitbake sources/meta-96boards sources/meta-fre…

    kraj committed Apr 29, 2019
    …escale sources/meta-intel sources/meta-odroid sources/meta-qt5 sources/meta-raspberrypi sources/meta-riscv sources/meta-rust sources/meta-ti sources/meta-variscite-fslc sources/openembedded-core
    
    * sources/bitbake 3aaf8d65...3f2c2eb2 (6):
      > bitbake: fetch2/git: git-lfs check
      > bb: siggen: Print more info when basehash are mis-matched
      > bb: siggen: Make dump_sigfile and compare_sigfiles print uuid4
      > bitbake-diffsigs: Use 4 spaces as indent for recursecb
      > toaster: update to Warrior
      > bitbake-user-manual: Added section on modifying variables
    
    * sources/meta-96boards caa9db4...863a1e3 (1):
      > Merge pull request #309 from petegriffin/hikey-mesa-lima-pull
    
    * sources/meta-freescale 6977a56d...02eb08c1 (1):
      > imx-imx-boot-bootpart.wks.in: increase boot partition to 64m
    
    * sources/meta-intel ed44056d...7573548c (3):
      > mkl-dnn: upgrade 0.17.4 -> 0.18.1
      > mkl-dnn: fix upstream release checking
      > ixgbevf: 4.5.2 -> 4.5.3
    
    * sources/meta-odroid b8fde89...03ee6ff (6):
      > fix xml:
      > testing travis builds:
      > Merge branch 'master' of github.com:akuster/meta-odroid
      > armv8.inc: remove local copy
      > amlogic-meson64: use upstream armv8a.inc
      > linux-stable/5.0: update to 5.0.6
    
    * sources/meta-qt5 eb5d6da...8586caf (4):
      > qt5: update SRCREVs after v5.12.3 tags were downmerged to 5.12 branch
      > qtwayland: check also that the destination for private headers exists before installing them
      > qtwayland: improve manual header installation
      > qtwayland: workaround upstream bug: install missing headers manually
    
    * sources/meta-raspberrypi 8eeb579...7059c37 (4):
      > psplash: Raise alternatives priority to 200
      > linux-raspberrypi 4.9: Drop old version
      > linux-raspberrypi: Switch default back to 4.14.y
      > linux-raspberrypi: Update 4.14.y kernel
    
    * sources/meta-riscv b9e9d69...9e78155 (5):
      > freedom-u540: Setup u-boot autoboot for TFTP
      > freedom-u540: Allow u-boot to be an OpenSBI payload
      > u-boot: Add support for SMP boot on Freedom U540
      > opensbi: Fix the u-boot dependency
      > wic: Update the sdcard generation
    
    * sources/meta-rust 0d03c20...84710b3 (1):
      > Merge pull request #239 from agherzan/ag/patchfix
    
    * sources/meta-ti 90949a4c...f218dd2a (7):
      > ti-ndk: Upgrade to 3.60.00.13
      > ti-ns: Upgrade to 2.60.00.07
      > ti-ipc-rtos: add SRCREV_FORMAT
      > linux-ti-staging: update to ti2019.01-rc1 tag
      > u-boot-ti-staging: update to ti2019.01-rc1 tag
      > ti-pdk-build-rtos: SRCREV bump to use COPYING.txt for license checksum
      > prueth-fw: use icss-emac-lld sources
    
    * sources/meta-variscite-fslc 5c19ac6...1843197 (2):
      > linux-firmware: Upgrade bcm43xx WIFI/BT firmware
      > alsa-tools: Remove incompatible features
    
    * sources/openembedded-core 879b590fe8...ecba50f871 (95):
      > ptest-packagelists: Add m4 and gettext as 'fast' ptests
      > python3: Drop ptest hack
      > systemd: add cgroupv2 PACKAGECONFIG
      > gnome-doc-utils: Remove stale patch
      > linux-yocto_5.0: set devicetree for armv5
      > linux-yocto/5.0: integrate TCP timeout / hang fix
      > linux-yocto/5.0: port RAID configuration tweaks from master
      > linux-yocto-rt/4.19: fix merge conflict in lru_drain
      > bitbake.conf: add git-lfs to HOSTTOOLS_NONFATAL
      > Adding back wrapper and using OEPYTHON3HOME variable for python3
      > libsoup: Upgrade from 2.64.2 to 2.66.1
      > gettext: add ptest support
      > manual compliance: remove bits done at runtime
      > ltp_compliance: add new runtime
      > logparser: Add LTP compliance section
      > resulttool: add LTP compliance section
      > ltp: add runtime test
      > logparser: Add decoding ltp logs
      > resulttool: add ltp test support
      > utils/multiprocess_launch: Improve failing subprocess output
      > vte: move shell auto scripts into seperate package
      > kernel-module-split.bbclass: support CONFIG_MODULE_COMPRESS=y
      > systemd: upgrade to 242
      > glibc: always use bfd linker
      > resulttool/manualexecution: Enable test case configuration option
      > webkitgtk: Fix build with clang
      > Revert "wic: Set a miniumum FAT16 volume size."
      > icu: Upgrade 64.1 -> 64.2
      > wget: update to 1.20.3
      > python3-pygobject: update to 3.32.1
      > python-numpy: update to 1.16.3
      > vte: upgrade 0.52.2 -> 0.56.1
      > core-image-rt-sdk: make sure that we append to DEPENDS
      > core-image-rt: make sure that we append to DEPENDS
      > oeqa/core/runner: dump stdout and stderr of each test case
      > webkitgtk: set CVE_PRODUCT
      > cryptodev: fix module loading error
      > dnf: Enable nativesdk
      > mesa: Update 19.0.1 -> 19.0.3
      > Use the best xz compression for the SDK
      > lttng-tools: Add missing patch Upstream-Status
      > ninja: add Upstream-Status and SOB for musl patch
      > resultool/resultutils: Fix module import error
      > gtk-doc.bbclass: unify option setting for meson-based recipes
      > icecc.bbclass: stop causing everything to be effectivelly MACHINE_ARCH
      > buildhistory: call a dependency parser only on actual dependency lists
      > resulttool: Add log subcommand
      > resulttool: Load results from URL
      > m4: add ptest support
      > python3-pip: update to 19.0.3
      > python3-pbr: update to 5.1.3
      > python3-mako: update to 1.0.9
      > python-setuptools: update to 41.0.1
      > python-scons: update to 3.0.5
      > msmtp: fix upstream version check
      > acpica: update to 20190405
      > acpica: upgrade to 20190215
      > meson: add missing Upstream-Status and SOB to a patch
      > lttng-tools: fix Upstream-Status
      > base-files: move hostname operations out of issue file settings
      > connman: add PACKAGECONFIG for nfc, fix MACHINE_ARCH signature when l2tp is enabled
      > classes/waf: Set WAFLOCK
      > busybox: fix ptest failure about 'dc'
      > python3-pygobject: update to 3.32.0
      > meson: do not try to substitute the prefix in python supplied paths
      > python3: add another multilib fix
      > epiphany: update to 3.32.1.2
      > icu: update to 64.1
      > ltp: Fix setrlimit03 call succeeded unexpectedly
      > libcap: update to 2.27
      > pixman: update to 0.38.4
      > kernel.bbclass: convert base_do_unpack_append() to a task
      > valgrind: update from 3.14.0 to 3.15.0
      > qemu: Add PACKAGECONFIG for snappy
      > cups: update to 2.2.11
      > u-boot: Fix missing Python.h build failure
      > help2man-native: update to 1.47.10
      > orc: update to 0.4.29
      > lz4: update to 1.9.0
      > gnupg: update to 2.2.15
      > quota: update to 4.05
      > git: update to 2.21.0
      > libpsl: update to 0.21.0
      > libcroco: update to 0.6.13
      > libpng: update to 1.6.37
      > libnotify: update to 0.7.8
      > libinput: update to 1.13.1
      > libdrm: update to 2.4.98
      > gcc-sanitizers: fix -Werror=maybe-uninitialized issue
      > systemd: change default locale from C.UTF-8 to C
      > core-image-sato-sdk-ptest: Add temporary PROVIDES core-image-sato-ptest
      > core-image-sato-sdk-ptest: Include more ptests in ptest image
      > core-image-sato-ptest-fast: Add 'fast' ptest execution image
      > elfutils: fix build failure with musl
      > elfutils: add ptest support
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 22, 2019
  1. Merge pull request #167 from YoeDistro/kraj/master

    cbrake committed Apr 22, 2019
    Layer Updates:  sources/meta-96boards sources/meta-browser sources/me…
Commits on Apr 20, 2019
  1. Layer Updates: sources/meta-96boards sources/meta-browser sources/met…

    kraj committed Apr 20, 2019
    …a-freescale sources/meta-freescale-3rdparty sources/meta-intel sources/meta-openembedded sources/meta-qt5 sources/meta-raspberrypi sources/meta-riscv sources/meta-ti sources/meta-variscite-fslc
    
    * sources/meta-96boards 2414a75...caa9db4 (1):
      > Merge pull request #305 from mrchapp/d/rm-cpupower
    
    * sources/meta-browser 2848153...164e929 (1):
      > chromium-ozone-wayland: Fix regression with VizDisplayCompositor
    
    * sources/meta-freescale 0ef9809c...6977a56d (12):
      > linux-fslc: Bump revision to c7a0e482a175
      > u-boot-fslc-common: Bump revision to c93ced78dbc
      > imx-base.inc: Use UBOOT_SUFFIX in UBOOT_BINARY variable
      > ls1088ardb-be: remove machine config
      > ls2088ardb-be:remove machine config
      > ls1043ardb-be: remove machine config
      > ls1046ardb-be: remove machine config
      > ls1046ardb-32b: remove machine config
      > ls1043ardb-32b: remove machine config
      > ls1012ardb-32b: remove machine config
      > ls1012afrwy-32b: remove machine config
      > qca-tools: Limit to arm/arm64 hosts alone
    
    * sources/meta-freescale-3rdparty 55356fd...40a05f3 (2):
      > imx6ul-pico: Add support to PICO-DWARF baseboard
      > imx7d-pico: Add support to PICO-DWARF baseboard
    
    * sources/meta-intel cd2c3bfc...ed44056d (2):
      > linux-intel-rt/4.14: update to v4.14.106
      > linux-intel/4.19: update to v4.19.34
    
    * sources/meta-openembedded 0477c76116...d42cce95a8 (29):
      > sip: Update to 4.19.16.
      > s-suite: push SRCREV to version 3.2
      > linux-atm: Replace bogus on_exit removal with musl-specific hack
      > linux-atm: Remove DEPENDS on virtual/kernel and PACKAGE_ARCH
      > python-pycodestyle: Fix conflict error with python3-pycodestyle during do_rootfs
      > thrift: update to 0.12.0
      > paho-mqtt-c: 1.2.1 -> 1.3.0
      > python-obd: Add missing RDEPENDS
      > netkit-rsh: security fixes
      > gvfs: remove systemd user unit executable permission adjustment
      > gvfs: fix typo libexec
      > mycroft: Bump from 19.2.2 to 19.2.3
      > mycroft: Update the systemd service to ensure we are ready to start
      > To fix confilict error with python3-pbr.
      > apache-websocket: upgrade to latest git rev
      > apache2: upgrade 2.4.34 -> 2.4.39
      > gpm: Recipe cleanup
      > gpm: Remove duplicate definition of _GNU_SOURCE
      > gpm: Generate documentation
      > gpm: Add PID file to systemd unit file
      > gpm: Fix gpm path in unit file
      > redis: Upgrade to 4.0.14
      > libforms: add x11 to required DISTRO_FEATURES because of libx11
      > ftgl: add x11 to required DISTRO_FEATURES like freeglut
      > python-dateutil: upgrade 2.7.3 -> 2.8.0
      > python-beabutifulsoup4: upgrade 4.6.0 -> 4.7.1
      > python-certifi: upgrade 2018.8.13 -> 2019.3.9
      > python-attrs: upgrade 18.1.0 -> 19.1.0
      > python-cffi: upgrade 1.11.5 -> 1.12.2
    
    * sources/meta-qt5 a4bf240...eb5d6da (6):
      > qtwayland: disable gold for all archs like in qtbase
      > qt5: upgrade to 5.12.3
      > qtbase: disable gold for all archs not just x86
      > qtbase-native: use QT_CONFIG_FLAGS variable like qtbase and nativesdk-qtbase
      > qtbase: Fix build with recent oe-core/pseudo on hosts with glibc >= 2.28
      > qtbase, qtmultimedia: refresh patches to apply cleanly and update them on github.com/meta-qt5 forks
    
    * sources/meta-raspberrypi 6745beb...8eeb579 (3):
      > userland: use default PACKAGE_ARCH
      > bluez5: apply the same patches and pi-bluetooth dependency for all rpi MACHINEs
      > qtbase_%.bbappend: update PACKAGECONFIG name for xkbcommon
    
    * sources/meta-riscv d77546d...b9e9d69 (3):
      > linux-mainline: Use the new 32-bit defconfig in Linux 5.1
      > linux-mainline: Fix the 32-bit boot
      > freedom-u540: Don't hardcode linux-version
    
    * sources/meta-ti f885d787...90949a4c (3):
      > am65xx-evm: add additional DTBOs
      > dra7xx-evm: add additional DTBs
      > linux-ti-staging: update to 4.19.31
    
    * sources/meta-variscite-fslc 01a67ec...5c19ac6 (2):
      > linux-variscite: Update to Variscite imx_4.14.78_1.0.0_ga_var01 release
      > u-boot: Update to latest revision
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 17, 2019
  1. Merge pull request #166 from YoeDistro/kraj/master

    cbrake committed Apr 17, 2019
    Layer Updates:  sources/meta-freescale sources/meta-raspberrypi sourc…
  2. Layer Updates: sources/meta-freescale sources/meta-raspberrypi source…

    kraj committed Apr 17, 2019
    …s/openembedded-core
    
    * sources/meta-freescale f07fbd00...0ef9809c (1):
      > wic: Fix image generation for i.MX with bootpart script
    
    * sources/meta-raspberrypi 9ceb84e...6745beb (1):
      > linux_raspberrypi_4.19: Update to 4.19.34
    
    * sources/openembedded-core 303ac64b89...879b590fe8 (34):
      > core-image-sato-sdk-ptest: Try and keep image below 4GB limit
      > libyaml: update SRC_URI[md5sum] and SRC_URI[sha256sum]
      > python-numpy: update to 1.16.2
      > python: update to 3.7.3
      > python: update to 2.7.16
      > ffmpeg: update to 4.1.3
      > at-spi2-core: fix meson 0.50 build
      > libmodulemd: update to 2.2.3
      > meson: update to 0.50.0
      > btrfs-tools: upgrade 4.20.1 -> 4.20.2
      > dnf: upgrade 4.1.0 -> 4.2.2
      > libcomps: upgrade 0.1.10 -> 0.1.11
      > libdnf: update to 0.28.1
      > vala: update to 0.44.3
      > libdazzle: update to 3.32.1
      > webkitgtk: update to 2.24.0
      > dtc: upgrade 1.4.7 -> 1.5.0
      > gobject-introspection: update to 1.60.1
      > msmtp: 1.6.6 -> 1.8.3
      > linux-yocto/4.19: update to v4.19.34
      > linux-yocto/5.0: update to v5.0.7
      > linux-yocto-rt: update to 5.0.5-rt3
      > linux-yocto/5.0: update to v5.0.5
      > musl: Upgrade to master past 1.1.22
      > gcc: Remove Java support variables
      > Set XZ_COMPRESSION_LEVEL to -9
      > grub-efi-native: Install grub-editenv
      > iptables: upgrade 1.6.2 -> 1.8.2
      > ptest.bbclass: Use d.getVar instead of os.environ
      > dhcp: Replace OE specific patch for compatibility with latest bind with upstream patch
      > harfbuzz: update source checksums after upstream replaced the tarball
      > uboot-sign: add support for different u-boot configurations
      > iw: upgrade 4.14 -> 5.0.1
      > gnutls: upgrade 3.6.5 -> 3.6.7
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 15, 2019
  1. make SAMBA scripts a little more consistent

    cbrake authored and kraj committed Apr 15, 2019
Commits on Apr 14, 2019
  1. Merge pull request #164 from YoeDistro/kraj/master

    cbrake committed Apr 14, 2019
    Layer Updates:  sources/bitbake sources/meta-freescale-3rdparty sourc…
  2. Layer Updates: sources/meta-odroid

    kraj committed Apr 14, 2019
    * sources/meta-odroid 890aeed...b8fde89 (3):
      > wayland: Keep wayland-egl.pc when using mali
      > odroid-arm-defaults: update u-boot default to 2019.04
      > u-boot: update to work with 2019.04
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 12, 2019
  1. Layer Updates: sources/bitbake sources/meta-freescale-3rdparty source…

    kraj committed Apr 12, 2019
    …s/meta-odroid sources/meta-openembedded sources/openembedded-core
    
    * sources/bitbake aae15f3c...3aaf8d65 (1):
      > poky.ent: Removed "ECLIPSE" entity variables.
    
    * sources/meta-freescale-3rdparty a38e633...55356fd (1):
      > imx7s-warp: Update settings to use U-Boot 2019.04
    
    * sources/meta-odroid c96d4dd...890aeed (3):
      > armv8.inc: remove local copy
      > amlogic-meson64: use upstream armv8a.inc
      > linux-stable/5.0: update to 5.0.6
    
    * sources/meta-openembedded 4a9deabbc8...0477c76116 (37):
      > multipath-tools: fix up patch to avoid segfault
      > lua: upgrade from v5.3.4 to v5.3.5
      > networkmanager: rework musl build
      > fatresize_1.0.2.bb: Add recipe for fatresize command line tool
      > wireshark: upgrade 3.0.0 -> 3.0.1
      > chrony: update to 3.4
      > ledmon: control hard disk led for RAID arrays
      > squid: upgrade squid 3.5.28 -> 4.6
      > xbitmaps: upgrade 1.1.1 -> 1.1.2
      > xstdcmap: upgrade 1.0.3 -> 1.0.4
      > xsetroot: upgrade 1.1.1 -> 1.1.2
      > xrefresh: upgrade 1.0.5 -> 1.0.6
      > xrdb: upgrade 1.1.1 -> 1.2.0
      > xlsatoms: upgrade 1.1.2 -> 1.1.3
      > python-flask-socketio: move to meta-python directory
      > ristretto: upgrade 0.8.3 -> 0.8.4
      > parole: upgrade 1.0.1 -> 1.0.2
      > udisks2: upgrade 2.8.1 -> 2.8.2
      > analyze-suspend: update to 5.3
      > ell: remove recipe
      > wolfssl: update to 4.0.0
      > macchanger: update to 1.7.0
      > python-cryptography: Move linker flag to .inc
      > gd: fix compile error caused by -Werror=maybe-uninitialized
      > gvfs: remove executable permission from systemd user services
      > drbd: update to 9.0.17-1
      > drbd-utils: update to 9.8.0
      > babeld: update to 1.8.4
      > stunnel: update to 5.51
      > nanomsg: update to 1.1.5
      > open-isns: update to 0.99
      > usbredir: update to 0.8.0
      > keepalived: update to 2.0.15
      > cifs-utils: update to 6.9
      > fwknop: update to 2.6.10
      > phytool: update to v2
      > smcroute: update to 2.4.4
    
    * sources/openembedded-core 68bcd9790d...303ac64b89 (1):
      > Revert "nettle: fix ptest failure"
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  2. Merge pull request #163 from YoeDistro/kraj/master

    cbrake committed Apr 12, 2019
    Layer Updates:  sources/bitbake sources/meta-freescale sources/meta-i…
Older
You can’t perform that action at this time.