Skip to content
Permalink
Branch: master
Commits on Jun 17, 2019
  1. Layer Updates: sources/meta-browser sources/meta-freescale sources/me…

    kraj committed Jun 17, 2019
    …ta-openembedded sources/meta-ti sources/openembedded-core
    
    * sources/meta-browser 7061c14...e7dbbbb (2):
      > chromium: Forward port musl patches
      > chromium: Update to 75.0.3770.90.
    
    * sources/meta-freescale a3d38477...e7684e51 (1):
      > qca-modules: Mark arm/aarch64 specific
    
    * sources/meta-openembedded 866daa14e3...3b245e4fe8 (83):
      > openipmi: upgrade 2.0.25 -> 2.0.27
      > phpmyadmin: upgrade 4.8.5 -> 4.9.0.1
      > xdebug: upgrade 2.7.0RC2 -> 2.7.2
      > fcgi: upgrade 2.4.1+git -> 2.4.2
      > xfsprogs: upgrade 4.18.0 -> 5.0.0
      > yaffs2-utils: update to latest master
      > fuse: upgrade 2.9.8 -> 2.9.9
      > libspatialite: update to 4.3.0a
      > nano: update to 4.2
      > lxdm: provides fake gdmflexiserver for xfce desktop environment
      > rocksdb: 5.18.3 -> 6.0.2
      > python-urllib3: upgrade 1.25.2 -> 1.25.3
      > python-requests: upgrade 2.21.0 -> 2.22.0
      > python-psutil: upgrade 5.6.2 -> 5.6.3
      > python-lxml: upgrade 4.3.3 -> 4.3.4
      > python-cython: upgrade 0.29.7 -> 0.29.10
      > python-cryptography-vectors: upgrade 2.6.1 -> 2.7
      > python-cryptography: upgrade 2.6.1 -> 2.7
      > python-cachetools: upgrade 3.1.0 -> 3.1.1
      > python-babel: upgrade 2.6.0 -> 2.7.0
      > oprofile: drop virtual/kernel dependency and switch back to TUNE_PKGARCH
      > xfce4-settings: set default theme Adwaita
      > .gitignore: add *.pyc and *.pyo
      > openh264: Fix armv7ve build
      > kea: replace -Og with -O
      > mcelog: Remove manual RDEPENDS from PN-ptest to PN package
      > wireless-regdb: Upgrade 2019.03.01 -> 2019.06.03
      > recipes-devtools: Move back from meta-networking to meta-perl
      > haveged: fix CPU cache size detection
      > xfsprogs: Fix host contamination
      > xfce4-session: Reformat DEPENDS and RDEPENDS
      > xfce4-session: Add xrdb RDEPENDS
      > python-mako: upgrade 1.0.10 -> 1.0.12
      > python-pbr: upgrade 5.2.0 -> 5.2.1
      > libgpiod: Enable cxx bindings by default
      > cpprest: temporary ignore deprecated-copy and redundant-move errors detected by gcc9
      > spice: append to CFLAGS instead of +=
      > hwloc: Upgrade to 1.11.12
      > net-snmp: split net-snmp-config to package net-snmp-dev
      > postgresql: improve reproducibility
      > python-ldap: add python-pyasn1 and python-pyasn1-modules as runtime dependencies
      > lmsensors: Update to 3.5.0
      > cryptsetup: Add PACKAGECONFIG options
      > multipath-tools: upgrade 0.8.0 -> 0.8.1
      > pavucontrol: upgrade 3.0 -> 4.0
      > xf86-video-ati: upgrade 18.0.1 -> 19.0.1
      > php: upgrade 7.3.4 -> 7.3.6
      > rrdtool: upgrade 1.7.1 -> 1.7.2
      > python-pygobject: upgrade 3.28.3 -> 3.32.1
      > phoronix-test-suite: upgrade from 8.6.0 -> 8.8.1
      > libcapture-tiny-perl: upgrade 0.46 -> 0.48; enable ptest
      > libxml-libxml-perl: enable ptest
      > libstrictures-perl: upgrade 2.000003 -> 2.000006; enable ptest
      > libhtml-parser-perl: enable ptest
      > libhtml-tagset-perl: add recipe for v3.20
      > libexutils-config-perl: enable ptest
      > libextutils-installpaths-perl: upgrade 0.011 -> 0.012; enable ptest
      > libcrypt-openssl-random-perl: upgrade 0.11 -> 0.15; enable ptest
      > libcrypt-openssl-rsa-perl: upgrade 0.30 -> 0.31; enable ptest
      > libcrypt-openssl-guess-perl: rename from libcrypt-openssl-guess; enable ptest
      > libcgi-perl: upgrade 4.38 -> 4.43; enable ptest
      > libtest-deep-perl: add recipe for v1.128
      > libterm-readkey-perl: upgrade 2.37 -> 2.38; fix upstream check; enable ptest
      > xfce4-power-manager: 1.6.1 -> 1.6.2
      > libxfce4ui: 4.13.4 -> 4.13.5
      > xfconf: 4.13.6 -> 4.13.7
      > xfwm4: 4.13.1 -> 4.13.2
      > libxfce4util: 4.13.2 -> 4.13.3
      > xfce4-appfinder: 4.13.2 -> 4.13.3
      > thunar-volman: 0.9.1 -> 0.9.2
      > xfce4-panel: 4.13.4 -> 4.13.5
      > xfdesktop: 4.13.3 -> 4.13.4
      > thunar: 1.8.4 -> 1.8.6
      > php-fpm-apache: fix module path
      > s-suite: push SRCREV to version 3.4
      > imagemagick: update from 7.0.8-43 to 7.0.8-47
      > samba: Upgrade 4.8.11 -> 4.8.12
      > spice: fix compile errors on 32bit system
      > open-vm-tools: import gcc9 fixes from fedora
      > open-vm-tools: refresh the patches so that they can be easily applied with devtool or git am
      > gsl: update to version 2.5
      > python3-pywbem:solved the conflict with python-pywbem
      > python-pywbem: solved the conflict with python3-pywbem
    
    * sources/meta-ti 8b8ddfd9...eabeaeef (3):
      > u-boot-ti-staging: update to the latest
      > j7-evm: add new infotainment DTBO file
      > linux-ti-stagin: update to the latest
    
    * sources/openembedded-core ca737408bb...27744ad292 (23):
      > gstreamer1.0-libav: disable API documentation
      > lttng-modules: Upgrade 2.10.9 -> 2.10.10
      > perl: Fix setgroup call regression from 5.30
      > devicetree.bbclass: Combine stderr into stdout to see actual dtc error
      > python3-scons: fix regex replacing python by python3
      > systemd: Backport OpenSSL BUF_MEM fix
      > scons: inherit python3native
      > serf: cleanup recipe
      > diffutils/run-ptest: support to run at arbitrary path
      > selftest/devtool: fix URI to MarkupSafe package
      > opkg-utils: upgrade to version 0.4.1
      > oescripts.py: avoid error when cairo module is not available
      > linux-yocto: Add scsi_debug module when ptest is in DISTRO_FEATURES
      > util-linux: Stop udevd to run ptests
      > dbus-test: Upgrade 1.12.16
      > dbus: Upgrade to 1.12.16
      > qemu/qemu-system-native: depend bison-native
      > popt: fix SRC_URI
      > mesa: Update 19.0.6 -> 19.1.0
      > efibootmgr: add
      > efivar: add
      > pigz: install pigz, unpigz, pigzcat in native and nativesdk builds again
      > rng-tools: harmonise systemd and sysvinit
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Jun 14, 2019
  1. Layer Updates: sources/meta-freescale sources/meta-intel sources/meta…

    kraj committed Jun 14, 2019
    …-openembedded sources/meta-raspberrypi sources/openembedded-core
    
    * sources/meta-freescale c927ec08...a3d38477 (20):
      > qca-tools: Upgrade to version 2.0.3
      > imx-kobs: Update SRCREV to 02c01d
      > imx-uuc: Update SRCREV to fc48b4
      > imx-test: Switch to branch imx_4.14.98_2.0.0_ga
      > firmware-qca: Upgrade to version 2.0.3
      > linux-imx-mfgtool: Update to version 4.14.98
      > kernel-modules: upgrade qca6174 and qca9377 to version 2.1
      > linux-imx-headers: update to version 4.14.98
      > linux-imx: Update to version 4.14.98
      > imx-atf: Fix build error 'Invalid platform' for i.MX 8QXP
      > u-boot-imx: Update intermediate name for u-boot nodtb binary
      > imx8qmmek.conf: Set the mkimage target for imx-boot
      > imx8mqevk.conf: Add DisplayPort support
      > firmware-imx*: Upgrade to 8.1.1
      > imx-boot: Remove i.MX 8QXP u-boot configuration
      > imx8qxpmek.conf: Configure imx-boot
      > imx-boot: Drop independent DCD component
      > imx-boot: Add DisplayPort firmware for i.MX 8M
      > imx-boot: Upgrade to L4.14.98-2.0.0_ga
      > imx-mkimage: Upgrade to L4.14.98-2.0.0_ga
    
    * sources/meta-intel c941d896...7bdafc20 (3):
      > intel-graphics-compiler: Fix build error with GCC9
      > intel-graphics-compiler: update to v1.0.6
      > libyami: fix build error with gcc9
    
    * sources/meta-openembedded dd5622ef2b...866daa14e3 (14):
      > polkit: Upgrade to 0.116
      > mozjs: Upgrade to version 60.x
      > python-jsmin,python-pytoml,python-which: Add recipes
      > python-six: put python2/3 variant together
      > safec: Initial recipe for safe C library
      > samba/libldb: add rconflicts
      > netkit-telnet: add rconflicts
      > lxdm: provides fake gdmflexiserver for xfce desktop environment
      > libp11: update to 0.4.10
      > networkmanager: Update to 1.18.0
      > libmikmod: upgrade to 3.3.11.1
      > uthash: do not use unstable github archive tarballs
      > cli11: 1.6.2 -> 1.7.1
      > syslog-ng: add rconflict for package syslog-ng-libs
    
    * sources/meta-raspberrypi 920822c...40283f5 (1):
      > sdcard_image-rpi : minor bug in use of FATPAYLOAD
    
    * sources/openembedded-core f79c95f6a8...ca737408bb (16):
      > bluez: fix test case failures with GCC 9
      > kernel-fitimage: uboot-sign: Check UBOOT_DTB_BINARY before adding deps
      > qemu: fix qemu ptest cannot work
      > multilib: add override for image recipe
      > util-linux: upgrade to 2.33.2
      > vim: Update to 8.1.1518 to fix CVE-2019-12735
      > cmake: Avoid passing empty prefix to os.path.relpath
      > gtk+3: update 3.24.5 -> 3.24.8
      > gdk-pixbuf: update 2.38.0 -> 2.38.1
      > selftests: add tests for INCOMPATIBLE_LICENSE
      > resulttool/merge: Enable control TESTSERIES and extra configurations
      > resulttool/store: Enable add EXECUTED_BY config to results
      > resulttool/resultutils: Enable add extra configurations to results
      > rng-tools: recipe cleanup
      > python3: fix build on softfloat mips
      > python-nose: python3-nose should be default
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Jun 12, 2019
  1. Layer Updates: sources/bitbake sources/meta-browser sources/meta-free…

    kraj committed Jun 12, 2019
    …scale sources/meta-intel sources/meta-odroid sources/meta-qt5 sources/meta-raspberrypi sources/meta-rust sources/meta-ti sources/meta-variscite-fslc sources/openembedded-core
    
    * sources/bitbake 3d319c79...578f0c02 (12):
      > cooker: Ensure mcdeps are processed even if only one multiconfig
      > build: implement custom progress handlers injected via OE_EXTRA_IMPORTS
      > build/progress: use context managers for progress handlers
      > build: extract progress handler creation logic into its own method
      > knotty: allow progress rate for indeterminate bars
      > cooker: Add compability handling for multiconfig: prefix migration
      > multiconfig: Switch from 'multiconfig' -> 'mc'
      > toaster: Fix Thud Bitbake release metadata
      > fetch2: runfetchcmd(): unset _PYTHON_SYSCONFIGDATA_NAME
      > main: Fix error message typo
      > bitbake: Show base multiconfig environment
      > bitbake: cooker: Rename __depends in all multiconfigs
    
    * sources/meta-browser 6386d9a...7061c14 (6):
      > make firefox recipes RDEPEND on firefox; add to ABISAFE list
      > move other firefox recipes to dynamic layer
      > dynamic-layers: move Firefox to rust-layer
      > chromium: Update to 75.0.3770.80.
      > chromium-ozone-wayland: Fixup V4L2VDA patch on Linux
      > chromium: Update to 74.0.3729.169.
    
    * sources/meta-freescale 84f5a23a...c927ec08 (3):
      > linux-fslc-lts-4.19: upgrade 4.19.44 -> 4.19.45
      > linux-fslc(-lts-4.19): add USB_PRINTER and USB_SERIAL_PL2303 to defconfig
      > linux-fslc(-lts-4.19): Fix menuconfig
    
    * sources/meta-intel 35555fb5...c941d896 (3):
      > mkl-dnn: update SRCREV to fix GCC9 build failure
      > mkl-dnn: upgrade 0.18.1 -> 0.19
      > igt-gpu-tools: fix build error with gcc9
    
    * sources/meta-odroid e4bce8c...884e182 (10):
      > linux-hardkernel/4.9: update to 4.9.177
      > odroid-n2: hard kernel does not build with gcc 9
      > linux-stable/4.19: refresh odroid-c2 meson patches
      > linux-stable/5.1: update to 5.1.5
      > linux-stable/5.0: update to 5.0.19
      > odroid-n2 : boot with yocto build thanks to u-boot-hardkernel:odroidn2-25 and linux-hardkernel tuning
      > linux-stable: add 5.1 kernel support
      > linux-stable: allow KMETA SRC_URI to be over written
      > odroid-n2: cleanup machine file
      > odroid-n2: use std hardkernel u-boot
    
    * sources/meta-qt5 60e61ea...2a5f941 (3):
      > qtbase: fix build with gcc-9
      > qtlocation: add PACKAGECONFIGs for geoservices
      > qmake5_base.bbclass: Don't expand find -name search patterns
    
    * sources/meta-raspberrypi 36c3c2e...920822c (4):
      > firmware: Update 20190220 -> 20190517
      > userland: Update to 20190501
      > rpi-default-versions: Switch defaults to 4.19
      > linux-raspberrypi_4.19.bb: Update to 4.19.44
    
    * sources/meta-rust 84710b3...9487b08 (2):
      > Merge pull request #243 from akiernan/checksums-and-fuzz
      > Merge pull request #241 from webdino/update-to-1.34.2
    
    * sources/meta-ti 59e66caf...8b8ddfd9 (11):
      > linux-ti-staging: update to the latest with support for J7
      > u-boot-ti-staging: update to the latest with support for J7
      > arm-trusted-firmware: update to the latest with support for J7
      > j7-evm: add config for J7 (J721e) machine
      > am65xx-evm: add tispl.bin to wic image and comment for tiboot3.bin and sysfw.itb
      > dsplib: bump SRCREV to pick up updated test reports
      > mathlib: bump SRCREV to pick up updated test reports
      > swtools: bump SRCREV to compile dsplib/mathlib with "--legacy"
      > serdes-diag-rtos: SRCREV update to 1.0.0.12 and adding support to k3
      > ti-sgx-ddk-um: bump SRCREV to pick up the fix for AM5 performance degradation
      > vps-lld-rtos: fix DEPENDS
    
    * sources/meta-variscite-fslc 0a03c89...ff12ab7 (7):
      > imx6ul-var-dart: Add support for i.MX6ULZ SOCs to both Variscite VAR-SOM-6UL & DART-6UL SOMs
      > imx6ul-var-dart: Add support for the Variscite VAR-SOM-6UL family of SOMs
      > imx6ul-var-dart: Reorganize DTs
      > linux-variscite: Update to latest revision
      > u-boot: Update to latest revision
      > variscite boards: Use weak assignments for PREFERRED_PROVIDER settings
      > bcm43xx-utils: fix typo in variscite-wifi.service
    
    * sources/openembedded-core 9e5efbe1a3...f79c95f6a8 (152):
      > kernel.bbclass: Make task clean depend on cleaning of make-mod-scripts
      > tune-thunderx: Set the correct PACKAGE_EXTRA_ARCHS_tune-thunderx
      > meta: license: fix non-SPDX license being removed from INCOMPATIBLE_LICENSE
      > wic/plugins: kernel image refer to KERNEL_IMAGETYPE
      > json-c: Backport --disable-werror patch to allow compilation under icecc
      > dhcp:"dhclient -x eth0" action is not correct.
      > gstreamer1.0-python_1.16.0.bb: Override libpython dir
      > build-appliance-image: Update to master head revision
      > recipetool: add python3 support
      > runqemu: QB_FSINFO to support fstype wic images
      > multiconfig: Adapt to bitbake switch 'multiconfig' -> 'mc'
      > oeqa: Add reproducible build selftest
      > base.bbclass: Add OE_EXTRA_IMPORTS
      > testimage: consider QB_DEFAULT_FSTYPE
      > qemurunner: fix undefined variable
      > oeqa/runtime: add simple test for scons
      > serf: switch to python3-scons-native
      > scons.bbclass: use python3-scons
      > python3-scons-{native}: add recipe for v3.0.5
      > openssh: Document skipped test dependency
      > gawk: ptest fixes
      > parted: drop patch for linux <2.6.20 support
      > parted: swap patches for the commits that landed upstream
      > libxslt: add comment saying when a workaround can be removed
      > glib-2.0: udpate 2.58.3 -> 2.60.3
      > mesa: Update 19.0.5 -> 19.0.6
      > wic/filemap: handle FIGETBSZ failing
      > gnutls: Use the sysconfdir variable for the ca-certificates path
      > slang: modify an array test
      > bash: Replace uninative loader path in ptest
      > Remove manual RDEPENDS from PN-ptest to PN package
      > gpg_sign/selftest: Fix secmem parameter handling
      > openssh: Add missing ptest dependency on coreutils
      > wic/engine: include .wks.in in wic search and list
      > openssl: Upgrade 1.1.1b -> 1.1.1c
      > gcc: Remove 0006-gcc-disable-MASK_RELAX_PIC_CALLS-bit.patch
      > oeqa/utils/qemurunner: Set both the threadport&serverport with tcpserial parameter
      > runqemu: Add the support to pass multi ports to tcpserial parameter
      > package.bbclass: Clean up writing of runtime pkgdata files
      > bluez5: fix obex packaging
      > recipes: Fix license "names"/versions.
      > vte: Fix the license information
      > libical: tidy up Perl finding
      > ptest-runner: update SRCREV to latest HEAD on ptest-runner2 repo
      > opkg-utils: fix opkg-list-fields script
      > newlib: export CC_FOR_TARGET as CC
      > newlib: Upgrade to 3.1.0
      > libidn2: upgrade to 2.2.0
      > libpam: fix upstream version check
      > local.conf.sample: change default MACHINE to qemux86-64
      > gcc: CVE-2018-12886
      > ffmpeg: add PACKAGECONFIG for mfx
      > groff: improve reproducibility
      > resulttool: Remove prints if no tests occur
      > glib-2.0: ptest fixes
      > classes/package: Sort ELF file list
      > zip: Remove build date to improve reproducibility
      > resulttool/manualexecution: Enable creation of test case configuration
      > linux-yocto: ptest: Add SCSI debug configuration for util-linux
      > liburcu: update to 0.11.1
      > e2fsprogs: Fix missing ptest dependencies
      > resulttool: modify to be multi-machine
      > lib/oe/reciputils.py: support character `+' in git pv
      > grub/grub-efi: fix unrecognized command line option '-pipe-Wno-error' in CFLAGS
      > libpam: Upgrade 1.3.0 -> 1.3.1
      > tcp-wrappers: Add compile warning fixes from Debian
      > lrzsz: Add implicit declaration fixes from Debian
      > systemd-conf: configure wired network with dhcp
      > perl-rdepends.txt: fix perl-module-data-dumper dependencies
      > mesa-demos: update to 8.4.0
      > source-highlight: remove the recipe
      > libpsl: fix the gtk-doc 1.30 build
      > gtk-doc: upgrade 1.29 -> 1.30
      > linux-yocto/5.0: fix systemtap on arm
      > linux-yocto-rt/5.0: update to -rt11
      > linux-yocto/5.0: update to v5.0.19
      > linux-yocto-rt/5.0: update to -rt9
      > linux-yocto/5.0: update to v5.0.17
      > libxml-perl: Fix module and ptest dependencies
      > libxml-sax-perl: Fix module ptest dependencies
      > libconvert-aan1-perl: Fix module and ptest dependencies
      > liburi-perl: Fix module ptest dependencies
      > perl: Add missing perl module dependency
      > libtimedate-perl: Fix ptest dependencies
      > libtest-needs-perl: Fix ptest dependencies
      > quilt: Add patch depends for quilt-ptest
      > python3-pygments: add a recipe
      > sysstat: add UPSTREAM_VERSION_UNKNOWN
      > bash: run bash ptest as non-root user
      > bash: add big5hkscs gconv RDEPENDS needed by bash-ptest.
      > Revert "ncurses: fix incorrect UPSTREAM_CHECK_GITTAGREGEX"
      > ccache: fix upstream version check
      > mesa: Update 19.0.3 -> 19.0.5
      > perl: install Config_git.pl
      > perl-rdepends.txt: improve dependencies for perl module ptests
      > libxml-parser-perl: fix ptest dependencies
      > piglit: upgrade to latest revision
      > perl: update to 5.30.0
      > liburcu: update to 0.11.0
      > useradd: Ensure do_populate_sysroot has dependency on useradd variables
      > elfutils: fix ptest failures
      > gstreamer1.0-vaapi: upgrade to version 1.16.0
      > glibc-locale: DEPEND on virtual/libc
      > gnutls: Use ca-certificates as default trust store file
      > at-spi2: Make X11 support truly optional
      > perl: Set build date to SOURCE_DATE_EPOCH
      > useradd: Fix build architecture corruption of sstate artefacts
      > runqemu: Add support for kvm on aarch64
      > qemuarm64: Add QB_CPU_KVM to allow kvm acceleration
      > libva: upgrade 2.4.0 -> 2.4.1
      > dpkg: Remove workaround patches for no longer supported host distributions
      > ca-certificates: Fix openssl runtime dependencies
      > linux-yocto-dev: bump to v5.2-rc
      > kernel: package modules.builtin.modinfo
      > linux-yocto/4.19: update to v4.19.44
      > linux-yocto/4.19: update to v4.19.40
      > linux-yocto/5.0: update to v5.0.13
      > dbus-test: Upgrade 1.12.12 -> 1.12.14
      > dbus: Upgrade 1.12.12 -> 1.12.14
      > openssh: Upgrade 7.9p1 -> 8.0p1
      > wic: bootimg-efi: add label source parameter
      > systemd: add rconflicts
      > btrfs-tools: Pass DEBUG_MAP_PREFIX flags to Python
      > bc: use u-a for bc as well
      > Revert "pigz: pigz is not gzip"
      > Revert "image_types: use pigz to create .gz files"
      > gdb: Let gdbserver be empty for riscv64
      > base.bbclass: add named SRCREVs to the sstate hash
      > packagegroup-core-full-cmdline: Make nfs-utils/rpcbind optional
      > inetutils: fix wrong package name
      > cmake: Use compiler launcher variable when ccache is enabled
      > busybox-inittab/sysvinit-inittab: add rconflicts
      > dropbear: add openssh/openssh-sshd as rconflict
      > connman: add networkmanager as rconflict
      > uninative: Switch from bz2 to xz
      > yocto-uninative: Update to 2.5 release
      > mdadm: Add missing ptest dependency
      > util-linux: Fix ptest dependencies
      > ptest-packagelists: Add mdadm
      > strace: Tweak ptest disk space management
      > uninative-tarball: Use xz compression and SDK_ARCHIVE_CMD
      > populate_sdk_base: Use highest compression level for xz
      > uninative-tarball: Fix file generation after class changes
      > go: Remove INSANE_SKIP_* textrel that are now handled in go.bbclass
      > Remove Go 1.11
      > bluez5: manage udev dependency with PACKAGECONFIG
      > perl: Preserve attributes when applying cross files
      > vim: Move PACKAGECONFIG[gtkgui] from GTK 2 to GTK 3
      > gcc: reduce the variables in symtab
      > p11-kit: update to 0.23.16.1
      > file: update to 5.37
      > bash: add iso8859-1 gconv RDEPENDS needed by bash-ptest.
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 29, 2019
  1. Layer Updates: sources/meta-openembedded sources/meta-raspberrypi sou…

    kraj committed May 29, 2019
    …rces/meta-variscite-fslc sources/openembedded-core
    
    * sources/meta-openembedded 321a62261d...dd5622ef2b (28):
      > nginx: fix kill path in nginx systemd unit file
      > nginx: add PACKAGECONFIG[http-auth-request]
      > nginx: update stable version to 1.16.0
      > nginx: update to version 1.17.0
      > crash: do not use unstable github archive tarballs
      > leptonica: fix SRC_URI
      > packagegroup-xfce-extended: add xfce4-screensaver
      > xfce4-screensaver: add recipe
      > xfce4-session: 4.13.1 -> 4.13.2
      > libmikmod: fix SRC_URI
      > uriparser: upgrade to 0.9.3
      > gpsd: Switch PACKAGECONFIG[qt] from Qt4 to Qt5
      > kea: Upgrade to 1.5.0
      > turbostat: copy bits.h from kernel to turbostat
      > mariadb: Upgrade to 10.3.15
      > lldpd: update to 1.0.3
      > udisks: Remove bash dependency
      > udisks: Install bash_completion script in OE familiar dir
      > libsrtp: Fix compilation and add pkgconfig
      > android-tools-conf: import one more improvement for android-gadget-setup from meta-luneos
      > ttf-mplus, ttf-vlgothic: add ttf-mplus license
      > Geoclue: Update to 2.5.3
      > hunspell-dictionaries: import from meta-luneos to make hunspell in meta-oe a bit more useful
      > hunspell: use git fetcher instead of github archive
      > funyahoo-plusplus, icyque, pidgin-sipe, purple-skypeweb: add couple plugins for pidgin
      > pidgin: upgrade to 2.13.0
      > rrdtool: improve reproducibility
      > spice,spice-protocol: Uprev to 0.14.0
    
    * sources/meta-raspberrypi 7059c37...36c3c2e (1):
      > gstreamer1.0-omx: Forward port bbappend and patches to v1.16.x
    
    * sources/meta-variscite-fslc 138ea01...0a03c89 (2):
      > u-boot-splash: Stop using hardcoded splash.bmp file location
      > pm-utils: Remove the default sleep.d scripts
    
    * sources/openembedded-core 335f891c55...9e5efbe1a3 (41):
      > mesa: Fix patch Upstream-Status
      > lttng-tools: Fix patch Upstream-Status
      > tcmode-default: Make gcc9 the default
      > gst-validate: upgrade to version 1.16.0
      > gstreamer1.0-python: upgrade to version 1.16.0
      > gstreamer1.0-rtsp-server: upgrade to version 1.16.0
      > gstreamer1.0-libav: upgrade to version 1.16.0
      > gstreamer1.0-omx: upgrade to version 1.16.0
      > gstreamer1.0-plugins-ugly: upgrade to version 1.16.0
      > gstreamer1.0-plugins-bad: upgrade to version 1.16.0
      > gstreamer1.0-plugins-good: upgrade to version 1.16.0
      > gstreamer1.0-plugins-base: upgrade to version 1.16.0
      > gstreamer1.0: upgrade to version 1.16.0
      > ethtool: update to 5.1
      > systemd: avoid musl specific patches affect glibc systems
      > musl: Upgrade to master tip
      > binutils: Workaround mips assembler crash on target
      > layer.conf: Whitelist lttng-tools->lttng-modules dependency
      > lttng-tools: add lttng-modules to ptest dependencies
      > lttng-tools: prevent test timeout when lttng-modules is not present
      > chkconfig: fix upstream version check
      > chkconfig: do not use unstable github archive tarballs
      > iproute2: upgrade 5.0.0 -> 5.1.0
      > librsvg: Replace workaround for old host systems with upstream fix
      > avahi: Add PACKAGECONFIG for libdns_sd
      > texinfo-dummy-native: Rewrite template.py to use argparse
      > texinfo-dummy-native: A little clean up of template.py
      > Revert "musl: Add TEMP_FAILURE_RETRY from glibc"
      > connman: fix segfault with musl >v1.1.21
      > ofono: Add TEMP_FAILURE_RETRY optional definition
      > qemu: Backport the arm segfault fix
      > pinentry: Switch pinentry-qt from Qt4 to Qt5
      > mdadm: use ${systemd_unitdir} rather than /lib/systemd
      > mesa: Fix a case when gbm is enabled but DRIDRIVERS is not defined
      > m4/tar: Remove remove-gets.patch
      > apt: Remove workaround patches for no longer supported host distributions
      > squashfs-tools: Mark as incompatible with musl
      > meson.bbclass: Make meson support aarch64_be.
      > python*-setuptools: add separate packages for pkg_resources module
      > gsettings-desktop-schemas: upgrade 3.28.1 -> 3.32.0
      > glib-networking: add PACKAGECONFIG for openssl
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 26, 2019
  1. Layer Updates: sources/meta-freescale sources/meta-variscite-fslc

    kraj committed May 26, 2019
    * sources/meta-freescale 179c81a7...84f5a23a (1):
      > wayland-protocols-imx: Upgrade to version 1.17
    
    * sources/meta-variscite-fslc 1f2e707...138ea01 (3):
      > fsl-image-qt5: temporary remove qtwebkit for all backends but x11
      > xserver-xorg: fix crash with latest 1.20.1
      > Revert "reintroduce xserver-xorg 1.19.6"
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 25, 2019
  1. Layer Updates: sources/meta-ti

    kraj committed May 25, 2019
    * sources/meta-ti b8965c33...59e66caf (3):
      > am65xx-hs-evm: fix load address for FIT image
      > u-boot-ti-staging: switch to ti-2019.01 branch
      > u-boot-ti-staging: update with K2 HS fixes
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 24, 2019
  1. Layer Updates: sources/meta-intel sources/meta-openembedded sources/m…

    kraj committed May 24, 2019
    …eta-yoe
    
    * sources/meta-intel 6633f870...35555fb5 (2):
      > intel-microcode: fix upstream release checking
      > linux-intel_4.19: update to v4.19.40
    
    * sources/meta-openembedded f3018013ff...321a62261d (23):
      > ne10, libopus: add armv7ve override as well
      > apache2: add all extra/*.conf to conffiles
      > lcov: Upgrade 1.11 -> 1.14
      > modemmanager: Update to 1.10.0
      > Remove ipsec-tools and umip
      > dvb-apps: Remove workaround patch for ancient target compilers
      > Remove start-stop-daemon
      > pm-graph: add recipe
      > mdns: update to 878.200.35
      > nbd: update to 3.19
      > mtr: update to 0.92
      > php-7: mark two tests as expected to fail
      > ipcalc: update to 2.2.3
      > atftp: update to 0.7.2
      > Upgraded python-pysnmp from version 4.3.5. to 4.4.9.
      > rp-pppoe: update to 3.13
      > openocd: Fix build on x86_64
      > libnfc: Fix build with musl
      > polkit: fix CVE-2019-6133
      > python-obd: Uprade from 0.7.0 to 0.7.1
      > python-ldap: update to 3.2.0
      > opensaf: update to 5.19.03
      > igmpproxy: remove 0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch and _GNU_SOURCE
    
    * sources/meta-yoe 7b45fba...e890ed3 (1):
      > Merge pull request #31 from YoeDistro/yoe/mut
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 22, 2019
  1. Layer Updates: sources/meta-browser sources/meta-freescale sources/me…

    kraj committed May 22, 2019
    …ta-freescale-3rdparty sources/meta-intel sources/meta-riscv sources/meta-ti sources/openembedded-core
    
    * sources/meta-browser aa3649e...6386d9a (2):
      > chromium-ozone-wayland: Fix V4L2 VDA CanCreateEGLImageFrom()
      > chromium: Update to 74.0.3729.157.
    
    * sources/meta-freescale abfc7b1e...179c81a7 (4):
      > linux-fslc-lts-4.19: initial add
      > qca-tools: Disable for musl hosts
      > imx-atf: Upgrade version from 1.5 to 2.0
      > imx-sc-firmware: Upgrade version from 0.9 to 1.2
    
    * sources/meta-freescale-3rdparty 40a05f3...ca9029c (7):
      > imx6qdl-variscite-som: use linux-fslc-lts-4.19 when selecting mainline
      > add support for linux-fslc-lts-4.19
      > init-ifupdown: ccimx6ulsbcpro: Add Wi-Fi interfaces to the interfaces file
      > init-ifupdown: ccimx6ulsbcexpress: Add wi-Fi interfaces to interfaces file
      > linux-fslc: ccimx6som: Add support for wireless module variants
      > udev-rules-digi: Add udev rules for Digi International SOMs
      > ccimx6ulsom: Add wireless driver and firmware files
    
    * sources/meta-intel 886d2063...6633f870 (1):
      > intel-microcode: upgrade to 20190514a
    
    * sources/meta-riscv 4dd427a...4157f3e (2):
      > gdb: Remove the RISC-V GDB
      > layer.conf: Mark master warrior and newer compatible only
    
    * sources/meta-ti 49a622ef...b8965c33 (1):
      > u-boot-ti-staging: update to ti2019.01-rc5 tag
    
    * sources/openembedded-core 066fa83eea...335f891c55 (45):
      > iproute2: Remove bogus workaround patch for musl
      > kexec-tools: refresh patches with devtool
      > perl/modules: Add various missing ptest perl module dependencies
      > m4: Add coreutils and diffutils dependency for ptest
      > libpcre: Add make dependency for ptest
      > openssh: Add sudo dependency for ptest
      > bash: Fix bash-ptest dependencies
      > perl-rdepends: Add missing module dependencies
      > btrfs-tools: update to 5.1
      > epiphany: update to 3.32.2
      > webkitgtk: update to 2.24.2
      > usbutils: upgrade 010->012
      > freetype: upgrade 2.9.1 -> 2.10.0
      > acpica: upgrade 20190405 -> 20190509
      > gst-examples: upgrade to 1.16.0
      > bash-completion: upgrade 2.8 -> 2.9
      > python3-pbr: upgrade 5.1.3 -> 5.2.0
      > linux-firmware: upgrade to latest revision
      > x264: upgrade to latest revision
      > libsoup-2.4: upgrade 2.66.1 -> 2.66.2
      > glib-networking: upgrade 2.60.1 -> 2.60.2
      > at-spi2-atk: upgrade 2.30.0 -> 2.32.0
      > at-spi2-core: upgrade 2.30.0 -> 2.32.1
      > pkgconf: upgrade 1.6.0 -> 1.6.1
      > python3-pip: upgrade 19.0.3 -> 19.1.1
      > libxcrypt: upgrade 4.4.4 -> 4.4.6
      > lz4: upgrade 1.9.0 -> 1.9.1
      > alsa-lib: upgrade 1.1.8 -> 1.1.9
      > alsa-utils: upgrade 1.1.8 -> 1.1.9
      > alsa-plugins: upgrade 1.1.8 -> 1.1.9
      > gawk: upgrade 4.2.1 -> 5.0.0
      > systemtap: upgrade 4.0 -> 4.1
      > go: update 1.12.1->1.12.5
      > nss: upgrade 3.43 -> 3.44
      > python3-mako: upgrade 1.0.9 -> 1.0.10
      > atk: upgrade 2.30.0 -> 2.32.0
      > bison: upgrade 3.1 -> 3.3.2
      > adwaita-icon-theme: upgrade 3.30.1 -> 3.32.0
      > libdazzle: upgrade 3.32.1 -> 3.32.2
      > createrepo-c: upgrade 0.12.2 -> 0.14.0
      > libmodulemd: fix erroneous linking against v2 library when v1 was requested
      > libmodulemd: upgrade 2.2.3 -> 2.4.0
      > librepo: upgrade 1.9.6 -> 1.10.2
      > ofono: Fix another race condition during the build
      > ofono: Use external ell instead of an internal copy
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 21, 2019
  1. Layer Updates: sources/bitbake sources/meta-intel sources/meta-openem…

    kraj committed May 21, 2019
    …bedded sources/openembedded-core
    
    * sources/bitbake fd27ab60...3d319c79 (2):
      > bitbake: fetch2/npm: fix npw view parsing
      > svn.py: Stop SVN from directly pulling from an external layer w/o fetcher
    
    * sources/meta-intel 8cd484ab...886d2063 (1):
      > lttng-modules: add bbappend
    
    * sources/meta-openembedded 1ecd8b4364...f3018013ff (24):
      > opencv: use the same package name in PACKAGES and RDEPENDS
      > toybox: Re-order inherit location so we can override do_configure
      > triggerhappy: fix issues
      > python-cassandra-driver.inc: fix DEPENDS
      > wireguard: Upgrade 20190123 -> 20190406
      > mscgen: fix SRC_URI for multilib
      > ell: remove recipe
      > Add irda-utils
      > umip: make MACHINE_ARCH
      > oprofile: make MACHINE_ARCH
      > ndctl: make MACHINE_ARCH and ignore from libblockdev
      > gtkwave: add distro_features_check
      > python-pysocks: upgrade 1.6.8 -> 1.7.0
      > python-pip: upgrade 19.1 -> 19.1.1
      > python-mako:upgrade 1.0.9 -> 1.0.10
      > python-wrapt: upgrade 1.10.11 -> 1.11.1
      > python-urllib3: upgrade 1.23 -> 1.25.2
      > python-typing: upgrade 3.6.4 -> 3.6.6
      > python-six: upgrade 1.11.0 -> 1.12.0
      > xl2tpd: update to 1.3.14
      > pure-ftpd: update to 1.0.47
      > znc: update to 1.7.3
      > openocd: Upgrade to latest git version
      > python-pyparsing: upgrade 2.2.0 -> 2.4.0
    
    * sources/openembedded-core 8a6ef2044c...066fa83eea (20):
      > libxfont2: set CVE_PRODUCT
      > python: add a fix for CVE-2019-9948 and CVE-2019-9636
      > valgrind: add 'file' to ptest depends
      > valgrind: Make ptest timestamps copasetic
      > libpcre2: upgrade 10.32 -> 10.33
      > socat: Remove workaround for musl issue now fixed upstream
      > insane: add sanity checks to SRC_URI
      > icu: Remove workaround for musl issue fixed upstream 2 years ago
      > gnu-config: Update to latest SHA
      > gdb: Upgrade from 8.2.1 to 8.3
      > libnss-mdns: Stop trying to build for musl
      > python-numpy: Avoid installing copy of f2py script
      > vim: Rework things so vim adds features not vim-tiny removes
      > vim: split the common part into vim.inc
      > systemd: Some upstreamable musl patches have been upstreamed
      > nss-myhostname: Stop trying to build for musl
      > util-linux: Add missing ptest dependencies
      > npm: remove some temporary build files
      > npm: fix node and npm default directory conflict
      > npm: get npm package name from npm pack
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  2. Layer Updates: sources/meta-browser sources/meta-intel

    kraj committed May 21, 2019
    * sources/meta-browser ee30061...aa3649e (1):
      > chromium: Refresh musl related patches
    
    * sources/meta-intel c80d7ac0...8cd484ab (1):
      > README: Updated Tested Hardware
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 20, 2019
  1. Layer Updates: sources/meta-freescale sources/meta-qt5 sources/meta-v…

    kraj committed May 20, 2019
    …ariscite-fslc
    
    * sources/meta-freescale 57562d1c...abfc7b1e (2):
      > imx-boot: drop dependency to u-boot
      > imx-usb-loader: Update to 29fa8ab revision
    
    * sources/meta-qt5 c7e0ba5...60e61ea (6):
      > qt3d-runtime: update to v2.3
      > qtbase: add no-opengl to PACKAGECONFIG_GL when opengl isn't in DISTRO_FEATURES
      > qtbase: add accessibility from PACKAGECONFIG_KDE to PACKAGECONFIG_DEFAULT
      > qtbase: add libxext dependency for xcb PACKAGECONFIG
      > python-pyqt5: Update to version 5.12.1.
      > python-pyqt: Fix annoying problems.
    
    * sources/meta-variscite-fslc cd33ae9...1f2e707 (1):
      > linux-variscite: Updated to latest revision
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 19, 2019
  1. Layer Updates: sources/meta-atmel

    kraj committed May 19, 2019
    * sources/meta-atmel 7934878...031f2ef (11):
      > u-boot-at91: update kernel bootargs with rng_core param
      > linux-at91: add linux-at91-4.19 recipe
      > linux-at91: remove 4.9 version
      > u-boot-at91: add 2019.04 version
      > uboot-at91: remove older versions
      > at91bootstrap: remove older versions
      > at91bootstrap: add 3.8.13 recipe
      > Merge pull request #130 from texierp/fixes/u-boot-env
      > atmel-qt-demo-init: do not use generic license file
      > Merge pull request #129 from YoeDistro/yoe/mut
      > Merge pull request #128 from danielbatw/update_latest
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 18, 2019
  1. Layer Updates: sources/bitbake sources/meta-browser sources/meta-free…

    kraj committed May 18, 2019
    …scale sources/meta-intel sources/meta-odroid sources/meta-openembedded sources/meta-qcom sources/meta-qt5 sources/meta-riscv sources/meta-ti sources/meta-variscite-fslc sources/openembedded-core
    
    * sources/bitbake 9b4a9e54...fd27ab60 (2):
      > gitsm: Fix a bug where the wrong path was used for the submodule init
      > bitbake-user-manual: Added npm to other fetcher list.
    
    * sources/meta-browser 1f363e2...ee30061 (2):
      > chromium-ozone-wayland: Fix usage without zwp_linux_dmabuf and NGMB.
      > chromium: Fix arm64 build.
    
    * sources/meta-freescale 3dc8f2fe...57562d1c (11):
      > imx-gst1.0-plugin: Upgrade version from 4.4.2 to 4.4.5
      > gstreamer1.0-plugins-bad: Switch to MM_04.04.05_1902_L4.14.98_GA branch
      > gstreamer1.0-plugins-good: Switch to MM_04.04.05_1902_L4.14.98_GA branch
      > gstreamer1.0-plugins-base: Switch to MM_04.04.05_1902_L4.14.98_GA branch
      > gstreamer1.0: Switch to MM_04.04.05_1902_L4.14.98_GA branch
      > imx-vpuwrap: Upgrade version from 4.4.2 to 4.4.5
      > imx-parser: Upgrade version from 4.4.2 to 4.4.5
      > imx-codec: Upgrade version from 4.4.2 to 4.4.5
      > imx-vpu-hantro: Upgrade version from 1.8.0 to 1.11.0
      > utilities.inc: fix return None type error
      > u-boot-imx: Upgrade version 2017.03 to 2018.03
    
    * sources/meta-intel 8630938e...c80d7ac0 (7):
      > intel-graphics-compiler: add
      > clang: build Intel common-clang and spirv
      > build linux_linker from common clang
      > linux-intel-dev: add recipe
      > itt: add recipe
      > README: remove reference to bitbake version
      > linux-intel-rt/4.19: update meta SRCREVs to v4.19.31
    
    * sources/meta-odroid 03ee6ff...e4bce8c (11):
      > linux-stable/4.19: update to 4.19.40
      > linux-stable/5.0: update to 5.0.13
      > meson64-common.cfg: remove config not needed anymore
      > linux-stable/4.19: update to 4.19.37
      > linux-stable/5.0: update to 5.0.10
      > odroid-kmeta: update fragments.
      > linux-stable/4.19: update to 4.19.36
      > linux-stable/5.0: update to 5.0.9
      > linux-stable: set audit level to 2
      > linux-stable/5.0: fixup kernel fragments
      > linux-stable/4.19: update kernel fragments
    
    * sources/meta-openembedded 7142f09407...1ecd8b4364 (32):
      > cannelloni: move from meta-oe to meta-networking
      > python-rfc3987: upgrade 1.3.7 -> 1.3.8
      > python-pyperclip: upgrade 1.6.2 -> 1.7.0
      > aufs-util: prevent native aufs-util depending on target kernel
      > libdbi-perl: prevent native libdbi-perl depending on target perl
      > efivar: prevent native efivar depending on target kernel
      > rdfind: Upgrade 1.3.4 -> 1.4.1
      > geos: Upgrade 3.4.2 -> 3.4.3
      > openvpn: update to 2.4.7
      > libvncserver: set PV in the recipe
      > jsoncpp: add native BBCLASSEXTEND
      > conntrack-tools: update to 1.4.5
      > catch2: Upgrade 2.6.1 -> 2.7.2
      > openwbem: Remove stale files of recipe removed 2 years ago
      > ode: Remove stale file of recipe removed 2 years ago
      > liboop: Upgrade 1.0 -> 1.0.1
      > inotify-tools: Upgrade 3.14 -> 3.20.1
      > daemonize: Upgrade 1.7.7 -> 1.7.8
      > ccid: Upgrade 1.4.24 -> 1.4.30
      > augeas: Upgrade 1.11.0 -> 1.12.0
      > fvwm: Upgrade 2.6.7 -> 2.6.8
      > glm: Upgrade 0.9.9.3 -> 0.9.9.5
      > openwsman: Upgrade 2.6.8 -> 2.6.9
      > libqb: Upgrade 1.0.3 -> 1.0.5
      > libcec: Upgrade 4.0.2 -> 4.0.4
      > fluentbit: Upgrade 0.12.1 -> 0.12.19
      > cloud9: Remove stale files of recipe removed 2 years ago
      > rocksdb: Upgrade 5.18.2 -> 5.18.3
      > postgresql: Upgrade 11.2 -> 11.3
      > bpftool: remove LIC_FILES_CHKSUM
      > mozjs: Make mozjs support arm32BE.
      > libnetfilter-conntrack: update to 1.0.7
    
    * sources/meta-qcom d7a873a...d5801c5 (1):
      > qcom-sdm845.inc: use arch-armv8a tune instead of arch-armv8
    
    * sources/meta-qt5 f4531ec...c7e0ba5 (2):
      > qtwebengine: arm: use OE specified -mcpu option
      > qtbase-tools: Fix error during pkg_postinst
    
    * sources/meta-riscv e3e7f75...4dd427a (1):
      > linux-mainline: Fix kernel version checks
    
    * sources/meta-ti db08a45c...49a622ef (8):
      > kselftests: enable ptp/testptp target
      > linux-ti-staging: update the RT kernel tag for ti2019.01-rc4
      > linux-ti-staging: update to ti2019.01-rc4 tag
      > u-boot-ti-staging: update to ti2019.01-rc4 tag
      > beaglebone-capes: Update checksums for LICENSE
      > gdbc6x: bump SRCREV for build fix
      > dsptop: bump SRCREV for build fix
      > arm-trusted-firmware: depend on openssl-native for signing purposes
    
    * sources/meta-variscite-fslc 1843197...cd33ae9 (2):
      > linux-variscite: Update to latest revision
      > fsl-image-gui: Remove packagegroup-fsl-tools-gpu
    
    * sources/openembedded-core 244f2e5fb5...8a6ef2044c (70):
      > ofono: upgrade 1.25 -> 1.29
      > mesa: fix imx gallium driver PACKAGECONFIG option
      > qemux86: use a Core 2 Duo CPU instead of the original circa-1993 Pentium
      > packagegroup-cross-canadian: repackage when TUNE_ARCH changes
      > systemd: Disable idn properly for musl instead of NI_IDN workarounds
      > glib-2.0: add missing libgcc dependency to glib-2.0-ptest
      > tcmode-default.inc: use the same TUNE_PKGARCH variable as PN set in go-cross
      > apr/apr-util: Add ptest dependency on libgcc
      > gettext/flex/m4/bzip2/gzip/parted/slang/attr: Add make to -ptest packages
      > musl: Add TEMP_FAILURE_RETRY from glibc
      > grub-efi-cfg, systemd-boot-cfg: use MACHINE_ARCH
      > mdadm: install the systemd service through Makefile
      > sysstat: Add PACKAGECONFIG[cron] for '--enable-install-cron' option
      > libtest-needs-perl: upgrade 0.002005 -> 0.002006
      > epiphany: Do not bypass initialization of variable with __attribute__((cleanup))
      > mmc-utils: Fix build with clang
      > dhcp: fix a NSUPDATE compiling issue
      > kernel.bbclass: adjust a condition checking
      > mesa: Convert recipe to use meson build system
      > libinput: Upgrade 1.13.1 -> 1.13.2
      > glib-2.0: fix last failing ptest
      > ptest: Add RDEPENDS frpm PN-ptest to PN package
      > dbus-test: Improve ptest dependencies dependencies
      > valgrind: fix call/cachegrind ptests
      > valgrind: adjust test filters and expected output
      > valgrind: update the ptest subdirs list
      > valgrind: Include debugging symbols in ptests
      > valgrind: fix vg_regtest return code
      > core-image-sato-sdk-ptest: Tweak size to stay within 4GB limit
      > perf: make sure that the tools/include/uapi/asm-generic directory exists
      > distutils: Tidy and simplify for readability
      > Remove irda-utils and the irda feature
      > wic/bootimg-efi: replace hardcoded volume name with label
      > packagegroup-self-hosted: drop epiphany
      > ell: update to 0.20
      > oeqa/targetcontrol.py: fix qemuparams not work in runqemu with launch_cmd
      > openssl: Remove openssl10
      > oeqa/target/ssh: Replace suggogatepass with ignoring errors
      > weston-init: Fix WESTON_USER typo
      > groff: imporve musl support
      > webkitgtk: fix compile error for arm64
      > openssh: Avoid PROVIDES warning from rng-tools dependency
      > ghostscript: 9.26 -> 9.27
      > libxml2: upgrade 2.9.8 -> 2.9.9
      > groff: upgrade 1.22.3 -> 1.22.4
      > subversion: upgrade 1.11.1 -> 1.12.0
      > gpgme: upgrade 1.12.0 -> 1.13.0
      > ncurses: fix incorrect UPSTREAM_CHECK_GITTAGREGEX
      > bash: upgrade 4.4.18 -> 5.0
      > man-db: upgrade 2.8.4 -> 2.8.5
      > man-pages: upgrade 4.16 -> 5.01
      > apr: upgrade 1.6.5 -> 1.7.0
      > base-passwd: Add kvm group
      > glib-2.0: add missing locales for the tests
      > glib-2.0: fix locale handling
      > run-postinsts: Fix full execution of scripts at first boot
      > procps: update legacy sysctl.conf to fix rp_filter sysctl issue
      > oeqa/selftest: Automate manual pybootchart tests
      > openssh: recommend rng-tools with sshd
      > lttng-modules: upgrade 2.10.8 -> 2.10.9
      > bitbake.conf: set NO_RECOMMENDATIONS with weak assignment
      > ccache: upgrade 3.6 -> 3.7.1
      > weston-init: Add support for non-root start
      > weston-init: Fix tab indentation
      > systemd: Bump up SRCREV to systemd-stable top to include the fix for shutdown now hang
      > gcc-9: Add recipes for gcc 9.1 release
      > libgfortan: Package target gcc include directory to fix
      > tcmode-default: Add PREFERRED_VERSION for libgfortran
      > oeqa/concurrenttest: Patch subunit module to handle classSetup failures
      > oeqa/runner: Fix subunit setupClass/setupModule failure handling
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 11, 2019
  1. Layer Updates: sources/meta-openembedded

    kraj committed May 11, 2019
    * sources/meta-openembedded 7832621d1c...7142f09407 (33):
      > cpupower: remove LIC_FILES_CHKSUM
      > Remove me as maintainer
      > dovecot: Upgrade 2.2.36 -> 2.2.36.3
      > pptp-linux: Upgrade 1.9.0 -> 1.10.0
      > postfix: Upgrade 3.4.1 -> 3.4.5
      > dnrd: Remove stale files of recipe removed 2 years ago
      > python-pymongo: upgrade 3.7.2 -> 3.8.0
      > python-psutil: upgrade 5.6.1 -> 5.6.2
      > python-pbr: upgrade 5.1.3 -> 5.2.0
      > python-mock: upgrade 2.0.0 -> 3.0.5
      > python-cython: upgrade 0.29.6 -> 0.29.7
      > Remove liboil
      > vlc: Remove workaround and patches for problems fixed upstream
      > schroedinger: Remove the obsolete DEPENDS on liboil
      > dvb-apps: Remove dvb-fe-xc5000c-4.1.30.7.fw
      > caps: Upgrade 0.9.24 -> 0.9.26
      > python-alembic: upgrade 1.0.9 -> 1.0.10
      > libnet-dns-perl: upgrade 1.19 -> 1.20
      > samba: update to 4.8.11
      > glade3: move to to meta-xfce
      > libxfce4ui: Add PACKAGECONFIG 'gladeui2' for glade (gtk3) support
      > xfce4-session: remove strange entry in FILES_${PN}
      > xfce4-session: get rid of machine-host
      > opensaf: update to 5.19.01
      > networkd-dispatcher: update to 2.0.1
      > libnetfilter-queue: fix update to 1.0.3
      > wv: upgrade 1.2.4 -> 1.2.9
      > sshfs-fuse: upgrade 2.8 -> 2.10
      > imagemagick: update from 7.0.8-35 to 7.0.8-43
      > doxygen: replace ninja 1.9.0 fix with official one
      > gd: set CVE_PRODUCT
      > ipsec-tools: fix CVE tag in patch
      > netkit-rsh: add tag to CVE patch
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 10, 2019
  1. Layer Updates: sources/meta-intel sources/meta-qcom

    kraj committed May 10, 2019
    * sources/meta-intel 9eb61e56...8630938e (1):
      > Revert "linux-intel-rt/4.19: update to v4.19.31"
    
    * sources/meta-qcom 70703d8...d7a873a (1):
      > machine/*/dragonbard-845c: Set ext4 rootfs image to 4096 block size
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  2. Layer Updates: sources/meta-browser sources/meta-freescale sources/me…

    kraj committed May 10, 2019
    …ta-qcom sources/openembedded-core
    
    * sources/meta-browser cd88d7b...1f363e2 (1):
      > chromium: Update to 74.0.3729.131
    
    * sources/meta-freescale 4d53f874...3dc8f2fe (1):
      > imx-base: make sure sha384sum is available for all i.MX 8 variants
    
    * sources/meta-qcom 9aa3565...70703d8 (2):
      > meta-qcom: Add linux-linaro-qcomlt_5.1.bb kernel for DB845c
      > conf/machine: Add initial machine definitions for db845c
    
    * sources/openembedded-core 728c6c43de...244f2e5fb5 (17):
      > icu: Added armeb support.
      > systemd: move "machines" symlinks to systemd-container
      > systemd: Use PACKAGECONFIG definition to depend on libnss-myhostname
      > shadow: Backport last change reproducibility
      > uboot-sign: Fix u-boot-nodtb symlinks
      > patch: add minver and maxver parameters
      > gdb: Fix aarch64 build with musl
      > perl: update to 5.28.2
      > meson: update to 0.50.1
      > oeqa/sdk: use bash to execute SDK test commands
      > systemd: Restore mask and preset targets, fix instance creation
      > systemd-systemctl: Restore support for enable command
      > systemd: Default to non-stateless images
      > sysstat: inherit upstream-version-is-even
      > oeqa/core/runner: Handle unexpectedSucesses
      > meta/lib+scripts: Convert to SPDX license headers
      > oeqa: Drop OETestID
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 9, 2019
  1. Layer Updates: sources/meta-freescale sources/meta-ti sources/openemb…

    kraj committed May 9, 2019
    …edded-core
    
    * sources/meta-freescale a2f54239...4d53f874 (1):
      > utilities.inc: split by any number of whitespaces
    
    * sources/meta-ti 29219faf...db08a45c (7):
      > arm-trusted-firmare: sign ATF image for am65xx HS
      > recipes: convert existing uses of am65xx-evm to am65xx SOC family
      > conf/machine: introduce am65xx SOC family and new am65xx-hs-evm
      > arm-trusted-firmware: update to ti2019.01-rc3 tag
      > linux-ti-staging: update to ti2019.01-rc3 tag
      > u-boot-ti-staging: update to ti2019.01-rc3 tag
      > ti-sgx-ddk-km: bump SRCREV to pick up toolchain enhancement
    
    * sources/openembedded-core 07bc5a5367...728c6c43de (24):
      > coreutils: Fix patch upstream status field
      > target-sdk-provides-dummy: resolve sstate conflict
      > python3: fix do_install fail for parallel buiild
      > systemd: Backport patch to fix build with gcc9
      > bitbake.conf: use https instead of http
      > wpa-supplicant: update to 2.8
      > msmtp: update to 1.8.4
      > mtools: update to 4.0.23
      > coreutils: update to 8.31
      > kmscube: update to latest revision
      > sqlite3: update to 3.28.0
      > libxcb: remove workaround patch for a bug that was fixed in gcc 5 in 2015
      > cogl: remove -Werror=maybe-uninitialized workaround
      > cogl: upgrade 1.22.2 -> 1.22.4
      > mmc-utils: update to the latest upstream code
      > resulttool: Add option to dump all ptest logs
      > bison: upgrade 3.0.4 -> 3.1
      > socat: upgrade 1.7.3.2 -> 1.7.3.3
      > grub: Use -Wno-error instead of doing this on a per-warning basis
      > gnu-efi: Remove support patch for gcc < 4.7
      > scripts/pybootchart/draw: Fix some bounding problems
      > scripts/pybootchart/draw: Clarify some variable names
      > scripts/pybootchart: Port to python3
      > scripts/pybootchart: Fix mixed indentation
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 8, 2019
  1. Layer Updates: sources/meta-intel sources/openembedded-core

    kraj committed May 8, 2019
    * sources/meta-intel 40225d8c...9eb61e56 (1):
      > linux-intel-rt/4.19: update to v4.19.31
    
    * sources/openembedded-core 078950f6ff...07bc5a5367 (17):
      > openssh/systemd/python/qemu: Fix patch Upstream-Status
      > acpica: use update-alternatives for acpidump
      > squashfs-tools: set CVE_PRODUCT
      > flac: also add flac to CVE_PRODUCT
      > systemd: Add -Wno-error=format-overflow to fix build with gcc9
      > gcc-target: Do not set --with-sysroot and gxx-include-dir paths
      > cml1.bbclass: fix undefined behavior
      > distutils: Run python from the PATH in the -native case as well
      > recipetool: fix unbound variable when fixed SRCREV can't be found
      > go: Exclude vcs files when installing deps
      > python3: Add ntpath.py to python core
      > patchelf: Upgrade 0.9 -> 0.10
      > cpio/tar/native.bbclass: move rmt to sbindir and add a prefix to avoid native clashing
      > ghostscript: set CVE_PRODUCT
      > file: Stop adding -std=c99 to CFLAGS
      > libxcrypt: Stop adding -std=gnu99 to CPPFLAGS
      > nss: cleanup recipe to match OE style
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 7, 2019
  1. Layer Updates: sources/bitbake sources/meta-freescale sources/meta-in…

    kraj committed May 7, 2019
    …tel sources/meta-openembedded sources/meta-riscv sources/meta-ti sources/openembedded-core
    
    * sources/bitbake 93e94c06...9b4a9e54 (4):
      > HEADER: Drop it
      > bitbake: Strip old editor directives from file headers
      > bitbake: Drop duplicate license boilerplace text
      > bitbake: Add initial pass of SPDX license headers to source code
    
    * sources/meta-freescale 02eb08c1...a2f54239 (5):
      > qtwayland: drop xcomposite-egl, xcomposite-glx packageconfig for mx8
      > imx8mmevk.conf, imx8mqevk.conf: drop adding m4 demos do the boot partition
      > imx8qmmek: fix files in the boot partition
      > libdrm: prevent warning on mx8
      > imx-base: make gstreamer1.0 packages socarch specific for all imx soc
    
    * sources/meta-intel b412c960...40225d8c (5):
      > intel-mediasdk: upgrade 18.4.1 -> 19.1.0
      > gmmlib: upgrade 18.4.1 -> 19.1.2
      > intel-media-driver: upgrade 18.4.1 -> 19.1.0
      > conf: use zlib-intel by default for target builds
      > zlib-intel: add zlib fork with IA-specific optimisations
    
    * sources/meta-openembedded 50108c18e5...7832621d1c (53):
      > ebtables: add UPSTREAM_CHECK_URI
      > ypbind-mt: update to 2.6
      > mongodb: Fix build with gcc
      > xfce4-terminal: add vte-prompt to RRECOMMENDS
      > libwnck3: upgrade 3.30.0 and move to meson build
      > desktop-file-utils: remove - a more recent version is in oe-core
      > xfce4-notifyd: upgrade 0.4.3 -> 0.4.4
      > xfce4-datetime-plugin: upgrade 0.7.0 -> 0.7.1
      > xfce4-places-plugin: upgrade 1.7.0 -> 1.8.0
      > exo: upgrade 0.12.4 -> 0.12.5
      > fontforge: upgrade 20170731 -> 20190413
      > itstool: rework - it went out too early
      > gtksourceview-classic-light: extend to gtksourceview4
      > gtksourceview4: initial add 4.2.0
      > meta-xfce: add meta-networking to layer depends
      > packagegroup-meta-networking: replace DISTRO_FEATURE by DISTRO_FEATURES
      > xfce4-cpufreq-plugin: Fix memory leak and reduce CPU load
      > pmtools: use update-alternatives for acpidump
      > php: correct httpd path
      > evince: add patch to fix build with recent gobject-introspection
      > efivars: Drop workaround patch for host gcc < 4.7
      > arno-iptables-firewall: update to 2.0.3
      > ser2net: upgrade to version 3.5.1
      > vlc: rework qt PACKAGECONFIG
      > cannelloni: new package, CAN to ethernet proxy
      > libnfc: Initial recipe for Near Field Communication library.
      > bdwgc: upgrade 7.6.12 -> 8.0.4
      > meta-filesystems: drop bitbake from README
      > python-requests: Set CVE_PRODUCT
      > python3-pillow: Set CVE_PRODUCT
      > python-urllib3: Set CVE_PRODUCT
      > python3-raven: add version 6.10.0
      > python3-sentry-sdk: add version 0.7.14
      > libcdio: update to version 2.1.0
      > python3-tinyrecord: add version 0.1.5
      > python3-websocket-client: add version 0.56.0
      > python3-supervisor: add version 4.0.2
      > python3-aiohttp: add version 3.5.4
      > libmodbus: add documentation PACKAGECONFIG
      > cpupower: Inherit bash completion class
      > zbar: fix SRC_URI for multilib
      > miniupnpd: fix SRC_URI for multilib
      > opusfile: fix SRC_URI for multilib
      > esound: fix SRC_URI for multilib
      > gnome-desktop3: set correct meson gtk doc option
      > xfce4-vala: auto-detect vala api version
      > phpmyadmin: upgrade 4.8.3 -> 4.8.5
      > openhpi: update openhpi-fix-testfail-errors.patch
      > postgresql: fix compile error
      > php: upgrade 7.3.2 -> 7.3.4
      > python-pyasn1: upgrade 0.4.4 -> 0.4.5
      > samba: add PACKAGECONFIG for libunwind
      > python-pip: upgrade 18.0 -> 19.1
    
    * sources/meta-riscv 9e78155...e3e7f75 (2):
      > linux: Update to 5.1 stable
      > u-boot: Check if ${UBOOT_ENV}.txt exists before using it
    
    * sources/meta-ti 484c2d0d...29219faf (1):
      > ti-sgx-ddk-um: bump SRCREV to pick up wsegl fix
    
    * sources/openembedded-core e79f0db074...078950f6ff (13):
      > gtk-icon-cache: clean up DEPENDS
      > license_image: Use new oe.path.copyhardlink() helper
      > oe.path: Add copyhardlink() helper function
      > mdadm: Disable Werror
      > wic: add global debug option
      > wic: change expand behaviour to match docs
      > ell: add recipe
      > packagegroup-core-full-cmdline: remove zlib
      > libsolv: update to 0.7.4
      > xorg-lib: drop native overrides for REQUIRED_DISTRO_FEATURES
      > m4: update patch status
      > initrdscripts: merge multiple "mkdir" calls
      > useradd-staticids: print exception after parse_args() error
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 3, 2019
  1. Layer Updates: sources/meta-browser sources/meta-intel sources/meta-q…

    kraj committed May 3, 2019
    …t5 sources/openembedded-core
    
    * sources/meta-browser 164e929...cd88d7b (1):
      > chromium-ozone-wayland: Stop depending on the system's wayland-scanner binary
    
    * sources/meta-intel 7573548c...b412c960 (2):
      > README: update for warrior release requirements
      > linux-yocto-rt/5.0: add bbappend
    
    * sources/meta-qt5 8586caf...f4531ec (1):
      > qtwebengine: restore the fix for build with clang/libc++ on aarch64/arm
    
    * sources/openembedded-core 17e8751037...e79f0db074 (17):
      > uboot-sign: Fix build when UBOOT_DTB_BINARY is empty
      > opkg: fix ptest packaging when OPKGLIBDIR == libdir
      > image: call systemctl preset-all for images
      > systemctl-native: Rewrite in Python supporting preset-all and mask
      > systemd: create preset files instead of installing in image
      > systemd-conf: simplify creation of machine-specific configuration
      > systemd: do not create machine-id
      > systemd: don't build firstboot by default
      > populate_sdk_base: provide options to set sdk type
      > dbus: fix ptest failure
      > qemu: Upgrade from 3.1.0 to 4.0.0
      > bitbake.conf: Account for older versions of bitbake
      > elfutils: Fix ptest compile failures on musl
      > elfutils: ptest fixes
      > mpg123: port to use libsdl2
      > vim: Update to 8.1.1240
      > vim: Rework to not rely on relative directories
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on May 2, 2019
  1. gitmodules: Do not sue shallow clones by default

    kraj committed May 2, 2019
    Command "git submodule update --init --recursive --remote sources/bitbake" returned status code 1:
    
    stderr: fatal: Needed a single revision
    Unable to find current origin/yoe/mut revision in submodule path 'sources/bitbake'
    
    CI loop fails occasionally with such errors
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  2. Layer Updates: sources/bitbake sources/meta-openembedded sources/meta…

    kraj committed May 2, 2019
    …-ti sources/openembedded-core
    
    * sources/bitbake 3f2c2eb2...93e94c06 (8):
      > build: Disable warning about dependent tasks for now
      > build: Ensure warning for invalid task dependencies is useful
      > knotty: Implement console 'keepalive' output
      > knotty: Pretty print task elapsed time
      > build: Add verbnote to shell log commands
      > tests/parse.py: Add testcase for addtask and deltask
      > build.py: check dependendent task for addtask
      > BBHandler: Fix addtask and deltask
    
    * sources/meta-openembedded d42cce95a8...50108c18e5 (57):
      > libdbd-mysql-perl: Upgrade to 4.050
      > libnetfilter-queue: update to 1.0.3
      > cpprest: update to 2.10.13, drop 32bit build fix upstream
      > v4l-utils: upgrade 1.16.0 -> 1.16.5
      > libdev-checklib-perl: add new recipe
      > rrdtool: Upgrade to 1.7.1
      > libopus: use armv7a, aarch64 overrides when adding ne10 dependency
      > apache2: add back patch for set perlbin
      > nftables: add UPSTREAM_CHECK_URI
      > nfacct: add UPSTREAM_CHECK_URI
      > nuttcp: update to 8.2.2
      > traceroute: add UPSTREAM_CHECK_URI
      > vblade: add UPSTREAM_CHECK_URI
      > uftp: update to 4.9.9
      > wpan-tools: update to 0.9
      > networkmanager-openvpn: update to 1.8.10
      > ne10: set NE10_TARGET_ARCH with an override instead of anonymous python
      > ledmon: Mark as incompatible on musl instead of adding bogus patch
      > Revert "ell: remove recipe"
      > ntp: upgrade 4.2.8p12 -> 4.2.8p13
      > python-decorator: upgrade 4.3.0 -> 4.4.0
      > python-zopeinterface: upgrade 4.5.0 -> 4.6.0
      > python-twisted: upgrade 18.4.0 -> 19.2.0
      > python-hyperlink: upgrade 18.0.0 -> 19.0.0
      > python-cffi: upgrade 1.12.2 -> 1.12.3
      > python-alembic: upgrade 1.0.0 -> 1.0.9
      > hwdata: Upgrade to 0.322
      > hostapd: Upgrade to 2.8
      > nano: update to 4.1
      > indent: Upgrade to 2.2.12
      > fluidsynth: upgrade 2.0.4 -> 2.0.5
      > nghttp2: update to 1.38
      > python-lxml: upgrade 4.3.1 -> 4.3.3
      > python-jinja2: upgrade 2.10 -> 2.10.1
      > python-editor: upgrade 1.0.3 -> 1.0.4
      > python-cython: upgrade 0.28.5 -> 0.29.6
      > apache2: Correct packaging of build and doc related files
      > apache2: Correct appending to SYSROOT_PREPROCESS_FUNCS
      > openbox: Add python-shell as a runtime dependency
      > squid: Link with libatomic on mips/ppc
      > python-pbr: upgrade 4.2.0 -> 5.1.3
      > samba: rework localstatedir package split
      > samba: install bundled libs into seperate packages
      > fltk: upgrade 1.3.4-2 -> 1.3.5
      > xfconf: fix 'Failed to get connection to xfconfd' during do_rootfs
      > python-stevedore: upgrade 1.29.0 -> 1.30.1
      > python-pytz: upgrade 2018.5 -> 2019.1
      > python-pyopenssl: upgrade 18.0.0 -> 19.0.0
      > openhpi: fix failure of ptest case ohpi_035
      > python-pymongo: upgrade 3.7.1 -> 3.7.2
      > python-py: upgrade 1.6.0 -> 1.8.0
      > drbd-utils: fix file conflict with base-files
      > drbd: fix compile errors
      > python-psutil: upgrade 5.4.6 -> 5.6.1
      > python-paste: upgrade 3.0.6 -> 3.0.8
      > python-msgpack: upgrade 0.6.0 -> 0.6.1
      > python-mako: upgrade 1.0.7 -> 1.0.9
    
    * sources/meta-ti f218dd2a...484c2d0d (6):
      > am65xx-evm: workaround for YOCTO #13280 bug
      > linux-ti-staging: update to ti2019.01-rc2 tag
      > u-boot-ti-staging: update to ti2019.01-rc2 tag
      > gdbc6x: update with gcc8 warning suppression
      > prueth-fw-bin: update 5.1.0.7 -> 5.3.0.5
      > ti-cgt-arm-native: Upgrade to 18.12.1.LTS
    
    * sources/openembedded-core ecba50f871...17e8751037 (17):
      > oeqa/ssh: Avoid unicode decode exceptions
      > qemux86: Allow higher tunes
      > qemu: split out vte into seperate PACKAGECONFIG
      > maintainers.inc: take over as perl maintainer
      > python3-pycairo: update to 1.18.1
      > linux-yocto/5.0: update TCP patch to mainline version
      > staging: add ${datadir}/gtk-doc/html to the sysroot blacklist
      > nettle: fix ptest failure
      > nettle: fix the Segmentation fault
      > libsdl: set CVE_PRODUCT
      > piglit: support build piglit without x11
      > waffle: supprt build waffle without x11
      > dropbear: set CVE_PRODUCT
      > openssh: fix CVE-2018-20685, CVE-2019-6109, CVE-2019-6111
      > binutils: fix CVE-2019-9074 CVE-2019-9075 CVE-2019-9076 CVE-2019-9077
      > gdb: fix CVE-2017-9778
      > gcc: fix CVE-2018-18484
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 29, 2019
  1. Layer Updates: sources/bitbake sources/meta-96boards sources/meta-fre…

    kraj committed Apr 29, 2019
    …escale sources/meta-intel sources/meta-odroid sources/meta-qt5 sources/meta-raspberrypi sources/meta-riscv sources/meta-rust sources/meta-ti sources/meta-variscite-fslc sources/openembedded-core
    
    * sources/bitbake 3aaf8d65...3f2c2eb2 (6):
      > bitbake: fetch2/git: git-lfs check
      > bb: siggen: Print more info when basehash are mis-matched
      > bb: siggen: Make dump_sigfile and compare_sigfiles print uuid4
      > bitbake-diffsigs: Use 4 spaces as indent for recursecb
      > toaster: update to Warrior
      > bitbake-user-manual: Added section on modifying variables
    
    * sources/meta-96boards caa9db4...863a1e3 (1):
      > Merge pull request #309 from petegriffin/hikey-mesa-lima-pull
    
    * sources/meta-freescale 6977a56d...02eb08c1 (1):
      > imx-imx-boot-bootpart.wks.in: increase boot partition to 64m
    
    * sources/meta-intel ed44056d...7573548c (3):
      > mkl-dnn: upgrade 0.17.4 -> 0.18.1
      > mkl-dnn: fix upstream release checking
      > ixgbevf: 4.5.2 -> 4.5.3
    
    * sources/meta-odroid b8fde89...03ee6ff (6):
      > fix xml:
      > testing travis builds:
      > Merge branch 'master' of github.com:akuster/meta-odroid
      > armv8.inc: remove local copy
      > amlogic-meson64: use upstream armv8a.inc
      > linux-stable/5.0: update to 5.0.6
    
    * sources/meta-qt5 eb5d6da...8586caf (4):
      > qt5: update SRCREVs after v5.12.3 tags were downmerged to 5.12 branch
      > qtwayland: check also that the destination for private headers exists before installing them
      > qtwayland: improve manual header installation
      > qtwayland: workaround upstream bug: install missing headers manually
    
    * sources/meta-raspberrypi 8eeb579...7059c37 (4):
      > psplash: Raise alternatives priority to 200
      > linux-raspberrypi 4.9: Drop old version
      > linux-raspberrypi: Switch default back to 4.14.y
      > linux-raspberrypi: Update 4.14.y kernel
    
    * sources/meta-riscv b9e9d69...9e78155 (5):
      > freedom-u540: Setup u-boot autoboot for TFTP
      > freedom-u540: Allow u-boot to be an OpenSBI payload
      > u-boot: Add support for SMP boot on Freedom U540
      > opensbi: Fix the u-boot dependency
      > wic: Update the sdcard generation
    
    * sources/meta-rust 0d03c20...84710b3 (1):
      > Merge pull request #239 from agherzan/ag/patchfix
    
    * sources/meta-ti 90949a4c...f218dd2a (7):
      > ti-ndk: Upgrade to 3.60.00.13
      > ti-ns: Upgrade to 2.60.00.07
      > ti-ipc-rtos: add SRCREV_FORMAT
      > linux-ti-staging: update to ti2019.01-rc1 tag
      > u-boot-ti-staging: update to ti2019.01-rc1 tag
      > ti-pdk-build-rtos: SRCREV bump to use COPYING.txt for license checksum
      > prueth-fw: use icss-emac-lld sources
    
    * sources/meta-variscite-fslc 5c19ac6...1843197 (2):
      > linux-firmware: Upgrade bcm43xx WIFI/BT firmware
      > alsa-tools: Remove incompatible features
    
    * sources/openembedded-core 879b590fe8...ecba50f871 (95):
      > ptest-packagelists: Add m4 and gettext as 'fast' ptests
      > python3: Drop ptest hack
      > systemd: add cgroupv2 PACKAGECONFIG
      > gnome-doc-utils: Remove stale patch
      > linux-yocto_5.0: set devicetree for armv5
      > linux-yocto/5.0: integrate TCP timeout / hang fix
      > linux-yocto/5.0: port RAID configuration tweaks from master
      > linux-yocto-rt/4.19: fix merge conflict in lru_drain
      > bitbake.conf: add git-lfs to HOSTTOOLS_NONFATAL
      > Adding back wrapper and using OEPYTHON3HOME variable for python3
      > libsoup: Upgrade from 2.64.2 to 2.66.1
      > gettext: add ptest support
      > manual compliance: remove bits done at runtime
      > ltp_compliance: add new runtime
      > logparser: Add LTP compliance section
      > resulttool: add LTP compliance section
      > ltp: add runtime test
      > logparser: Add decoding ltp logs
      > resulttool: add ltp test support
      > utils/multiprocess_launch: Improve failing subprocess output
      > vte: move shell auto scripts into seperate package
      > kernel-module-split.bbclass: support CONFIG_MODULE_COMPRESS=y
      > systemd: upgrade to 242
      > glibc: always use bfd linker
      > resulttool/manualexecution: Enable test case configuration option
      > webkitgtk: Fix build with clang
      > Revert "wic: Set a miniumum FAT16 volume size."
      > icu: Upgrade 64.1 -> 64.2
      > wget: update to 1.20.3
      > python3-pygobject: update to 3.32.1
      > python-numpy: update to 1.16.3
      > vte: upgrade 0.52.2 -> 0.56.1
      > core-image-rt-sdk: make sure that we append to DEPENDS
      > core-image-rt: make sure that we append to DEPENDS
      > oeqa/core/runner: dump stdout and stderr of each test case
      > webkitgtk: set CVE_PRODUCT
      > cryptodev: fix module loading error
      > dnf: Enable nativesdk
      > mesa: Update 19.0.1 -> 19.0.3
      > Use the best xz compression for the SDK
      > lttng-tools: Add missing patch Upstream-Status
      > ninja: add Upstream-Status and SOB for musl patch
      > resultool/resultutils: Fix module import error
      > gtk-doc.bbclass: unify option setting for meson-based recipes
      > icecc.bbclass: stop causing everything to be effectivelly MACHINE_ARCH
      > buildhistory: call a dependency parser only on actual dependency lists
      > resulttool: Add log subcommand
      > resulttool: Load results from URL
      > m4: add ptest support
      > python3-pip: update to 19.0.3
      > python3-pbr: update to 5.1.3
      > python3-mako: update to 1.0.9
      > python-setuptools: update to 41.0.1
      > python-scons: update to 3.0.5
      > msmtp: fix upstream version check
      > acpica: update to 20190405
      > acpica: upgrade to 20190215
      > meson: add missing Upstream-Status and SOB to a patch
      > lttng-tools: fix Upstream-Status
      > base-files: move hostname operations out of issue file settings
      > connman: add PACKAGECONFIG for nfc, fix MACHINE_ARCH signature when l2tp is enabled
      > classes/waf: Set WAFLOCK
      > busybox: fix ptest failure about 'dc'
      > python3-pygobject: update to 3.32.0
      > meson: do not try to substitute the prefix in python supplied paths
      > python3: add another multilib fix
      > epiphany: update to 3.32.1.2
      > icu: update to 64.1
      > ltp: Fix setrlimit03 call succeeded unexpectedly
      > libcap: update to 2.27
      > pixman: update to 0.38.4
      > kernel.bbclass: convert base_do_unpack_append() to a task
      > valgrind: update from 3.14.0 to 3.15.0
      > qemu: Add PACKAGECONFIG for snappy
      > cups: update to 2.2.11
      > u-boot: Fix missing Python.h build failure
      > help2man-native: update to 1.47.10
      > orc: update to 0.4.29
      > lz4: update to 1.9.0
      > gnupg: update to 2.2.15
      > quota: update to 4.05
      > git: update to 2.21.0
      > libpsl: update to 0.21.0
      > libcroco: update to 0.6.13
      > libpng: update to 1.6.37
      > libnotify: update to 0.7.8
      > libinput: update to 1.13.1
      > libdrm: update to 2.4.98
      > gcc-sanitizers: fix -Werror=maybe-uninitialized issue
      > systemd: change default locale from C.UTF-8 to C
      > core-image-sato-sdk-ptest: Add temporary PROVIDES core-image-sato-ptest
      > core-image-sato-sdk-ptest: Include more ptests in ptest image
      > core-image-sato-ptest-fast: Add 'fast' ptest execution image
      > elfutils: fix build failure with musl
      > elfutils: add ptest support
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 20, 2019
  1. Layer Updates: sources/meta-96boards sources/meta-browser sources/met…

    kraj committed Apr 20, 2019
    …a-freescale sources/meta-freescale-3rdparty sources/meta-intel sources/meta-openembedded sources/meta-qt5 sources/meta-raspberrypi sources/meta-riscv sources/meta-ti sources/meta-variscite-fslc
    
    * sources/meta-96boards 2414a75...caa9db4 (1):
      > Merge pull request #305 from mrchapp/d/rm-cpupower
    
    * sources/meta-browser 2848153...164e929 (1):
      > chromium-ozone-wayland: Fix regression with VizDisplayCompositor
    
    * sources/meta-freescale 0ef9809c...6977a56d (12):
      > linux-fslc: Bump revision to c7a0e482a175
      > u-boot-fslc-common: Bump revision to c93ced78dbc
      > imx-base.inc: Use UBOOT_SUFFIX in UBOOT_BINARY variable
      > ls1088ardb-be: remove machine config
      > ls2088ardb-be:remove machine config
      > ls1043ardb-be: remove machine config
      > ls1046ardb-be: remove machine config
      > ls1046ardb-32b: remove machine config
      > ls1043ardb-32b: remove machine config
      > ls1012ardb-32b: remove machine config
      > ls1012afrwy-32b: remove machine config
      > qca-tools: Limit to arm/arm64 hosts alone
    
    * sources/meta-freescale-3rdparty 55356fd...40a05f3 (2):
      > imx6ul-pico: Add support to PICO-DWARF baseboard
      > imx7d-pico: Add support to PICO-DWARF baseboard
    
    * sources/meta-intel cd2c3bfc...ed44056d (2):
      > linux-intel-rt/4.14: update to v4.14.106
      > linux-intel/4.19: update to v4.19.34
    
    * sources/meta-openembedded 0477c76116...d42cce95a8 (29):
      > sip: Update to 4.19.16.
      > s-suite: push SRCREV to version 3.2
      > linux-atm: Replace bogus on_exit removal with musl-specific hack
      > linux-atm: Remove DEPENDS on virtual/kernel and PACKAGE_ARCH
      > python-pycodestyle: Fix conflict error with python3-pycodestyle during do_rootfs
      > thrift: update to 0.12.0
      > paho-mqtt-c: 1.2.1 -> 1.3.0
      > python-obd: Add missing RDEPENDS
      > netkit-rsh: security fixes
      > gvfs: remove systemd user unit executable permission adjustment
      > gvfs: fix typo libexec
      > mycroft: Bump from 19.2.2 to 19.2.3
      > mycroft: Update the systemd service to ensure we are ready to start
      > To fix confilict error with python3-pbr.
      > apache-websocket: upgrade to latest git rev
      > apache2: upgrade 2.4.34 -> 2.4.39
      > gpm: Recipe cleanup
      > gpm: Remove duplicate definition of _GNU_SOURCE
      > gpm: Generate documentation
      > gpm: Add PID file to systemd unit file
      > gpm: Fix gpm path in unit file
      > redis: Upgrade to 4.0.14
      > libforms: add x11 to required DISTRO_FEATURES because of libx11
      > ftgl: add x11 to required DISTRO_FEATURES like freeglut
      > python-dateutil: upgrade 2.7.3 -> 2.8.0
      > python-beabutifulsoup4: upgrade 4.6.0 -> 4.7.1
      > python-certifi: upgrade 2018.8.13 -> 2019.3.9
      > python-attrs: upgrade 18.1.0 -> 19.1.0
      > python-cffi: upgrade 1.11.5 -> 1.12.2
    
    * sources/meta-qt5 a4bf240...eb5d6da (6):
      > qtwayland: disable gold for all archs like in qtbase
      > qt5: upgrade to 5.12.3
      > qtbase: disable gold for all archs not just x86
      > qtbase-native: use QT_CONFIG_FLAGS variable like qtbase and nativesdk-qtbase
      > qtbase: Fix build with recent oe-core/pseudo on hosts with glibc >= 2.28
      > qtbase, qtmultimedia: refresh patches to apply cleanly and update them on github.com/meta-qt5 forks
    
    * sources/meta-raspberrypi 6745beb...8eeb579 (3):
      > userland: use default PACKAGE_ARCH
      > bluez5: apply the same patches and pi-bluetooth dependency for all rpi MACHINEs
      > qtbase_%.bbappend: update PACKAGECONFIG name for xkbcommon
    
    * sources/meta-riscv d77546d...b9e9d69 (3):
      > linux-mainline: Use the new 32-bit defconfig in Linux 5.1
      > linux-mainline: Fix the 32-bit boot
      > freedom-u540: Don't hardcode linux-version
    
    * sources/meta-ti f885d787...90949a4c (3):
      > am65xx-evm: add additional DTBOs
      > dra7xx-evm: add additional DTBs
      > linux-ti-staging: update to 4.19.31
    
    * sources/meta-variscite-fslc 01a67ec...5c19ac6 (2):
      > linux-variscite: Update to Variscite imx_4.14.78_1.0.0_ga_var01 release
      > u-boot: Update to latest revision
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 17, 2019
  1. Layer Updates: sources/meta-freescale sources/meta-raspberrypi source…

    kraj committed Apr 17, 2019
    …s/openembedded-core
    
    * sources/meta-freescale f07fbd00...0ef9809c (1):
      > wic: Fix image generation for i.MX with bootpart script
    
    * sources/meta-raspberrypi 9ceb84e...6745beb (1):
      > linux_raspberrypi_4.19: Update to 4.19.34
    
    * sources/openembedded-core 303ac64b89...879b590fe8 (34):
      > core-image-sato-sdk-ptest: Try and keep image below 4GB limit
      > libyaml: update SRC_URI[md5sum] and SRC_URI[sha256sum]
      > python-numpy: update to 1.16.2
      > python: update to 3.7.3
      > python: update to 2.7.16
      > ffmpeg: update to 4.1.3
      > at-spi2-core: fix meson 0.50 build
      > libmodulemd: update to 2.2.3
      > meson: update to 0.50.0
      > btrfs-tools: upgrade 4.20.1 -> 4.20.2
      > dnf: upgrade 4.1.0 -> 4.2.2
      > libcomps: upgrade 0.1.10 -> 0.1.11
      > libdnf: update to 0.28.1
      > vala: update to 0.44.3
      > libdazzle: update to 3.32.1
      > webkitgtk: update to 2.24.0
      > dtc: upgrade 1.4.7 -> 1.5.0
      > gobject-introspection: update to 1.60.1
      > msmtp: 1.6.6 -> 1.8.3
      > linux-yocto/4.19: update to v4.19.34
      > linux-yocto/5.0: update to v5.0.7
      > linux-yocto-rt: update to 5.0.5-rt3
      > linux-yocto/5.0: update to v5.0.5
      > musl: Upgrade to master past 1.1.22
      > gcc: Remove Java support variables
      > Set XZ_COMPRESSION_LEVEL to -9
      > grub-efi-native: Install grub-editenv
      > iptables: upgrade 1.6.2 -> 1.8.2
      > ptest.bbclass: Use d.getVar instead of os.environ
      > dhcp: Replace OE specific patch for compatibility with latest bind with upstream patch
      > harfbuzz: update source checksums after upstream replaced the tarball
      > uboot-sign: add support for different u-boot configurations
      > iw: upgrade 4.14 -> 5.0.1
      > gnutls: upgrade 3.6.5 -> 3.6.7
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 14, 2019
  1. Layer Updates: sources/meta-odroid

    kraj committed Apr 14, 2019
    * sources/meta-odroid 890aeed...b8fde89 (3):
      > wayland: Keep wayland-egl.pc when using mali
      > odroid-arm-defaults: update u-boot default to 2019.04
      > u-boot: update to work with 2019.04
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 12, 2019
  1. Layer Updates: sources/bitbake sources/meta-freescale-3rdparty source…

    kraj committed Apr 12, 2019
    …s/meta-odroid sources/meta-openembedded sources/openembedded-core
    
    * sources/bitbake aae15f3c...3aaf8d65 (1):
      > poky.ent: Removed "ECLIPSE" entity variables.
    
    * sources/meta-freescale-3rdparty a38e633...55356fd (1):
      > imx7s-warp: Update settings to use U-Boot 2019.04
    
    * sources/meta-odroid c96d4dd...890aeed (3):
      > armv8.inc: remove local copy
      > amlogic-meson64: use upstream armv8a.inc
      > linux-stable/5.0: update to 5.0.6
    
    * sources/meta-openembedded 4a9deabbc8...0477c76116 (37):
      > multipath-tools: fix up patch to avoid segfault
      > lua: upgrade from v5.3.4 to v5.3.5
      > networkmanager: rework musl build
      > fatresize_1.0.2.bb: Add recipe for fatresize command line tool
      > wireshark: upgrade 3.0.0 -> 3.0.1
      > chrony: update to 3.4
      > ledmon: control hard disk led for RAID arrays
      > squid: upgrade squid 3.5.28 -> 4.6
      > xbitmaps: upgrade 1.1.1 -> 1.1.2
      > xstdcmap: upgrade 1.0.3 -> 1.0.4
      > xsetroot: upgrade 1.1.1 -> 1.1.2
      > xrefresh: upgrade 1.0.5 -> 1.0.6
      > xrdb: upgrade 1.1.1 -> 1.2.0
      > xlsatoms: upgrade 1.1.2 -> 1.1.3
      > python-flask-socketio: move to meta-python directory
      > ristretto: upgrade 0.8.3 -> 0.8.4
      > parole: upgrade 1.0.1 -> 1.0.2
      > udisks2: upgrade 2.8.1 -> 2.8.2
      > analyze-suspend: update to 5.3
      > ell: remove recipe
      > wolfssl: update to 4.0.0
      > macchanger: update to 1.7.0
      > python-cryptography: Move linker flag to .inc
      > gd: fix compile error caused by -Werror=maybe-uninitialized
      > gvfs: remove executable permission from systemd user services
      > drbd: update to 9.0.17-1
      > drbd-utils: update to 9.8.0
      > babeld: update to 1.8.4
      > stunnel: update to 5.51
      > nanomsg: update to 1.1.5
      > open-isns: update to 0.99
      > usbredir: update to 0.8.0
      > keepalived: update to 2.0.15
      > cifs-utils: update to 6.9
      > fwknop: update to 2.6.10
      > phytool: update to v2
      > smcroute: update to 2.4.4
    
    * sources/openembedded-core 68bcd9790d...303ac64b89 (1):
      > Revert "nettle: fix ptest failure"
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  2. Layer Updates: sources/bitbake sources/meta-freescale sources/meta-in…

    kraj committed Apr 12, 2019
    …tel sources/meta-riscv sources/meta-ti sources/meta-yoe sources/openembedded-core
    
    * sources/bitbake 57e765e3...aae15f3c (3):
      > bitbake: Post release version bumnp to 1.43
      > bitbake: Update version to 1.42.0
      > utils: Let mkdirhier fail if existing path is not a folder
    
    * sources/meta-freescale 0dc8c940...f07fbd00 (26):
      > linux-qoriq/4.19: depends "bison-native:do_populate_sysroot"
      > dpdk: Add missing patch
      > qemu-qoriq: update to 798304e
      > vpp-core: add "-DCLIB_LOG2_CACHE_LINE_BYTES=6" to CFLAGS
      > ddy-phy :update recipes
      > optee-test-qoriq:update to 6690584
      > optee-os-qoriq:update to b7a1527
      > optee-client-qoriq:update to 0842873
      > linux-qoriq/4.9: remove recipes
      > linux-qoriq/4.14:update to 7e52442
      > linux-qoriq/4.19 : add recipes
      > ovs-dpdk: Upgrade version to 2.10
      > dpdk: update to c0fe1b9
      > restool: update to 8b1dd40
      > mc: Upgrade version to 10.14.3
      > dce: update to 0455555
      > aiopsl: update to 87d83d8
      > fmlib: update to 69a7047
      > eth-config: update to 6164664
      > cst: update to 2737b8b
      > openssl-qoriq: update to 472c9c3
      > uefi: update to de8834d
      > u-boot: update to 80b2d2b
      > rcw: update to f137787
      > mc-utils: update to eeb8972
      > atf: update to 7e34aeb
    
    * sources/meta-intel 1b4c07b1...cd2c3bfc (2):
      > linux-intel_4.14: update to v4.14.110
      > linux-yocto: drop 4.18 appends
    
    * sources/meta-riscv c3c8661...d77546d (1):
      > qemuriscv: Allow overriding RISCV_SBI_PLAT
    
    * sources/meta-ti 3e5525f7...f885d787 (3):
      > ti-gc320-libs: fix host contamination warnings
      > pruss-lld: fix host contamination warnings
      > osal: fix host contamination warnings
    
    * sources/meta-yoe e059302...7b45fba (4):
      > set USB detect delay to 4s
      > make update image name configurable
      > add options for update file name and usb det delay
      > autoformat changes
    
    * sources/openembedded-core e2b4b0580c...68bcd9790d (96):
      > u-boot: Upgrade from 2019.01 to 2019.04
      > makedepend: update to 1.0.6
      > fontconfig: update to 2.13.1
      > libyaml: update to 0.2.2
      > weston: upgrade 5.0.0 -> 6.0.0
      > cronie: update to 1.5.4
      > dropbear: update to 2019.78
      > harfbuzz:upgrade 2.3.1 -> 2.4.0
      > libinput: update to 1.13.0
      > createrepo-c: update to 0.12.2
      > libsecret: 0.18.8
      > wget: update to 1.20.2
      > libxcrypt: update to 4.4.4
      > libxmu: update to 1.1.3
      > librepo: update to 1.9.6
      > ffmpeg: update to 4.1.2
      > tar: update to 1.32
      > ethtool: update to 5.0
      > connman: update to 1.37
      > libxrandr: update to 1.5.2
      > libxvmc: update to 1.0.11
      > libxkbfile: update 1.1.0
      > libxdmcp: update to 1.1.3
      > x11perf: update to 1.6.1
      > libxext: update to 1.3.4
      > curl: update to 7.64.1
      > iproute2: update to 5.0.0
      > xtrans:upgrade 1.3.5 -> 1.4.0
      > libtirpc:upgrade 1.0.3 -> 1.1.4
      > sysprof:upgrade 3.30.2 -> 3.32.0
      > nss:upgrade 3.42.1 -> 3.43
      > libxxf86dga:upgrade 1.1.4 -> 1.1.5
      > libxft:upgrade 2.3.2 -> 2.3.3
      > libgpg-error:upgrade 1.35 -> 1.36
      > libatomic-ops:upgrade 7.6.8 -> 7.6.10
      > build-appliance-image: Update to master head revision
      > build-appliance-image: Update to warrior head revision
      > kernel-fitimage: support RISC-V
      > nettle: fix ptest failure
      > runqemu: do not check return code of tput
      > gcc-cross-canadian: Make baremetal specific code generic
      > image_types.bbclass: fix a race between the ubi and ubifs FSTYPES
      > e2fsprogs: Skip slow ptest tests
      > goarch.bbclass: Simplify logic
      > go.bbclass: Remove unused override
      > python3: add a tr-tr locale for test_locale ptest
      > perf: workaround the error cased by maybe-uninitialized warning
      > resulttool/manualexecution: Refactor and remove duplicate code
      > ccmake.bbclass: Fix up un-escaped quotes in output formatting
      > cogl: fix compile error caused by -Werror=maybe-uninitialized
      > kernel-devsrc: check for localversion files in the kernel source tree
      > ruby: add ptest
      > ruby: make ext module fiddle can compile success
      > systemd: install libnss-myhostname.so when myhostname be enabled
      > recipetool: add missed module
      > opkg: add ptest
      > sanity: check_perl_modules bug fix
      > insane.bbclass: Trigger unrecognzed configure option for meson
      > gstreamer1.0-python: rework gobject-introspection handling
      > gst-plugins: move 'inherit gobject-introspection' to recipes supporting GI
      > glib-networking: upgrade 2.58.0 -> 2.60.1
      > libsoup-2.4: use gobject-introspection.bbclass on/off mechanism
      > atk: use gobject-introspection.bbclass on/off mechanism
      > at-spi2-core: use gobject-introspection.bbclass on/off mechanism
      > pango: use gobject-introspection.bbclass on/off mechanism
      > clutter-gtk-1.0: use gobject-introspection.bbclass on/off mechanism
      > libdazzle: use gobject-introspection.bbclass on/off mechanism
      > json-glib: use gobject-introspection.bbclass on/off mechanism
      > gdk-pixbuf: use gobject-introspection.bbclass on/off mechanism
      > libmodulemd: use gobject-introspection.bbclass on/off mechanism
      > gobject-introspection: auto-enable/-disable gobject-introspection for meson
      > elfutils: remove Elfutils-Exception and include GPLv2 for shared libraries
      > python3: Fix ptest output parsing
      > python3: Avoid hanging tests
      > pseudo: Update to gain key bugfixes
      > busybox: Use PTEST binary directory
      > util-linux: Use PTEST binary directory
      > ptest.bbclass: Add feature to populate a binary directory
      > update-alternatives.bbclass: Add function to get metadata
      > goarch.bbclass: use MACHINEOVERRIDES and simplify go_map_arm()
      > go.bbclass: Export more GO* environment variables
      > insane: fix gettext dependency warning
      > systemd: fix predictable network interface names in initrd
      > sstate.bbclass: Use bb.utils.to_boolean() for BB_NO_NETWORK
      > resulttool/manualexecution: Enable creation of configuration option file
      > resulttool/manualexecution: Enable configuration options selection
      > cmake: Support Eclipse and other cmake generators
      > bind: upgrade 9.11.5 -> 9.11.5-P4
      > Revert "mdadm: fix gcc8 maybe-uninitialized/format-overflow warning"
      > linux-yocto/4.18: remove versioned recipes
      > linux-yocto/5.0: tweak qemuarm -tiny configuration
      > qemumips: Enable the poweroff driver
      > linux-yocto/4.18: update to v4.18.33
      > linux-yocto-tiny/4.18: point KBRANCH to 4.18
      > linux-yocto/5.0: update CGL audit configuration fragment
      > linux-yocto-rt/4.19: fix duplicate TIF_NEED_RESCHED_LAZY
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 10, 2019
  1. Layer Updates: sources/bitbake sources/meta-freescale sources/openemb…

    kraj committed Apr 10, 2019
    …edded-core
    
    * sources/bitbake 30fe86d2...57e765e3 (1):
      > utils: Make prune_suffix prune a suffix
    
    * sources/meta-freescale 3d7696d9...0dc8c940 (1):
      > kernel-module-qcacld-lea: Mark imx specific
    
    * sources/openembedded-core d7c0e9d180...e2b4b0580c (14):
      > oeqa/utils/qemurunner: Fix typo in previous commit
      > ptest-runner: Add several logging fixes
      > openssh/util-linux/python*: Ensure ptest output is unbuffered
      > busybox: Enable domain search list support
      > patch/insane: Rework patch fuzz handling
      > lib/oe/utils: Make prune_suffix prune a suffix
      > autoconf: update runtime perl module dependencies
      > sanity: clarify error message if TMPDIR moves
      > ghostscript: Fix 3 CVEs
      > xf86-video-vesa: Refuse to run on UEFI machines
      > libgcc: Create linux-musleabihf and linux-gnueabihf symlinks
      > devtool: standard: Handle exporting generated config fragments
      > ccmake.bbclass: Create a cml1 style class for the CMake curses UI
      > cmake-native: Enable ccmake by default and depend on ncurses
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 9, 2019
  1. Layer Updates: sources/meta-openembedded

    kraj committed Apr 9, 2019
    * sources/meta-openembedded 0435c9e193...4a9deabbc8 (49):
      > lcdproc: Fix parallel build
      > nuttcp: update to 7.3.3
      > gnome-desktop3: Disable libseccomp for all archs
      > fping: update to 4.2
      > redis: Fix ocasional parallel build failure
      > alsa-oss: Upgrade to 1.1.8
      > networkmanager: Fix build with clang
      > wolfssl: update to 3.15.8 and use github SRC_URI
      > ncmpc: Rename artist_screen to library_screen
      > python-cryptography: Bump from 2.4.1 to 2.6.1
      > doxygen: Make it build with ninja 1.9.0
      > libfann: Initial commit
      > mycroft: Initial commit
      > python3-xxhash: Initial commit
      > python3-pocketsphinx: Initial commit
      > python3-pyfann2: Initial commit
      > python3-pyaudio: Initial commit
      > czmq: bump version 4.1.1 => 4.2.0
      > cppzmq: bump version 4.2.3 => 4.3.0
      > zeromq: bump version 4.2.5 => 4.3.1
      > libvncserver: enable split client/server packages
      > lockfile-progs: upgrade 0.1.17 -> 0.1.18
      > mcelog: upgrade 161 -> 162
      > libedit: upgrade 20181209-3.1 -> 20190324-3.1
      > augeas: upgrade 1.10.1 -> 1.11.0
      > gnome-desktop3: rework gobject-introspection handling
      > gnome-desktop3: remove gconf from DEPENDS
      > gvfs: Fix missing executable permission flags for files in libexec
      > libpeas: rework gobject-introspection handling
      > python*-requests: Update 2.20.1 -> 2.21.0
      > libmodbus: start to prefer version 3.1.4 as default
      > cpprest: fix build failure on 32bit systems, with upstream merged patch
      > dracut: fix udevdir not found
      > ipsec-tools: add missing CVE tags to patches
      > openldap: add missing CVE tag to patch
      > Fix build error for armeb.
      > rrdtool: fix build by disabling docs
      > tcpreplay: update to version 4.3.2
      > gvfs: fix configure options and DDEPENDS
      > imagemagic: upgrade to 7.0.8-35
      > networkmanager: fix build with musl
      > networkmanager: Fix upstream regex for 1.16
      > xfce4-screenshooter: upgrade 1.9.4 -> 1.9.5
      > Rsyslog: Add mmjsonparse to PACKAGECONFIG
      > python-flask-socketio
      > python-socketio: add recipe
      > python-engineio: add recipe
      > android-tools-conf: Make sure /dev/pts/0 exists
      > android-tools-conf: fix typo
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 8, 2019
  1. Layer Updates: sources/meta-96boards sources/meta-freescale sources/m…

    kraj committed Apr 8, 2019
    …eta-freescale-3rdparty sources/meta-intel sources/meta-raspberrypi
    
    * sources/meta-96boards e176678...2414a75 (1):
      > Merge pull request #304 from YoeDistro/yoe/mut
    
    * sources/meta-freescale 34632727...3d7696d9 (1):
      > README: use pull requests for contributing
    
    * sources/meta-freescale-3rdparty 2e80c70...a38e633 (1):
      > README: use pull requests for contributing
    
    * sources/meta-intel f5ebaf87...1b4c07b1 (1):
      > ixgbe: 5.5.3 -> 5.5.5
    
    * sources/meta-raspberrypi 490a444...9ceb84e (1):
      > linux_raspberrypi_4.19: Update to 4.19.32
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 6, 2019
  1. Layer Updates: sources/meta-freescale sources/openembedded-core

    kraj committed Apr 6, 2019
    * sources/meta-freescale 6ec4c4b2...34632727 (9):
      > qcacld: Fix missing firmware and tools packages
      > firmware-qca: Upgrade to 2.0.1
      > kernel-module-qca6174: Add support for QCA6174 on i.MX 8 Series
      > kernel-module-qca9377: Add support for QCA9377 on i.MX 7ULP
      > qca-tools: Add fcc_tools
      > firmware-qca6174: Add support for QCA6174 on i.MX 8 Series
      > firmware-qca9377: Add support for QCA9377 on i.MX 7ULP
      > imx-base.inc: Add QCA module support for 6174 and 9377
      > imx7ulpevk.conf: Add support for QCA9377
    
    * sources/openembedded-core 84c6a992e1...d7c0e9d180 (14):
      > gtk+: update for new catalog path
      > xmlto: clean up RDEPENDS
      > xmlto: remove XML catalog
      > asciidoc: use correct XML catalog path
      > libxslt: update for new catalog path
      > docbook-xsl: use xmlcatalog
      > docbook-xsl: neaten documentation
      > docbook-xml: use xmlcatalog class
      > xmlcatalog: new class to update the XML catalogue
      > lttng-tools: lttng-tools works fine on musl no need to remove it
      > lttng-ust: lttng-ust works fine on musl no need to remove it
      > lttng-ust: backport musl workaround
      > lttng-tools: improve ptest and test suite
      > base/pixbufcache: Remove obsolete sstatecompletions code
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  2. site.conf: Dont enable sdl in qemu explicitly

    kraj committed Apr 6, 2019
    enabling sdl is not necessary and it interferes with autotest on
    machines which dont have graphics enabled
    
    Pin make to use 1.5 CPU load, this helps in compiling large
    pieces e.g. chromium, qtwebkit in parallel and not run out of cpu
    or memory resources
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Commits on Apr 5, 2019
  1. Layer Updates: sources/meta-browser sources/meta-raspberrypi sources/…

    kraj committed Apr 5, 2019
    …meta-rust
    
    * sources/meta-browser 85c83ba...2848153 (1):
      > chromium: Update to 73.0.3683.103
    
    * sources/meta-raspberrypi 426eee1...490a444 (2):
      > layer.conf: Add warrior to compatible release series
      < layer.conf: Add warrior to compatible release series
    
    * sources/meta-rust 9a077b2...0d03c20 (1):
      > Merge pull request #238 from YoeDistro/yoe/mut
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
  2. gitmodules: Switch back meta-rust and meta-raspberrypi to master

    kraj committed Apr 5, 2019
    Warrior is now supported release in these repos
    
    Signed-off-by: Khem Raj <raj.khem@gmail.com>
Older
You can’t perform that action at this time.