Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Layer Updates: sources/bitbake sources/meta-intel sources/meta-opene… #231

Merged
merged 2 commits into from Nov 4, 2019

Conversation

@kraj
Copy link
Contributor

kraj commented Oct 30, 2019

…mbedded sources/meta-qcom sources/meta-qt5 sources/openembedded-core

  • sources/bitbake 5d83d828...f7a97360 (13):

    tests/fetch: add test for fetching shallow revs
    fetch2/git: fetch shallow revs when needed
    bitbake: ConfHandler: Use with to manage filehandle lifetime
    bitbake: prserv/serv: Use with while reading pidfile
    bitbake: contrib/vim: Add copyright and license notice
    bitbake: contrib/vim: handle shell indenting
    bitbake: contrib/vim: indenting for assignments; tweak Python indenting
    bitbake: contrib/vim: renaming & comments
    bitbake: contrib/vim: don't redeclare indenter
    bitbake: contrib/vim: Special handling of bb.fatal
    bitbake: contrib/vim: More Python indenting; move indent file to correct directory
    bitbake: contrib/vim: Modify Python indentation to work with 'python do_task {'
    bitbake: contrib/vim: initial commit, with unmodified code from indent/python.vim

  • sources/meta-intel eacd8eb9...1a141241 (3):

    intel-skylake-64: include mediasdk and media-driver in HWCODECS
    gma500-gfx-check: remove
    dldt-inference-engine: enable vpu by default

  • sources/meta-openembedded d06f1eeb34...c986cbed93 (68):

    vlc: Upgrade 3.0.6 -> 3.0.8
    webrtc-audio-processing: Upgrade 0.3 -> 0.3.1
    gstd: Fix the version number
    gerbera: Upgrade 1.3.0 -> 1.3.2
    rsyslog: upgrade from v8.1908.0 to v8.1910.0
    postfix: upgrade 3.4.5 -> 3.4.7
    keepalived: upgrade 2.0.16 -> 2.0.19
    dbus-broker: add patch to fix build with musl libc
    dbus-broker: build with SELinux if it's enabled via DISTRO_FEATURES
    dbus-broker: backport patches from master
    dbus-broker: 19 -> 21
    klibc: Upgrade 2.0.6 -> 2.0.7
    xmlsec1: upgrade 1.2.28 -> 1.2.29
    python-daemonize: upgrade 2.4.7 -> 2.5.0
    python-can: upgrade 2.2.1 -> 3.3.2
    python-bitarray: upgrade 0.8.3 -> 1.0.1
    network-manager-applet: upgrade 1.8.22 -> 1.8.23 / build with meson / cleanup
    gnome-system-monitor: upgrade 3.32.0 -> 3.32.1
    gspell: upgrade 1.8.1 -> 1.8.2
    gnome-bluetooth: upgrade 3.32.1 -> 3.34.0
    gnome-desktop3: upgrade 3.34.0 -> 3.34.1
    gnome-menus3: upgrade 3.10.1 -> 3.32.0
    gtksourceview4: upgrade 4.2.0 -> 4.4.0
    dconf-editor: upgrade 3.32.0 -> 3.34.0
    dconf: extend to native build for upcoming gdm
    zenity: rework recipe
    gnome-help.bbclass: Handle gnome-help files with new distro feature 'helpfiles'
    yelp: use itstool.bbclass
    yelp-xsl: use itstool.bbclass
    yelp-tools: use itstools.bbclass
    itstool: rework native shebang and add class to make native itstool work
    gpsd: Stop depending on chrpath-native
    gpsd: Backport a memory leak fix
    pavucontrol: polish the recipe
    open-vm-tools: Fix build by removing deprecated G_INLINE_FUNC
    mycroft: Fixup remaining issues
    s-suite: push SRCREV to version 3.6
    xorriso: upgrade 1.4.0 -> 1.5.0
    f2fs-tools: upgrade 1.11.0 -> 1.13.0
    fuse3: upgrade 3.6.2 -> 3.7.0
    simple-mtpfs: upgrade to 0.3.0.
    owfs: upgrade 3.2p2 -> 3.2p3
    Python: ujson: Clarify BSD license variant
    Python: pyusb: Clarify BSD license variant
    Python: pyhamcrest: Clarify BSD license variant
    Python: psutil: Clarify BSD license variant
    Python: oauthlib: Clarify BSD license variant
    Python: flask scrypt: Clarify BSD license variant
    Python: ndg httpsclient: Clarify BSD license variant
    Python: jsonpatch: Clarify BSD license variant
    Python: flask bcrypt: Clarify BSD license variant
    Python: dnspython: Clarify BSD license variant
    Python: markdown: Clarify BSD license variant
    Python: xxhash: Clarify BSD license variant
    Python: jsonpointer: Clarify BSD license variant
    Python: flask user: Clarify BSD license variant
    Python: babel: Clarify BSD license variant
    libgusb: initial add 0.3.0+
    libsigc++-3: initial add 3.0.0
    glibmm: upgrade 2.60.0 -> 2.62.0
    yelp: initial add 3.34.0
    yelp-tools: initial add 3.32.2
    yelp-xsl: initial add 3.34.0
    appstream-glib: initial add 0.7.16
    libstemmer: initial add 2.0.0
    geany-plugins: upgrade 1.34 -> 1.36
    geany: upgrade 1.34.1 -> 1.36
    gtkmm3: upgrade 3.24.1 -> 3.24.2

  • sources/meta-qcom 96aeeef...0d38363 (1):

    Merge pull request #121 from alimon/master_db845c_bt

  • sources/meta-qt5 911b346...653e12f (2):

    libqofono: bump SRCREV and add a fix for voicecall
    qtbase: Add PACKAGECONFIG for lttng

  • sources/openembedded-core 1a8d18eeee...b91b30c09f (15):

    qemu: Avoid potential build configuration contamination
    gcc: Remove stale gcc 8 patchfile
    nspr: Upgrade 4.21 -> 4.23
    stress-ng: Upgrade 0.10.00 -> 0.10.08
    screen: Upgrade 4.6.2 -> 4.7.0
    squashfs-tools: Upgrade to 4.4
    nfs-utils: Improve handling when no exported fileysystems
    python: fix CVE-2019-16935
    python3: fix CVE-2019-16935
    unfs3: fixed the issue that unfsd consumes 100% CPU
    bind: fix CVE-2019-6471 and CVE-2018-5743
    buildhistory-analysis: filter out -src changes by default
    meta: add missing description in recipes-gnome
    meta: update and add missing homepage/bugtracker links
    gsettings-desktop-schemas: upgrade 3.32.0 -> 3.34.0

Signed-off-by: Khem Raj raj.khem@gmail.com

kraj added 2 commits Oct 30, 2019
…bedded sources/meta-qcom sources/meta-qt5 sources/openembedded-core

* sources/bitbake 5d83d828...f7a97360 (13):
  > tests/fetch: add test for fetching shallow revs
  > fetch2/git: fetch shallow revs when needed
  > bitbake: ConfHandler: Use with to manage filehandle lifetime
  > bitbake: prserv/serv: Use with while reading pidfile
  > bitbake: contrib/vim: Add copyright and license notice
  > bitbake: contrib/vim: handle shell indenting
  > bitbake: contrib/vim: indenting for assignments; tweak Python indenting
  > bitbake: contrib/vim: renaming & comments
  > bitbake: contrib/vim: don't redeclare indenter
  > bitbake: contrib/vim: Special handling of bb.fatal
  > bitbake: contrib/vim: More Python indenting; move indent file to correct directory
  > bitbake: contrib/vim: Modify Python indentation to work with 'python do_task {'
  > bitbake: contrib/vim: initial commit, with unmodified code from indent/python.vim

* sources/meta-intel eacd8eb9...1a141241 (3):
  > intel-skylake-64: include mediasdk and media-driver in HWCODECS
  > gma500-gfx-check: remove
  > dldt-inference-engine: enable vpu by default

* sources/meta-openembedded d06f1eeb34...c986cbed93 (68):
  > vlc: Upgrade 3.0.6 -> 3.0.8
  > webrtc-audio-processing: Upgrade 0.3 -> 0.3.1
  > gstd: Fix the version number
  > gerbera: Upgrade 1.3.0 -> 1.3.2
  > rsyslog: upgrade from v8.1908.0 to v8.1910.0
  > postfix: upgrade 3.4.5 -> 3.4.7
  > keepalived: upgrade 2.0.16 -> 2.0.19
  > dbus-broker: add patch to fix build with musl libc
  > dbus-broker: build with SELinux if it's enabled via DISTRO_FEATURES
  > dbus-broker: backport patches from master
  > dbus-broker: 19 -> 21
  > klibc: Upgrade 2.0.6 -> 2.0.7
  > xmlsec1: upgrade 1.2.28 -> 1.2.29
  > python-daemonize: upgrade 2.4.7 -> 2.5.0
  > python-can: upgrade 2.2.1 -> 3.3.2
  > python-bitarray: upgrade 0.8.3 -> 1.0.1
  > network-manager-applet: upgrade 1.8.22 -> 1.8.23 / build with meson / cleanup
  > gnome-system-monitor: upgrade 3.32.0 -> 3.32.1
  > gspell: upgrade 1.8.1 -> 1.8.2
  > gnome-bluetooth: upgrade 3.32.1 -> 3.34.0
  > gnome-desktop3: upgrade 3.34.0 -> 3.34.1
  > gnome-menus3: upgrade 3.10.1 -> 3.32.0
  > gtksourceview4: upgrade 4.2.0 -> 4.4.0
  > dconf-editor: upgrade 3.32.0 -> 3.34.0
  > dconf: extend to native build for upcoming gdm
  > zenity: rework recipe
  > gnome-help.bbclass: Handle gnome-help files with new distro feature 'helpfiles'
  > yelp: use itstool.bbclass
  > yelp-xsl: use itstool.bbclass
  > yelp-tools: use itstools.bbclass
  > itstool: rework native shebang and add class to make native itstool work
  > gpsd: Stop depending on chrpath-native
  > gpsd: Backport a memory leak fix
  > pavucontrol: polish the recipe
  > open-vm-tools: Fix build by removing deprecated G_INLINE_FUNC
  > mycroft: Fixup remaining issues
  > s-suite: push SRCREV to version 3.6
  > xorriso: upgrade 1.4.0 -> 1.5.0
  > f2fs-tools: upgrade 1.11.0 -> 1.13.0
  > fuse3: upgrade 3.6.2 -> 3.7.0
  > simple-mtpfs: upgrade to 0.3.0.
  > owfs: upgrade 3.2p2 -> 3.2p3
  > Python: ujson: Clarify BSD license variant
  > Python: pyusb: Clarify BSD license variant
  > Python: pyhamcrest: Clarify BSD license variant
  > Python: psutil: Clarify BSD license variant
  > Python: oauthlib: Clarify BSD license variant
  > Python: flask scrypt: Clarify BSD license variant
  > Python: ndg httpsclient: Clarify BSD license variant
  > Python: jsonpatch: Clarify BSD license variant
  > Python: flask bcrypt: Clarify BSD license variant
  > Python: dnspython: Clarify BSD license variant
  > Python: markdown: Clarify BSD license variant
  > Python: xxhash: Clarify BSD license variant
  > Python: jsonpointer: Clarify BSD license variant
  > Python: flask user: Clarify BSD license variant
  > Python: babel: Clarify BSD license variant
  > libgusb: initial add 0.3.0+
  > libsigc++-3: initial add 3.0.0
  > glibmm: upgrade 2.60.0 -> 2.62.0
  > yelp: initial add 3.34.0
  > yelp-tools: initial add 3.32.2
  > yelp-xsl: initial add 3.34.0
  > appstream-glib: initial add 0.7.16
  > libstemmer: initial add 2.0.0
  > geany-plugins: upgrade 1.34 -> 1.36
  > geany: upgrade 1.34.1 -> 1.36
  > gtkmm3: upgrade 3.24.1 -> 3.24.2

* sources/meta-qcom 96aeeef...0d38363 (1):
  > Merge pull request #121 from alimon/master_db845c_bt

* sources/meta-qt5 911b346...653e12f (2):
  > libqofono: bump SRCREV and add a fix for voicecall
  > qtbase: Add PACKAGECONFIG for lttng

* sources/openembedded-core 1a8d18eeee...b91b30c09f (15):
  > qemu: Avoid potential build configuration contamination
  > gcc: Remove stale gcc 8 patchfile
  > nspr: Upgrade 4.21 -> 4.23
  > stress-ng: Upgrade 0.10.00 -> 0.10.08
  > screen: Upgrade 4.6.2 -> 4.7.0
  > squashfs-tools: Upgrade to 4.4
  > nfs-utils: Improve handling when no exported fileysystems
  > python: fix CVE-2019-16935
  > python3: fix CVE-2019-16935
  > unfs3: fixed the issue that unfsd consumes 100% CPU
  > bind: fix CVE-2019-6471 and CVE-2018-5743
  > buildhistory-analysis: filter out -src changes by default
  > meta: add missing description in recipes-gnome
  > meta: update and add missing homepage/bugtracker links
  > gsettings-desktop-schemas: upgrade 3.32.0 -> 3.34.0

Signed-off-by: Khem Raj <raj.khem@gmail.com>
…es/meta-ti sources/openembedded-core

* sources/meta-freescale 218e7c48...c3e3303e (1):
  > weston: fix the test condition for agl builds

* sources/meta-openembedded c986cbed93...e0daf6f8e0 (88):
  > iwd: Use python3 variant of docutils during build
  > python-docutils: Upgrade to 0.15.2
  > poco: Fix build on risc-v
  > ibus: initial add 1.5.21
  > miniupnpd: Build config.h before full build
  > syslog-ng: change conf files to version 3.19
  > syslog-ng: add volatile directory init for systemd
  > miniupnpd: Update to 2.1.20191006
  > ledmon: upgrade to 0.93
  > libtorrent: upgrade 0.13.7 -> 0.13.8
  > iwd: upgrade 0.20 -> 0.23
  > zabbix: upgrade 4.2.6 -> 4.2.7
  > freeradius: set CLEANBROKEN
  > rtorrent: upgrade 0.9.7 -> 0.9.8
  > python-pyfirmata: upgrade 1.0.3 -> 1.1.0
  > python-pyexpect: upgrade 1.0.17 -> 1.0.19
  > python-pycryptodome: upgrade 3.4.11 -> 3.9.0
  > python-pybind11: upgrade 2.2.3 -> 2.4.3
  > python-prompt-toolkit: upgrade 2.0.4 -> 2.0.10
  > python-progress: upgrade 1.4 -> 1.5
  > python-pint: upgrade 0.8.1 -> 0.9
  > python-periphery: upgrade 1.1.1 -> 2.0.0
  > python-pathlib2: upgrade 2.3.4 -> 2.3.5
  > python-parse: upgrade 1.8.4 -> 1.12.1
  > python-lazy-object-proxy: upgrade 1.3.1 -> 1.4.3
  > python-hpack: add recipe
  > python-hyperframe: add recipe
  > python-h2: add recipe
  > python-priority: add recipe
  > paho-mqtt-c: upgrade 1.3.0 -> 1.3.1
  > colord-gtk: initial add 0.2.0
  > colord: initial add 1.4.4
  > lmsensors: upgrade 3.5.0 -> 3.6.0
  > phoronix-test-suite: upgrade 8.8.1 -> 9.0.1
  > libhugetlbfs: upgrade 2.21 -> 2.22
  > iozone3: upgrade 484 -> 487
  > libowfat: upgrade 0.31 -> 0.32
  > python-javaobj-py3: upgrade 0.2.4 -> 0.3.0
  > python-isort: upgrade 4.3.4 -> 4.3.21
  > python-intervals: upgrade 1.5.4 -> 1.10.0
  > python-future: upgrade 0.16.0 -> 0.18.2
  > python-evdev: upgrade 0.7.0 -> 1.2.0
  > python-engineio: upgrade 3.9.3 -> 3.10.0
  > python-dnspython: upgrade 1.15.0 -> 1.16.0
  > python-simplejson: enable native and nativesdk
  > mdns: Mark as incompatible with musl
  > mtr: upgrade 0.92 -> 0.93
  > wireshark: upgrade 3.0.3 -> 3.0.6
  > unbound: upgrade 1.9.2 -> 1.9.4
  > nbd: upgrade 3.19 -> 3.20
  > htpdate: upgrade 1.2.1 -> 1.2.2
  > babeld: upgrade 1.8.4 -> 1.9.1
  > libiio: add python3 packageconfig
  > libgphoto2: Remove obsolete HAL files
  > poco: Upgrade 1.9.0 -> 1.9.4
  > libmicrohttpd: Upgrade 0.9.66 -> 0.9.67
  > xf86-input-tslib: Upgrade 0.0.6 -> 0.0.7
  > packagegroup-meta-networking: Exclude nonbuilding recipes with musl
  > cgdb: Upgrade 0.6.8 -> 0.7.1
  > znc: upgrade 1.7.4 -> 1.7.5
  > iscsi-initiator-utils: upgrade 2.0.877 -> 2.0.878
  > dhcpcd: upgrade 8.0.2 -> 8.1.1
  > nodejs: allow use of system libuv (and make default)
  > corosync: upgrade 2.4.4 -> 2.4.5
  > grpc: upgrade 1.24.1 -> 1.24.3
  > libuv: update to 1.33.1
  > openwsman: Upgrade 2.6.9 -> 2.6.11
  > pegtl: Upgrade 2.1.4 -> 2.8.1
  > libnss-nisplus: Upgrade to the latest upstream git
  > libdivecomputer: Upgrade to 0.6.0
  > php: Upgrade 7.3.9 -> 7.3.11
  > nodejs: Upgrade 10.16.3 -> 10.17.0
  > doxygen: Upgrade 1.8.15 -> 1.8.16
  > flashrom: Upgrade 1.0 -> 1.1
  > nodejs: allow use of system c-ares (and make default)
  > dbus-broker: build with libaudit if selinux is enabled
  > dovecot: Upgrade 2.2.36.3 -> 2.2.36.4
  > cim-schema: Remove duplicate file
  > usrsctp: Upgrade to a more recent git snapshot
  > lldpd: Upgrade 1.0.3 -> 1.0.4
  > unicode-ucd: Set correct SUMMARY and HOMEPAGE
  > pure-ftpd: upgrade 1.0.47 -> 1.0.49
  > autofs: upgrade 5.1.5 -> 5.1.6
  > gmime: upgrade 3.2.3 -> 3.2.4
  > poppler: upgrade 0.80.0 -> 0.82.0
  > unicode-ucd: initial add 12.1.0
  > opencv: Enable pkg-config .pc file generation
  > python3-pillow: update to 6.2.1

* sources/meta-ti 6514f160...320a03e4 (12):
  > am335x-evm: bump max_leb_cnt
  > arm-trusted-firmware: update to 2.2
  > u-boot-ti-staging: update to ti2019.05-rc1
  > linux-ti-staging: update to ti2019.05-rc1
  > am437x-evm: bump max_leb_cnt
  > ipc-lld: inherit update-alternatives for softlink
  > ti-sgx-ddk-um: update SRCREV to pick up Mesa-based EGL/GLES libraries
  > ti-pdk-build-rtos: SRCREV update to 01.00.00.14B
  > ti-ipc: Update to new version 3.50.04.08
  > ti-img-rogue-driver: Update srcrev to pick latest
  > kselftests: re-add ptp into main RDEPENDS
  > board-rtos: SRCREV update to 01.00.10.06G

* sources/openembedded-core b91b30c09f...992cec44ad (32):
  > coreutils: Move stdbuf into an own package coreutils-stdbuf
  > git: cleanup man install
  > git: some tools are no longer perl, so move to main recipe
  > cve-check: ensure all known CVEs are in the report
  > ltp: Fix overcommit_memory failure
  > ell: update to 0.25
  > mdadm: fix do_package failed when changed local.conf but not cleaned
  > libxslt: fix CVE-2019-18197
  > libtiff: fix CVE-2019-17546
  > elfutils: disable bzip
  > elfutils: add PACKAGECONFIG for compression algorithms
  > libmodulemd-v1: update to 1.8.16
  > btrfs-tools: update to 5.3
  > gcr: remove intltool-native
  > gcr: update to 3.34.0
  > ncurses: fix CVE-2019-17594, CVE-2019-17595
  > kernel-fitimage: introduce FIT_SIGN_ALG
  > sudo: Fix fetching sources
  > systemtap: support usrmerge
  > IMAGE_LINGUAS_COMPLEMENTARY: auto-add language packages other than locales
  > makedevs: fix invalidScanfFormatWidth to prevent overflowing usr_buf
  > makedevs: fix format strings in makedevs.c in print statements
  > libsdl2: Fix build failure when using mesa 19.2.1
  > binutils: fix CVE-2019-17451
  > binutils: fix CVE-2019-17450
  > ofono: tidy up the recipe
  > wpa-supplicant: fix CVE-2019-16275
  > squashfs-tools: clean up compile/install tasks
  > squashfs-tools: remove redundant source checksums
  > python3-numpy: Stop shipping manual config files
  > libcap-ng: undefined reference to `pthread_atfork'
  > gnu-efi: Upgrade 3.0.9 -> 3.0.10

Signed-off-by: Khem Raj <raj.khem@gmail.com>
@cbrake cbrake merged commit 180dc12 into master Nov 4, 2019
1 check passed
1 check passed
continuous-integration/drone/pr Build is passing
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.