Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Layer Updates: sources/meta-96boards sources/meta-freescale sources/… #234

Merged
merged 3 commits into from Nov 23, 2019

Conversation

@kraj
Copy link
Contributor

kraj commented Nov 20, 2019

…meta-openembedded sources/meta-ti

  • sources/meta-96boards 402097e...a96a1dd (1):

    Merge pull request #321 from YoeDistro/yoe/mut

  • sources/meta-freescale de48050f...0be39721 (20):

    linux-fslc-imx_4.9: resolve version for cve scans
    linux-fslc-imx_4.9-1.0.x: replace patchset to the one from stable
    aiopsl: fix missing path
    t4240rdb-64b: update UBOOT_CONFIG
    t4240rdb : update UBOOT_CONFIG
    t2080rdb-64b : update UBOOT_CONFIG
    t2080rdb : update UBOOT_CONFIG
    t1042d4rdb: update UBOOT_CONFIG
    t1042d4rdb-64b: update UBOOT_CONFIG
    t1024rdb: update UBOOT_CONFIG
    t1024rdb-64b: update UBOOT_CONFIG
    p5040ds-64b: update UBOOT_CONFIG
    p5040ds: update UBOOT_CONFIG
    p4080ds: update UBOOT_CONFIG
    p3041ds: update UBOOT_CONFIG
    p2041rdb: update UBOOT_CONFIG
    p2020rdb: update UBOOT_CONFIG
    p1020rdb: update UBOOT_CONFIG
    mpc8548cds: update UBOOT_CONFIG
    weston-init: Keep the logic to edit weston.ini to meta-freescale

  • sources/meta-openembedded 55de2d06ad...53d431639a (44):

    upm: Link with libatomic on clang/x86
    grpc: Link with libatomic on clang/x86
    libkcapi: Move static inline functions where used
    libldb: Do not require the "pam" distro feature to be enabled
    python3-jsonrpcserver: add recipe
    python3-apply-defaults: add recipe
    libtorrent: Disable instrumentation on ppc/mips
    libtorrent: Drop 64bit atomics patch for mips/ppc
    rsyslog: Dont force enable atomic builtins on mips
    libmad: Define O2 for all arches as default optimization
    evolution-data-server: add upstream-version-is-even & gsettings to inherit
    gmime: upgrade 3.2.4 -> 3.2.5
    gmime: move to meta-oe/recipes-gnome
    gmime: cleanup recipe
    gnome-terminal: Fix build for musl
    gnome-terminal: re-add 3.34.2
    fluidsynth: upgrade 2.0.7 -> 2.0.9
    surf: Add a simple web browser
    gperftools: Convert static and libunwind support to packageconfig
    pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t
    poppler: Extend the c/c++ flags fix to cover clang
    nginx: fix install paths
    flatbuffers: update to 1.11.0
    libgpiod: put gpio utils into an actual separate package
    evince: Fix build with clang
    python-jsonschema: add PACKAGECONFIG nongpl option
    python-jsonschema: multiple fixes
    squid: upgrade 4.6 -> 4.9
    ltrace: Remove RDEPENDS on elfutils
    gnome-settings-daemon: initial add 3.34.1
    libwacom: initial add 0.33
    libgweather: initial add 3.34.0
    geocode-glib: initial add 3.26.1
    nautilus: upgrade 3.18.5 -> 3.34.1
    tracker: initial add 2.3.1
    gnome-autoar: inital add 0.2.3
    gexiv2: initial add 0.12.0
    file-roller: inital add 3.32.2
    evince: upgrade 3.28.2 -> 3.34.1
    gnome-font-viewer: initial add 3.34.0
    evolution-data-server: upgrade 3.26.6 -> 3.34.1 and rework
    evolution-data-server: give up fine grained -dev/-dbg packages
    gtksourceview2: remove
    gedit: upgrade 2.30.4 -> 3.34.0

  • sources/meta-ti 7e03fc79...84249530 (1):

    kselftests: Disable for riscv

Signed-off-by: Khem Raj raj.khem@gmail.com

…eta-openembedded sources/meta-ti

* sources/meta-96boards 402097e...a96a1dd (1):
  > Merge pull request #321 from YoeDistro/yoe/mut

* sources/meta-freescale de48050f...0be39721 (20):
  > linux-fslc-imx_4.9: resolve version for cve scans
  > linux-fslc-imx_4.9-1.0.x: replace patchset to the one from stable
  > aiopsl: fix missing path
  > t4240rdb-64b: update UBOOT_CONFIG
  > t4240rdb : update UBOOT_CONFIG
  > t2080rdb-64b : update UBOOT_CONFIG
  > t2080rdb : update UBOOT_CONFIG
  > t1042d4rdb: update UBOOT_CONFIG
  > t1042d4rdb-64b: update UBOOT_CONFIG
  > t1024rdb: update UBOOT_CONFIG
  > t1024rdb-64b: update UBOOT_CONFIG
  > p5040ds-64b: update UBOOT_CONFIG
  > p5040ds: update UBOOT_CONFIG
  > p4080ds: update UBOOT_CONFIG
  > p3041ds: update UBOOT_CONFIG
  > p2041rdb: update UBOOT_CONFIG
  > p2020rdb: update UBOOT_CONFIG
  > p1020rdb: update UBOOT_CONFIG
  > mpc8548cds: update UBOOT_CONFIG
  > weston-init: Keep the logic to edit weston.ini to meta-freescale

* sources/meta-openembedded 55de2d06ad...53d431639a (44):
  > upm: Link with libatomic on clang/x86
  > grpc: Link with libatomic on clang/x86
  > libkcapi: Move static inline functions where used
  > libldb: Do not require the "pam" distro feature to be enabled
  > python3-jsonrpcserver: add recipe
  > python3-apply-defaults: add recipe
  > libtorrent: Disable instrumentation on ppc/mips
  > libtorrent: Drop 64bit atomics patch for mips/ppc
  > rsyslog: Dont force enable atomic builtins on mips
  > libmad: Define O2 for all arches as default optimization
  > evolution-data-server: add upstream-version-is-even & gsettings to inherit
  > gmime: upgrade 3.2.4 -> 3.2.5
  > gmime: move to meta-oe/recipes-gnome
  > gmime: cleanup recipe
  > gnome-terminal: Fix build for musl
  > gnome-terminal: re-add 3.34.2
  > fluidsynth: upgrade 2.0.7 -> 2.0.9
  > surf: Add a simple web browser
  > gperftools: Convert static and libunwind support to packageconfig
  > pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t
  > poppler: Extend the c/c++ flags fix to cover clang
  > nginx: fix install paths
  > flatbuffers: update to 1.11.0
  > libgpiod: put gpio utils into an actual separate package
  > evince: Fix build with clang
  > python-jsonschema: add PACKAGECONFIG nongpl option
  > python-jsonschema: multiple fixes
  > squid: upgrade 4.6 -> 4.9
  > ltrace: Remove RDEPENDS on elfutils
  > gnome-settings-daemon: initial add 3.34.1
  > libwacom: initial add 0.33
  > libgweather: initial add 3.34.0
  > geocode-glib: initial add 3.26.1
  > nautilus: upgrade 3.18.5 -> 3.34.1
  > tracker: initial add 2.3.1
  > gnome-autoar: inital add 0.2.3
  > gexiv2: initial add 0.12.0
  > file-roller: inital add 3.32.2
  > evince: upgrade 3.28.2 -> 3.34.1
  > gnome-font-viewer: initial add 3.34.0
  > evolution-data-server: upgrade 3.26.6 -> 3.34.1 and rework
  > evolution-data-server: give up fine grained -dev/-dbg packages
  > gtksourceview2: remove
  > gedit: upgrade 2.30.4 -> 3.34.0

* sources/meta-ti 7e03fc79...84249530 (1):
  > kselftests: Disable for riscv

Signed-off-by: Khem Raj <raj.khem@gmail.com>
@kraj kraj force-pushed the kraj/master branch from ef6d6de to 64bc817 Nov 20, 2019
kraj added 2 commits Nov 20, 2019
* sources/meta-clang ba6e545...3e25695 (4):
  > libffi: Use gcc for armeb
  > m4,ruby,webkitgtk: Do not use compiler-rt explicitly on arrmeb/ppc
  > armeb: Disable compiler-rt
  > qtwebengine: Link libatomic on x86/clang/gnu-runtime

* sources/meta-intel df2c8eef...afefffd2 (1):
  > clang: drop bbappend

Signed-off-by: Khem Raj <raj.khem@gmail.com>
…g sources/meta-intel sources/meta-openembedded sources/meta-ti sources/openembedded-core

* sources/bitbake 33197db8...ac1922d3 (5):
  > runqueue: Fix hash equivalence duplicate tasks running
  > contrib/vim/indent/bitbake.vim: move it to correct directory
  > fetch2/clearcase: Fix warnings from python 3.8
  > utils: also use mmap for SHA256 and SHA1, for performance
  > tests: add test for the hashing functions

* sources/meta-browser 22139d5...6316553 (1):
  > chromium: Update to 78.0.3904.108

* sources/meta-clang 3e25695...5eec6f9 (3):
  > Create CONTRIBUTING.md
  > Create CODE_OF_CONDUCT.md
  > Update issue templates

* sources/meta-intel afefffd2...62166cee (1):
  > recipes: use features_check instead of deprecated distro_features_check

* sources/meta-openembedded 53d431639a...e4ac09169d (57):
  > gedit: add gsettings to inherit
  > libdev-checklib-perl: upgrade 1.13 -> 1.14
  > dnsmasq.conf: fix dnsmasq path
  > librole-tiny-perl: upgrade 2.000006 -> 2.001004
  > hwdata: upgrade 0.328 -> 0.329
  > mcelog: upgrade 1.65 -> 1.66
  > softhsm: add recipe
  > libp11: add support for native builds
  > opensc: add support for native builds
  > opensc: use pcsc-lite instead of openct by default
  > pcsc-lite: add support for native builds
  > openct: merge do_install and do_install_append
  > exo: upgrade 0.12.8 -> 0.12.9
  > nodejs: libatomic patch should be target specific
  > sanlock: Replace cp -a with cp -R --no-dereference
  > sanlock: Use python3 and add sanlock user/group
  > python-pyelftools: add recipes
  > libclass-method-modifiers-perl: upgrade 2.12 -> 2.13
  > libdbd-sqlite-perl: upgrade 1.62 -> 1.64
  > libmoo-perl: upgrade 2.003004 -> 2.003006
  > googletest: move to release 1.10.0
  > libextutils-cppguess-perl: upgrade 0.12 -> 0.20
  > recipes: rename distro_features_check to features_check
  > python-jsonschema: add missing dependency
  > python-pyparted: upgrade 3.11.2 -> 3.11.3
  > python3-pykickstart: upgrade 3.20 -> 3.22
  > parole: upgrade 1.0.4 -> 1.0.5
  > libkcapi: Update patch to upstream submitted one
  > ruli: Fix install step and build samples too
  > python-pyephem: upgrade 3.7.6.0 -> 3.7.7.0
  > mariadb: replace dependency readline with libedit
  > python3-meh: upgrade 0.47 -> 0.48
  > python-twisted: upgrade 19.7.0 -> 19.10.0
  > python-twitter: upgrade 3.7.0 -> 3.8.0
  > python-tzlocal: upgrade 1.5.1 -> 2.0.0
  > python-urllib3: upgrade 1.25.6 -> 1.25.7
  > python-xlrd: upgrade 1.1.0 -> 1.2.0
  > python-xstatic: upgrade 1.0.1 -> 1.0.2
  > python-yappi: upgrade 0.98 -> 1.0
  > python-zopeinterface: upgrade 4.6.0 -> 4.7.1
  > liblockfile: Rename patch
  > networkmanager: do not deploy unnecessary udev rule file
  > python-scandir: Add native and nativesdk to BBCLASSEXTEND
  > python-contextlib2: Add native and nativesdk to BBCLASSEXTEND
  > python-configparser: Add native and nativesdk to BBCLASSEXTEND
  > python3-importlib-metadata: fix class-target overriding default dependencies
  > python-babel: add BBCLASSEXTEND for native/nativesdk
  > haveged: use the Fedora service file available from upstream
  > gitpkgv.bbclass: Support also lightweight tags
  > gitpkgv.bbclass: Use --git-dir option
  > gnome-terminal: add gsettings to inherit
  > gnome-settings-daemon: add gsettings to inherit
  > libgweather: add gsetings & upstream-version-is-even to inherit
  > nautilus: add gsettings to inherit
  > tracker: add gsettings to inherit
  > file-roller: add gsettings to inherit
  > dlm: Drop -fstack-clash-protection for clang

* sources/meta-ti 84249530...f35a0fdd (4):
  > kselftests: Fix typo in COMPATIBLE_MACHINE
  > am335x-evm: bump max_leb_cnt again
  > linux-ti-staging: update to ti2019.05-rc4
  > u-boot-ti-staging: update to ti2019.05-rc4

* sources/openembedded-core dfb3b56641...6dd59dffd7 (52):
  > package_ipk: Remove pointless comment to trigger rebuild
  > oeqa/selftest/sstatetests: Ensure we don't use hashequiv for sstatesigs tests
  > sanity: Add check for tar older than 1.28
  > runqemu: add options that enable virgl with the SDL frontend
  > core-image-full-cmdline: Add less
  > opkg-utils: Fix silent empty/broken opkg package creation
  > opkg: Add upstream fixes for empty packages
  > devtool: fix devtool upgrade with reproducible_builds class
  > glib-2.0: upgrade 2.62.1 -> 2.62.2
  > stress-ng: upgrade 0.10.08 -> 0.10.10
  > sqlite3: upgrade 3.30.0 -> 3.30.1
  > libsolv: upgrade 0.7.6 -> 0.7.8
  > harfbuzz: upgrade 2.6.1 -> 2.6.4
  > rng-tools: upgrade 6.7 -> 6.8
  > webkitgtk: Remove clang specific option
  > selftest: check that 'devtool upgrade' correctly drops backported patches
  > cairo: the component is dual licensed
  > cve-check: fetch CVE data once at a time instead of in a single call
  > cve-check: neaten get_cve_info
  > cve-check: rewrite look to fix false negatives
  > cve-update-db-native: clean up proxy handling
  > cve-update-db-native: add an index on the CVE ID column
  > cve-update-db-native: don't hardcode the database name
  > sysstat: upstream version check is working again
  > vala: upgrade 0.46.3 -> 0.46.4
  > mpg123: upgrade 1.25.12 -> 1.25.13
  > Revert "devtool/standard.py: Not filtering devtool workspace for devtool finish"
  > libxslt: update to 1.1.34
  > psmisc: update to 23.3
  > btrfs-tools: upgrade 5.3 -> 5.3.1
  > librepo: upgrade 1.10.6 -> 1.11.0
  > tiff: update to 4.1.0
  > python: update to 2.7.17
  > recipetool/create: Fix to work with reproducible_builds
  > oeqa/devtool: Avoid unbound variable errors
  > bind: Whitelist CVE-2019-6470
  > cdrtools-native: Don't set uid/gid during install
  > /oeqa/manual/compliance-test: remove obsolete test
  > oeqa/manual/compliance-test: move crashme to runtime
  > oeqa/manual/compliance-test: remove crashme tests
  > manual/bsd-hw: remove bash tests
  > oeqa/manual/bsp-hw: remove usb and SDmicro tests
  > oeqa/manual/bsp-hw: move storage tests to runtime
  > oeqa/manual/bsp-hw: remove reboot test
  > oeqa/runtime/boot: add reboot test
  > oeqa/manual/bsp-hw: remove rpm -ivh test
  > boost: fix build for x32
  > mesa: Upgrade to 19.2.4
  > selftest/wic: test wic rm with -r flag
  > wic: rm with -r flag support
  > systemd: remove ${PN}-xorg-xinitrc
  > distro_features_check: expand with MACHINE_FEATURES and COMBINED_FEATURES, rename

Signed-off-by: Khem Raj <raj.khem@gmail.com>
@cbrake cbrake merged commit d19763a into master Nov 23, 2019
1 check passed
1 check passed
continuous-integration/drone/pr Build is passing
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.