Permalink
Commits on Feb 3, 2013
  1. Release 0.0.4

    Signed-off-by: Yorick Peterse <yorickpeterse@gmail.com>
    committed Feb 3, 2013
  2. Properly deal with version oddities.

    RubyGems has a somewhat odd though understandable way of dealing with version
    numbers. For example, it considers the version "3.4" the same as "3.4.0". While
    this makes sense it gets a bit annoying when you want to download the `.gem`
    file. In case of Slop version 3.4 gem-mirror would try to download
    "slop-3.4.gem" while the file was actually supposed to be "slop-3.4.0.gem".
    
    This commit addresses this issue by filtering out non existing versions and
    using the latest version in case none were left.
    
    Signed-off-by: Yorick Peterse <yorickpeterse@gmail.com>
    committed Feb 3, 2013
  3. Release 0.0.3.

    Signed-off-by: Yorick Peterse <yorickpeterse@gmail.com>
    committed Feb 3, 2013
  4. Only fetch specific dependency versions.

    When fetching dependencies, either runtime or development dependencies, only
    the Gems that match the dependency version should be retrieved instead of
    retrieving *all* versions.
    
    This commit fixes #1.
    
    Signed-off-by: Yorick Peterse <yorickpeterse@gmail.com>
    committed Feb 3, 2013
  5. Added Confstruct to the dependencies list.

    Signed-off-by: Yorick Peterse <yorickpeterse@gmail.com>
    committed Feb 3, 2013
  6. Updated the MANIFEST and default config file.

    Signed-off-by: Yorick Peterse <yorickpeterse@gmail.com>
    committed Feb 3, 2013
  7. Initial commit.

    Signed-off-by: Yorick Peterse <yorickpeterse@gmail.com>
    committed Feb 3, 2013