Permalink
Branch: master
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
35 lines (28 sloc) 1.11 KB
Packages known to be needed to build in debian jessie and later.
Some of these will pull in other ones.
automake
build-essential * we now require C++11
cmake-curses-gui * 3.0 or later
dssi-dev
fluid not needed if compiling headless
libcairo2-dev
libfftw3-dev
libfltk1.3-dev not needed if compiling headless
libglu1-mesa-dev
libjack-jackd2-dev
libmxml-dev
libncurses5-dev
libreadline-dev
libxft-dev
libxml2-dev
pkg-config
xutils-dev
zlib1g-dev
LV2 plugin adds one more dependency:
lv2-dev with minimum version >= 1.0.0.
Optional alterative instead of libncurses5-dev
libncursesw5-dev * only needed for wide (unicode) character recognition. Note the 'w'!
Other distros may have slightly different names or version numbers, and may even have these installed by default. If in doubt try looking for just the main part of the name, but with the -dev extension where appropriate.
Optional alternative to glibc, part of build-essential
musl
This also requires argp-standalone which is not available from debian and must be built from source.