Skip to content
Browse files

Bump version and fix the gem dep

  • Loading branch information...
1 parent 194c223 commit fe9b7e438061c8cb0bfa1283c90888debc805b30 @Sutto Sutto committed Mar 31, 2011
Showing with 10 additions and 11 deletions.
  1. +1 −1 Rakefile
  2. +2 −2 lib/youth_tree/settings.rb
  3. +7 −8 youthtree-settings.gemspec
View
2 Rakefile
@@ -15,7 +15,7 @@ begin
gem.homepage = "http://github.com/YouthTree/youthtree-settings"
gem.authors = ["Darcy Laycock"]
gem.version = YouthTree::Settings::VERSION
- gem.add_dependency "activesupport", ">= 3.0.0.beta4"
+ gem.add_dependency "activesupport", "~> 3.0.1"
end
Jeweler::GemcutterTasks.new
rescue LoadError
View
4 lib/youth_tree/settings.rb
@@ -4,7 +4,7 @@
module YouthTree
class Settings
- VERSION = "0.2.0".freeze
+ VERSION = "0.2.1".freeze
cattr_reader :settings_path
def self.settings_path
@@ -103,7 +103,7 @@ def setup_mailer!
ActionMailer::Base.smtp_settings = s.smtp_settings.to_hash if s.smtp_settings?
ActionMailer::Base.sendmail_settings = s.sendmail_settings.to_hash if s.sendmail_settings?
ActionMailer::Base.default :from => s.from
-
+
# Setup sendgrid if present, sort of a faux-sendgrid helper.
if s.delivery_method.to_sym == :sendgrid
ActionMailer::Base.delivery_method = :smtp
View
15 youthtree-settings.gemspec
@@ -1,15 +1,15 @@
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
+# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{youthtree-settings}
- s.version = "0.2.0"
+ s.version = "0.2.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Darcy Laycock"]
- s.date = %q{2010-12-11}
+ s.date = %q{2011-03-31}
s.description = %q{Lets you use config/settings.yml in a rails application to manage settings on a per-env basis.}
s.email = %q{sutto@sutto.net}
s.extra_rdoc_files = [
@@ -27,20 +27,19 @@ Gem::Specification.new do |s|
]
s.homepage = %q{http://github.com/YouthTree/youthtree-settings}
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
+ s.rubygems_version = %q{1.6.2}
s.summary = %q{Simple Settings for Rails Applications}
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activesupport>, [">= 3.0.0.beta4"])
+ s.add_runtime_dependency(%q<activesupport>, ["~> 3.0.1"])
else
- s.add_dependency(%q<activesupport>, [">= 3.0.0.beta4"])
+ s.add_dependency(%q<activesupport>, ["~> 3.0.1"])
end
else
- s.add_dependency(%q<activesupport>, [">= 3.0.0.beta4"])
+ s.add_dependency(%q<activesupport>, ["~> 3.0.1"])
end
end

0 comments on commit fe9b7e4

Please sign in to comment.
Something went wrong with that request. Please try again.