Skip to content
ESLint configuration for our Wordpress projects
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.eslintignore
.gitignore
.prettierrc
.releaserc
.travis.yml
LICENSE
README.md
file-to-lint.js
index.js
package.json
yarn.lock

README.md

eslint-config-wordpress

npm (scoped) Build Status

ESLint configuration for our Wordpress projects

Features

Installation

$ yarn add --dev @yproximite/eslint-config-wordpress eslint@^5.8.0 babel-eslint@^10.0.0 prettier@^1.15.0

Usage

Edit your ESLint configuration file with:

{
  "extends": ["@yproximite/wordpress"]
}

Development workflow

You need to install some dependencies first:

$ yarn

Contribution

Publishing a new release

This is automatically done by Travis and semantic-release when you merge a pull request.

You can’t perform that action at this time.