Can't register YubiKey on Ubuntu - 'This device cannot be registered' #46

Closed
oren opened this Issue Oct 19, 2015 · 3 comments

Projects

None yet

3 participants

@oren
oren commented Oct 19, 2015

I got my YubiKey and I am trying to register it with Github.
I hit 'Add' in the 'Security keys' section on the configuration page and I see 'This device cannot be registered'.

I am using Ubuntu 15.04 (64-bit) and Chromium 44.0.2403.89

dmesg

usb 1-2: new full-speed USB device number 4 using xhci_hcd
usb 1-2: New USB device found, idVendor=1050, idProduct=0120
usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2: Product: Security Key by Yubico
usb 1-2: Manufacturer: Yubico
hid-generic 0003:1050:0120.0003: hiddev0,hidraw1: USB HID v1.10 Device [Yubico Security Key by Yubico] on usb-0000:00:14.0-2/input0

(I omitted the non-relevant entries)

lsusb -vv

Bus 001 Device 004: ID 1050:0120 Yubico.com
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0x1050 Yubico.com
  idProduct          0x0120
  bcdDevice            4.18
  iManufacturer           1
  iProduct                2
  iSerial                 0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           41
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0x80
      (Bus Powered)
    MaxPower               30mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      0 No Subclass
      bInterfaceProtocol      0 None
      iInterface              0
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.10
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      34
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x04  EP 4 OUT
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               2
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x84  EP 4 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               2

Do I need to mount my USB? I don't think so - I normaly use the mount command since I use i3 as my window manager, but I tried logging in with unity and I got the same issue.

Anything else I should output that will help in troubleshoot this? Is this the right place to report this issue?

@bogdal
bogdal commented Oct 20, 2015

@oren Probably you need to create the 70-u2f.rules file.

@oren
oren commented Oct 20, 2015

works. thanks!

@oren oren closed this Oct 20, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment