Permalink
Browse files

simplify the compatibility matrix

  • Loading branch information...
1 parent 89ef33d commit 6400b723becafee6f93e1c4a405ef54fac43f79e @ge0ffrey ge0ffrey committed Oct 26, 2011
@@ -2,119 +2,79 @@
<chapter version="5.0"
xsi:schemaLocation="http://docbook.org/ns/docbook http://www.docbook.org/xml/5.0/xsd/docbook.xsd http://www.w3.org/1999/xlink http://www.docbook.org/xml/5.0/xsd/xlink.xsd"
xml:base="../" xml:id="compatibility" xmlns="http://docbook.org/ns/docbook"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- xmlns:xs="http://www.w3.org/2001/XMLSchema"
- xmlns:xlink="http://www.w3.org/1999/xlink"
- xmlns:xi="http://www.w3.org/2001/XInclude"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xs="http://www.w3.org/2001/XMLSchema"
+ xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:xi="http://www.w3.org/2001/XInclude"
xmlns:ns="http://docbook.org/ns/docbook">
- <title>Drools compatibility matrix</title>
-
- <para>The following table shows the compatibility between different versions of Drools, jBPM and Guvnor
- </para>
-
- <table>
- <title>Compatibility Matrix</title>
- <tgroup cols="5">
- <colspec colnum="1"/>
- <colspec colnum="2"/>
- <colspec colnum="3" align="center"/>
- <colspec colnum="4" align="center"/>
- <colspec colnum="5" align="center"/>
-
- <!-- Header -->
- <thead>
- <row>
- <entry>Package</entry>
- <entry>Version</entry>
- <entry>Drools</entry>
- <entry>jBPM</entry>
- <entry>Guvnor</entry>
- </row>
- </thead>
-
- <tbody>
- <!-- Drools -->
- <row>
- <entry><emphasis role="strong">Drools</emphasis></entry>
- <entry>5.3.0.Final</entry>
- <entry>-</entry>
- <entry>5.1.2.Final</entry>
- <entry>5.3.0.Final</entry>
- </row>
- <row>
- <entry></entry>
- <entry>5.3.0.CR1</entry>
- <entry>-</entry>
- <entry>5.1.1.Final</entry>
- <entry>5.3.0.CR1</entry>
- </row>
- <row>
- <entry></entry>
- <entry>5.2.1.Final</entry>
- <entry>-</entry>
- <entry>5.1.1.Final</entry>
- <entry>5.2.1.Final</entry>
- </row>
- <row>
- <entry></entry>
- <entry>5.2.0.Final</entry>
- <entry>-</entry>
- <entry>5.1.0.Final</entry>
- <entry>5.2.0.Final</entry>
- </row>
- <row>
- <entry></entry>
- <entry>5.2.0.CR1</entry>
- <entry>-</entry>
- <entry>5.1.0.CR1</entry>
- <entry>5.2.0.CR1</entry>
- </row>
- <row rowsep="1">
- <entry></entry>
- <entry>5.2.0.M2</entry>
- <entry>-</entry>
- <entry>5.1.0.M1</entry>
- <entry>5.2.0.M2</entry>
- </row>
-
- <!-- jBPM -->
- <row>
- <entry><emphasis role="strong">jBPM</emphasis></entry>
- <entry>5.1.2.Final</entry>
- <entry>5.3.0.Final</entry>
- <entry>-</entry>
- <entry>5.3.0.Final</entry>
- </row>
- <row>
- <entry> </entry>
- <entry>5.1.1.Final</entry>
- <entry>5.2.1.Final</entry>
- <entry>-</entry>
- <entry>5.2.1.Final</entry>
- </row>
- <row>
- <entry> </entry>
- <entry>5.1.0.Final</entry>
- <entry>5.2.0.Final</entry>
- <entry>-</entry>
- <entry>5.2.0.Final</entry>
- </row>
- <row>
- <entry> </entry>
- <entry>5.1.0.CR1</entry>
- <entry>5.2.0.CR1</entry>
- <entry>-</entry>
- <entry>5.2.0.CR1</entry>
- </row>
- <row>
- <entry> </entry>
- <entry>5.1.0.M1</entry>
- <entry>5.2.0.M2</entry>
- <entry>-</entry>
- <entry>5.2.0.M2</entry>
- </row>
- </tbody>
- </tgroup>
- </table>
+ <title>Drools compatibility matrix</title>
+ <para>The following table shows the compatibility between different versions of Drools, jBPM and Guvnor.</para>
+
+ <table>
+ <title>Compatibility matrix</title>
+
+ <tgroup cols="3">
+ <thead>
+ <row>
+ <entry>Drools</entry>
+
+ <entry>jBPM</entry>
+
+ <entry>Guvnor</entry>
+ </row>
+ </thead>
+
+ <tbody>
+ <row>
+ <entry>5.3.0.Final</entry>
+
+ <entry>5.1.2.Final</entry>
+
+ <entry>5.3.0.Final</entry>
+ </row>
+
+ <row>
+ <entry>5.3.0.CR1</entry>
+
+ <entry>5.1.1.Final</entry>
+
+ <entry>5.3.0.CR1</entry>
+ </row>
+
+ <row>
+ <entry>5.2.1.Final</entry>
+
+ <entry>5.1.1.Final</entry>
+
+ <entry>5.2.1.Final</entry>
+ </row>
+
+ <row>
+ <entry>5.2.0.Final</entry>
+
+ <entry>5.1.0.Final</entry>
+
+ <entry>5.2.0.Final</entry>
+ </row>
+
+ <row>
+ <entry>5.2.0.CR1</entry>
+
+ <entry>5.1.0.CR1</entry>
+
+ <entry>5.2.0.CR1</entry>
+ </row>
+
+ <row>
+ <entry>5.2.0.M2</entry>
+
+ <entry>5.1.0.M1</entry>
+
+ <entry>5.2.0.M2</entry>
+ </row>
+ </tbody>
+ </tgroup>
+ </table>
+
+ <para>If you combine the versions specified in any <emphasis>single</emphasis> row of this table, they are
+ compatible.</para>
</chapter>

0 comments on commit 6400b72

Please sign in to comment.