Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fatal error after fresh install #6

Open
jlnbdt opened this issue Oct 30, 2019 · 6 comments

Comments

@jlnbdt
Copy link

@jlnbdt jlnbdt commented Oct 30, 2019

Hi,

I've just installed this app. I get the following message when I try to access it:

Fatal error: Uncaught Error: Class 'Locale' not found in /var/www/halcyon/language.php:6 Stack trace: #0 /var/www/halcyon/header.php(4): include() #1 /var/www/halcyon/home.php(1): include('/var/www/halcyo...') #2 /var/www/halcyon/index.php(1): include('/var/www/halcyo...') #3 {main} thrown in /var/www/halcyon/language.php on line 6

Since it seems related to language, I've tried to modify the default language in config.ini (I've tried fr_FR and en_US) ; it doesn't change anything.

Thanks!

@anmol26s

This comment has been minimized.

Copy link
Contributor

@anmol26s anmol26s commented Dec 1, 2019

but is the app working?

@jlnbdt

This comment has been minimized.

Copy link
Author

@jlnbdt jlnbdt commented Dec 1, 2019

Not at all, I only get this message.

@anmol26s

This comment has been minimized.

Copy link
Contributor

@anmol26s anmol26s commented Dec 1, 2019

I have updated the app. Can you try to reinstall?

@jlnbdt

This comment has been minimized.

Copy link
Author

@jlnbdt jlnbdt commented Dec 1, 2019

The message is gone but I get a blank page now.
From Nginx log, I get this:

capture

@anmol26s

This comment has been minimized.

Copy link
Contributor

@anmol26s anmol26s commented Dec 1, 2019

Enable all locales on your system which are supported by Halcyon by uncommenting them in /etc/locale.gen and run locale-gen after that.

I see this warning in the installation page of the Halcyon. I think you can try to uncomment your language and then try to install again.

@jlnbdt

This comment has been minimized.

Copy link
Author

@jlnbdt jlnbdt commented Dec 1, 2019

fr_FR is already uncommented, as en_US (and I ran locale-gen). I've tried to reinstalled the app twice (with fr_FR then en_US), it doesn't change anything :-(

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.