Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

a lot of engine downloads by zk-lobby fail #457

Closed
abma opened this issue Feb 6, 2015 · 11 comments
Closed

a lot of engine downloads by zk-lobby fail #457

abma opened this issue Feb 6, 2015 · 11 comments

Comments

@abma
Copy link

@abma abma commented Feb 6, 2015

thats just one example, there are several others:
(removed ip)

  • - [02/Feb/2015:17:44:57 +0100] "GET /dl/buildbot/default/master/91.0/spring_91.0_minimal-portable+dedicated.zip HTTP/1.1" 200 28245868 "-" "-"
  • - [03/Feb/2015:17:53:47 +0100] "GET /dl/buildbot/default/master/91.0/spring_91.0_minimal-portable+dedicated.zip HTTP/1.1" 200 28245868 "-" "-"
  • - [03/Feb/2015:17:57:14 +0100] "GET /dl/buildbot/default/master/91.0/spring_91.0_minimal-portable+dedicated.zip HTTP/1.1" 200 11906400 "-" "-"
  • - [03/Feb/2015:18:00:07 +0100] "GET /dl/buildbot/default/master/91.0/spring_91.0_minimal-portable+dedicated.zip HTTP/1.1" 200 28245868 "-" "-"
  • - [03/Feb/2015:18:02:07 +0100] "GET /dl/buildbot/default/master/91.0/spring_91.0_minimal-portable+dedicated.zip HTTP/1.1" 200 28245868 "-" "-"
  • - [03/Feb/2015:18:04:25 +0100] "GET /dl/buildbot/default/master/91.0/spring_91.0_minimal-portable+dedicated.zip HTTP/1.1" 200 28245868 "-" "-"
  • - [03/Feb/2015:18:09:02 +0100] "GET /dl/buildbot/default/master/91.0/spring_91.0_minimal-portable+dedicated.zip HTTP/1.1" 200 28245868 "-" "-"
  • - [03/Feb/2015:18:12:00 +0100] "GET /dl/buildbot/default/master/91.0/spring_91.0_minimal-portable+dedicated.zip HTTP/1.1" 200 28245868 "-" "-"
  • - [03/Feb/2015:18:13:27 +0100] "GET /dl/buildbot/default/master/91.0/spring_91.0_minimal-portable+dedicated.zip HTTP/1.1" 200 8447736 "-" "-"

please fix, this costs a lot of bandwith and very likely also causes users to be frustrated.

it seems zkl aborts download. or maybe fails to extract and downloads again? idk the code :-)

also it would be good if zkl sets a proper user-agent with version-number so such issues can be better debugged.

@abma

This comment has been minimized.

Copy link
Author

@abma abma commented Feb 6, 2015

also: please use .7z file as it is a lot smaller!

@Licho1

This comment has been minimized.

Copy link
Member

@Licho1 Licho1 commented Feb 6, 2015

Odd are you sure its same client? There is no code that would cacnel download.
ZKL cannot use 7z because there is no managed 7z library :-(

@abma

This comment has been minimized.

Copy link
Author

@abma abma commented Feb 6, 2015

yes, all downloads are from the same ip. meh, ok, sad there is no 7z lib. :-|

so, would be good to set a user agent, to pinpoint the problem.

@Orfelius

This comment has been minimized.

Copy link

@Orfelius Orfelius commented Feb 6, 2015

It could be just a connection issue. Happens from time to time :)

@abma

This comment has been minimized.

Copy link
Author

@abma abma commented Feb 6, 2015

in 5 days ~80 ip's with the same problem? imo no. also the download seems to be completed in some cases but it was restarted regardingless of that.

-> add version to user agent with version information so it can be pinpointed

@Licho1

This comment has been minimized.

Copy link
Member

@Licho1 Licho1 commented Feb 6, 2015

yeah version agent is good idea also maybe ip can be resolved back to player

@abma

This comment has been minimized.

Copy link
Author

@abma abma commented Feb 8, 2015

please add agent first, contacting people still can be done if no error can be found.

@Licho1

This comment has been minimized.

Copy link
Member

@Licho1 Licho1 commented Feb 9, 2015

Closing until further data gathered with client name.

@Licho1 Licho1 closed this Feb 9, 2015
@abma

This comment has been minimized.

Copy link
Author

@abma abma commented Feb 10, 2015

send you an email with access.log.

in ~24 hours again ~20 unique ip's which in most cases seems to have downloaded the engine multiple times sucessfully. some clients already used the user-agent, so happens in current version.

ideas what could fail here? for me this doesn't look like "usual" network problems as the transfer seems to completed but the file is downloaded again from the same ip.

@Licho1

This comment has been minimized.

Copy link
Member

@Licho1 Licho1 commented Feb 10, 2015

Really odd, i can't imagine the scenario. Every download has pretty visible download bar as well which would alert user if something wasnt right.

Is it possible it also lists HEAD requests? ZKL first check for file presence using HEAD request.

@abma

This comment has been minimized.

Copy link
Author

@abma abma commented Feb 10, 2015

no, i've explicitly removed HEAD requests from the access.log.

they would show up as a line with HEAD (vs GET)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.