New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Filter / Purge And Delete not running #321

Closed
marcusDSK opened this Issue Feb 3, 2014 · 2 comments

Comments

Projects
None yet
3 participants
@marcusDSK

marcusDSK commented Feb 3, 2014

Good day,

Before I say anything else, I would like to assure you that I have
scoured the forums and Wiki's of Zoneminder, Stackoverflow and Ubuntu
for about 2 months now without finding a solution to this problem.
This is my last resort to get this very important part of my
Zoneminder system running.

I am running ZM 1.25.0 on Ubuntu 12.04. The system is running fine
except for the PurgeAndDelete filter. I can modify and save the
filter, but it never runs. The logs contain the following error:
Uncaught TypeError: "Cannot read property 'checked' of undefined"

I followed the log details to the "/zm/skins/classic/views/js/filter.js"
file
on line 14. The Javascript is looking for the element "autoUpload".

I have a bit of experience in HTML, PHP and JS, so I chose "Inspect
Element"
through Google Chrome. I did this on the Filter Options page (where I
can modify the filter settings) - there was no input field named
"autoUpload". On the filterSave page [URL:
http://192.168.1.30/zm/index.php?view=filtersave&page=1&reload=0&execute=0&action=&subaction=&line=&fid=&filterName=PurgeAndDelete&filter%5Bterms%5D%5B0%5D%5Battr%5D=DiskPercent&filter%5Bterms%5D%5B0%5D%5Bop%5D=%3E%3D&filter%5Bterms%5D%5B0%5D%5Bval%5D=80&sort_field=DateTime&sort_asc=1&limit=10&autoExecuteCmd=&autoDelete=1]

I found a hidden input field named "autoUpload" but it has no value.

This is as far as I have gotten with diagnostics.
If you give me a direct email address, I can send you screen shots of
anything you need and I'd be more than happy to provide any further
information you require.

Thank you for your time!

Best Regards,
Marcus

@knight-of-ni

This comment has been minimized.

Member

knight-of-ni commented Feb 3, 2014

The only advice I can give you for the old version for zoneminder you are using is to make sure and select the "Run filter in background" check-box before you click Save. Otherwise it won't run. Maybe some of my peers can remember back that far. I don't recall if 1.25 had any issues running filters or not.

However, what I also recommend you do is upgrade to the latest version of zoneminder. Since you are using Ubuntu, all you have to do is add iconnor's ppa:
https://launchpad.net/~iconnor/+archive/zoneminder

For future reference, to add a screenshot to your post, just drag the image into the window.

@marcusDSK

This comment has been minimized.

marcusDSK commented Feb 4, 2014

Dear knnniggett,

thank you for your quick response!

Even though I had tried the "run in background" in the past and it didn't work, now all of a sudden it's running.

My server must've felt my near-apocalyptic rage.

Thank you again! Finally I don't need to worry about this anymore.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment