New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

feeds not being published on readthedocs #54

Closed
mr-c opened this Issue Oct 22, 2015 · 10 comments

Comments

Projects
None yet
2 participants
@mr-c

mr-c commented Oct 22, 2015

@abakan-zz

This comment has been minimized.

Owner

abakan-zz commented Oct 22, 2015

@mr-c

This comment has been minimized.

mr-c commented Oct 22, 2015

Hello @abakan

Based upon https://github.com/abakan/ablog/blob/devel/ablog/templates/page.html#L6 I expect to see links to the feed in my headers

@abakan-zz

This comment has been minimized.

Owner

abakan-zz commented Oct 22, 2015

Now I see the issue. I will check that today.

@abakan-zz

This comment has been minimized.

Owner

abakan-zz commented Oct 23, 2015

Links to feeds should now be included in header. I need to do some more changes though to make sure link to archive feeds is given in archive pages.

@mr-c

This comment has been minimized.

mr-c commented Oct 23, 2015

Hmm.. I updated my requirements.txt to pull your changes in but I'm not seeing the fix on RTD:

https://readthedocs.org/projects/mrc-snippets/builds/3424079/
http://mrc.commonwl.org/en/latest/

@abakan-zz

This comment has been minimized.

Owner

abakan-zz commented Oct 23, 2015

It looks like ablog was not reinstalled:

  Requirement already satisfied (use --upgrade to upgrade): ablog==0.8.0 from https://github.com/abakan/ablog/archive/28e7f0e64347bca6da1a2523d412ae0af262ecf3.zip in /home/docs/checkouts/readthedocs.org/user_builds/mrc-snippets/envs/latest/lib/python2.7/site-packages (from -r requirements.txt (line 1))

You could try wiping latest from Project -> Versions, and rebuilding.

@mr-c

This comment has been minimized.

mr-c commented Oct 23, 2015

Hmm.. Okay, I've wiped latest but I get the same result
https://readthedocs.org/projects/mrc-snippets/builds/3424979/

On Fri, Oct 23, 2015 at 6:44 PM Ahmet Bakan notifications@github.com
wrote:

It looks like ablog was not reinstalled:

Requirement already satisfied (use --upgrade to upgrade): ablog==0.8.0 from https://github.com/abakan/ablog/archive/28e7f0e64347bca6da1a2523d412ae0af262ecf3.zip in /home/docs/checkouts/readthedocs.org/user_builds/mrc-snippets/envs/latest/lib/python2.7/site-packages (from -r requirements.txt (line 1))

You could try wiping latest from Project -> Versions.


Reply to this email directly or view it on GitHub
#54 (comment).

@abakan-zz

This comment has been minimized.

Owner

abakan-zz commented Oct 24, 2015

I made a release, you should have feeds linked now. I don't know why it still didn't work on RTD after wiping. Maybe they preinstall a version of ablog, and unless version changes you cannot get it reinstalled.

@abakan-zz abakan-zz closed this Oct 24, 2015

@mr-c

This comment has been minimized.

mr-c commented Oct 24, 2015

Thank you @abakan , that worked.

Perhaps it is because I didn't check the 'use virtualenv' box?

@abakan-zz

This comment has been minimized.

Owner

abakan-zz commented Oct 25, 2015

Not sure, I have the hardest time troubleshooting things on RTD.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment