Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Object type ignored, not supported: FUGS, FUGX #2851

Closed
sarfran opened this issue Aug 7, 2019 · 6 comments
Closed

Object type ignored, not supported: FUGS, FUGX #2851

sarfran opened this issue Aug 7, 2019 · 6 comments
Labels
good first issue Want to help out with something small? serialization Translate between object types and files

Comments

@sarfran
Copy link

sarfran commented Aug 7, 2019

When creating a Repo from a Package, the object types FUGS and FUGX are not processed, error message:
Object type ignored, not supported: FUGS-
Object type ignored, not supported: FUGX-

We used the latest abapGit Client (1.89.0), and also installed the abapGit Plugin.
Any idea how we can also process these?
Thanks!

@larshp larshp added the serialization Translate between object types and files label Aug 7, 2019
@larshp
Copy link
Member

larshp commented Aug 8, 2019

currently not supported

FUGS Function Group with Customer Include: SAP Part
FUGX Function Group with Customer Include: Customer Part

@larshp
Copy link
Member

larshp commented Aug 8, 2019

FUGS objects are only for SAP internal use?

larshp added a commit that referenced this issue Aug 8, 2019
larshp added a commit that referenced this issue Aug 8, 2019
* add unsupported types FUGR + FUGX #2851

* and the gateway stuff is supported
@sarfran
Copy link
Author

sarfran commented Aug 8, 2019

Thanks for the quick response! Both function groups are needed for Customer Includes, FUGS is not only for SAP internal use.

@larshp larshp added the good first issue Want to help out with something small? label Oct 7, 2019
@larshp
Copy link
Member

larshp commented Oct 7, 2019

pull requests welcome, I currently dont have any good systems to test this on

@ghost
Copy link

ghost commented Oct 17, 2019

I tried to create a customer function but got the following message:

EXIT modules are no longer supported (Message no. FL049)

Diagnosis
As of release 5.0, the concept of SMOD/CMOD is not longer supported. For this reason, no new EXIT modules and groups can be created.

Procedure
Use BADIs instead of EXIT modules.

@larshp Should we really implement them though not supported by SAP anymore?

@mbtools
Copy link
Member

mbtools commented Apr 30, 2022

Not supported anymore. Closing

@mbtools mbtools closed this as completed Apr 30, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
good first issue Want to help out with something small? serialization Translate between object types and files
Development

No branches or pull requests

3 participants