[1.07 Beta 4] Search issue #489

Closed
keithsimister opened this Issue Mar 4, 2014 · 26 comments

Comments

Projects
None yet
6 participants

If I do a search, search results are returned OK, but when I click on Artist name from the search results no albums are shown (and the 'now playing' bar on that screen is broken)

Owner

abarisain commented Mar 4, 2014

The now playing bar on that screen is not broken, it's just not implemented yet.

Sorry - by 'broken' I meant 'not displaying correctly'

In this example, I did a search on "pink", clicked on artist "Pink Floyd:

mpdroid_search

This on stock Nexus 7 with Android 4.4.2

Owner

abarisain commented Mar 4, 2014

Oh, that explains both bugs ! I'm pretty sure that your albums are behind this mess

Owner

abarisain commented Mar 4, 2014

I guess I'll have to release Beta 5 since it's a really app-breaking bug

Trying this on an HTC One Mini phone (Android 4.3), the search is still broken but the now playing bar is fine

yello1

It's only if you tap on the artist name in the search results that fails - tapping on an album title works as expected

yello2

Don't know if the music choice is any more acceptable :)

Owner

abarisain commented Mar 4, 2014

Thanks for the feedback. What is your "albumartist tag to use" setting ? (it's probably not related)

Are you using the album cache ?

"Thanks for the feedback. What is your "albumartist tag to use" setting ? (it's probably not related)

Are you using the album cache ?"

I have tried all three options for "album artist tag to use" - same result for all.

I am using the album cache.

I've tried with "Use album cache" unchecked (on HTC One) and the bug disappears.

Contributor

kingosticks commented Mar 4, 2014

Does changing the "album artist tag to use" option automatically invalidate the cache? Presumably it should.

Owner

abarisain commented Mar 4, 2014

No it should not because it does not have any implication on the cache :)

Contributor

kingosticks commented Mar 4, 2014

Oops ok, sorry. I'll be quiet.(I was too lazy to read the code)

This is strange - I have tried on the Nexus 7 with "Use album cache" unchecked and search is still broken. All the settings are the same on both my phone and my tablet, yet the bug only occurs on the phone when the album cache is used, but on the tablet the bug is there regardless of the "Use album cache" setting.

Owner

abarisain commented Mar 4, 2014

Your tablet cannot show the results due to the mini player bug
Le 4 mars 2014 18:23, "keithsimister" notifications@github.com a écrit :

This is strange - I have tried on the Nexus 7 with "Use album cache"
unchecked and search is still broken. All the settings are the same on both
my phone and my tablet, yet the bug only occurs on the phone when the album
cache is used, but on the tablet the bug is there regardless of the "Use
album cache" setting.


Reply to this email directly or view it on GitHubhttps://github.com/abarisain/dmix/issues/489#issuecomment-36649924
.

Contributor

hurzl commented Mar 4, 2014

Your screenshot reminds me of my wish to have the year shown in the album view ;)

Owner

abarisain commented Mar 4, 2014

That's what I'll do next, with the "song details" window :)

Owner

abarisain commented Mar 4, 2014

@keithsimister I fixed the broken layout bug, but I can't really reproduce the cache bug ... Works for me.

Is anybody else capable of reproducing this ?

Contributor

hurzl commented Mar 4, 2014

I've never seen anything like that

I've played some more on my phone, and the bug is consistent with the Album cache setting:

cache_1
cache_2

nocache_1
nocache_2

Owner

abarisain commented Mar 5, 2014

I'm sorry but I really can't reproduce it. May sounds dumb or useless but can you wipe your app data ?

Owner

abarisain commented Mar 5, 2014

If you are rooted, can you please try to dump the MPDroid data (in /data/data/com.namelessdev.mpdroid) and upload it ? You should probably remove the shared_prefs xml beforehand, since it has your server information and possibly your password

Sorry - phone is not rooted.


From: Arnaud Barisain Monrose [mailto:notifications@github.com]
Sent: 05 March 2014 00:44
To: abarisain/dmix
Cc: keithsimister
Subject: Re: [dmix] [1.07 Beta 4] Search issue (#489)

If you are rooted, can you please try to dump the MPDroid data (in
/data/data/com.namelessdev.mpdroid) and upload it ? You should probably
remove the shared_prefs xml beforehand, since it has your server information
and possibly your password

Reply to this email directly or view
#489 (comment) it on
GitHub.
<https://github.com/notifications/beacon/4256937__eyJzY29wZSI6Ik5ld3NpZXM6Qm
VhY29uIiwiZXhwaXJlcyI6MTcwOTU5OTQ0NywiZGF0YSI6eyJpZCI6MjY5MTU4ODN9fQ==--d8e5
33296e26e3fdd195b7fe91701dd11c7e40ed.gif>

I have deleted the app data, but the problem still persists.


From: Arnaud Barisain Monrose [mailto:notifications@github.com]
Sent: 05 March 2014 00:40
To: abarisain/dmix
Cc: keithsimister
Subject: Re: [dmix] [1.07 Beta 4] Search issue (#489)

I'm sorry but I really can't reproduce it. May sounds dumb or useless but
can you wipe your app data ?

Reply to this email directly or view
#489 (comment) it on
GitHub.
<https://github.com/notifications/beacon/4256937__eyJzY29wZSI6Ik5ld3NpZXM6Qm
VhY29uIiwiZXhwaXJlcyI6MTcwOTU5OTE5OSwiZGF0YSI6eyJpZCI6MjY5MTU4ODN9fQ==--1cd9
753ee86f6a03bf23dc1dc2780d994a183d4c.gif>

tkone commented Mar 5, 2014

I have got the same problem Keith has on his Nexus on a 10" Toshiba tablet. No matter if cache is enabled or not. Jumping from the search results on the artist tab to the artist's album view does not work. Jumping from the albums results tab to the selected album also does not work.
The tablet is running Android 4.1.1.
But on a Samsung Galaxy S Advance with 4.1.2 the search is working properly, both with enabled and disabled cache.

Owner

abarisain commented Mar 5, 2014

Let me clear a recurring misconsception : There are two different problems
here. Tablet layout is broken (the results are hidden), this is why it
never works. I fixed this already but it's not released.

Then you have the other issue which I can not reproduce. You can only try
to trigger it on phones because the layout is not broken there.

@avuton avuton added the Layout label Apr 16, 2014

Owner

abarisain commented Mar 1, 2015

That should be fixed. Closing.

@abarisain abarisain closed this Mar 1, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment