Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

configure.requires in META.json incomplete? #1

Open
eserte opened this issue Aug 18, 2019 · 0 comments

Comments

@eserte
Copy link

commented Aug 18, 2019

Makefile.PL lists Crypt::OpenSSL::Guess as a configure_requires prerequisite, but it's not listed META.json. Therefore automatic installation fails on systems where Crypt::OpenSSL::Guess is not yet installed:

Output from '/usr/bin/perl Makefile.PL':

Can't locate Crypt/OpenSSL/Guess.pm in @INC (you may need to install the Crypt::OpenSSL::Guess module) (@INC contains: /var/tmp/cpansmoker-1023/2019081808/CPAN-Reporter-lib-j3qL /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at Makefile.PL line 7.
BEGIN failed--compilation aborted at Makefile.PL line 7.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.