Rails Contacts Gem Modified to work with hotmail
Ruby
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
examples
lib
test
.gitignore
LICENSE
README
Rakefile
abhi-contacts.gemspec
cruise_config.rb
geminstaller.yml

README

== Welcome to Abhi Contacts

Contacts is a universal interface to grab contact list information from various providers including Hotmail, AOL, Gmail, Plaxo and Yahoo.

== Download

* gem install abhi-contacts
* https://github.com/abhilashak/abhi-contacts
* git clone git@github.com:abhilashak/abhi-contacts.git

== Background

This gem is based on cardmagic contacts. https://github.com/cardmagic/contacts, and I patched some files in this gem and replaced the hotmail.rb file with deneuxa's contacts (https://github.com/deneuxa/contacts) to work the Hotmail importing.

While I am using the gem contacts for importing the contacts from gmail, yahoo and hotmail, I encountered Three-Four Problems (Major One: Hotmail importing is not working), the first error I got is the following,

/home/prescience-toshiba/.rvm/gems/ruby-1.9.2-p290@rails31rc/gems/activesupport-3.1.3/lib/active_support/dependencies.rb:240:in `require': no such file to load -- hpricot (LoadError)

so I patched in the file /home/prescience-toshiba/.rvm/gems/ruby-1.9.2-p290@rails31rc/gems/contacts-1.2.4/lib/contacts/aol.rb

and replaced the line 

require 'hpricot'

with

require 'hpricot' if RUBY_VERSION < '1.9'

this is valid for only the ruby version less than 1.9


then I changed

the file  /home/prescience-toshiba/.rvm/gems/ruby-1.9.2-p290@rails31rc/gems/gdata-1.1.1/lib/gdata.rb

replaced this line 

require 'jcode' 

with

require 'jcode' if RUBY_VERSION < '1.9'	

If any warning message comes with $KCODE when starting the server or starting the console then

replace

$KCODE = 'UTF8'

with

$KCODE = 'UTF8' if RUBY_VERSION < '1.9'

For the Hotmail importing issue, I replaced the hotmail.rb file from cardmagic contacts with deneuxa's contacts hotmail.rb file.

And Hotmail Authentication error is the issue shown in https://github.com/cardmagic/contacts/issues/42

Contacts::ConnectionError: Hotmail has changed its protocols, please upgrade this library first. If that does not work, report this error at http://rubyforge.org/forum/?group_id=2693

When I tried to use the gem  deneuxa-contacts gem, so many gem conflict error came. Hope this updated contacts gem will help you better.

== Usage

	Contacts::Hotmail.new(login, password).contacts # => [["name", "foo@bar.com"], ["another name", "bow@wow.com"]]
	Contacts::Yahoo.new(login, password).contacts
	Contacts::Gmail.new(login, password).contacts
	
	Contacts.new(:gmail, login, password).contacts
	Contacts.new(:hotmail, login, password).contacts
	Contacts.new(:yahoo, login, password).contacts
	
	Contacts.guess(login, password).contacts

== References
  
   https://github.com/cardmagic/contacts
   https://github.com/deneuxa/contacts