No description or website provided.
PHP
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
config
src
.gitignore
.travis.yml
README.md
composer.json
phpunit.xml

README.md

Laravel languages installer

Install translation files for any language with a command in your laravel projects. The language files will be downloaded from the awesome caouecs languages repository.

Requirements

  • PHP 5.5 or higher.
  • Laravel >= 5.1

Installation

Add the package to your composer.json:

composer require ablunier/laravel-lang-installer

Add the service provider in app.php:

    Ablunier\Laravel\Translation\LanguageInstallerServiceProvider::class,

Publish the package's assets:

php artisan vendor:publish

Configuration

Edit the 'lang-installer.php' file in your config folder to add your required languages and files.

Usage

Execute the command:

php artisan lang:install