Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ivy-occur counsel-find-file issue with subdirectories #1351

Closed
ekenberg opened this issue Dec 6, 2017 · 4 comments
Closed

ivy-occur counsel-find-file issue with subdirectories #1351

ekenberg opened this issue Dec 6, 2017 · 4 comments

Comments

@ekenberg
Copy link

@ekenberg ekenberg commented Dec 6, 2017

Great work on ivy-occur! As discussed on oremacs.com, here is more details on the issue with subdirectories:

piano:~/tmp$ git clone https://github.com/abo-abo/swiper/
piano:~/tmp$ cd swiper/
piano:~/tmp/swiper$ make plain
emacs --version
emacs -Q -l colir.el -l ivy-overlay.el -l ivy.el -l swiper.el -l counsel.el -l targets/plain.el
piano:~/tmp/swiper$ GNU Emacs 25.3.2

then in emacs:

counsel-find-file
C-c C-o ;; opens *ivy-occur counsel-find-file ""*

now, the entries in current directory work, but anything under subdirs (doc and targets) give error "File no longer exists". Like this, pressing ENTER on Changelog.org:

screenshot_20171206_224027

@abo-abo
Copy link
Owner

@abo-abo abo-abo commented Dec 14, 2017

Thanks, please test.

@ekenberg
Copy link
Author

@ekenberg ekenberg commented Dec 14, 2017

What is the best way of testing - I currently use melpa and ivy/swiper/counsel/ivy-hydra are all in separate packages. I've git cloned swiper, now do I create new "fake-elpa" directories or simply overwrite the latest versions of the relevant *.el?

@ekenberg
Copy link
Author

@ekenberg ekenberg commented Dec 14, 2017

Right, I forgot, just 'make plain'. Yes it seems to work alright, this will be very useful thank you!

@abo-abo
Copy link
Owner

@abo-abo abo-abo commented Dec 14, 2017

I've git cloned swiper, now do I create new "fake-elpa" directories or simply overwrite the latest versions of the relevant *.el?

You can modify your load-path so that the git cloned directory is ahead of the ELPA directory on the list. That way, you don't have to touch the ELPA version.

See for instance how I do it here: https://github.com/abo-abo/oremacs/blob/github/init.el#L10

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants