New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix for older Emacs #415

Closed
wants to merge 1 commit into
base: master
from

Conversation

Projects
None yet
2 participants
@syohex
Contributor

syohex commented Mar 3, 2016

defvar-local was introduced since Emacs 24.3.

Fix for older Emacs
defvar-local was introduced since Emacs 24.3.
@abo-abo

This comment has been minimized.

Show comment
Hide comment
@abo-abo

abo-abo Mar 3, 2016

Owner

Which Emacs version do you care about? I see defvar-local already in 24.3.1, which I believe is the version that most package managers provide.

I would like to try something like this instead of not using defvar-local:

(eval-when-compile
  (unless (fboundp 'defvar-local)
    (defmacro defvar-local (var val &optional docstring)
      "Define VAR as a buffer-local variable with default value VAL."
      (declare (debug defvar) (doc-string 3))
      ;; Can't use backquote here, it's too early in the bootstrap.
      (list 'progn (list 'defvar var val docstring)
            (list 'make-variable-buffer-local (list 'quote var))))))
Owner

abo-abo commented Mar 3, 2016

Which Emacs version do you care about? I see defvar-local already in 24.3.1, which I believe is the version that most package managers provide.

I would like to try something like this instead of not using defvar-local:

(eval-when-compile
  (unless (fboundp 'defvar-local)
    (defmacro defvar-local (var val &optional docstring)
      "Define VAR as a buffer-local variable with default value VAL."
      (declare (debug defvar) (doc-string 3))
      ;; Can't use backquote here, it's too early in the bootstrap.
      (list 'progn (list 'defvar var val docstring)
            (list 'make-variable-buffer-local (list 'quote var))))))
@syohex

This comment has been minimized.

Show comment
Hide comment
@syohex

syohex Mar 3, 2016

Contributor

Which Emacs version do you care about?

24.1 and 24.2.

;; Package-Requires: ((emacs "24.1"))

ivy.el requires 24.1 or higher version.

However I think it is no problem to drop support of 24.1 and 24.2.

Contributor

syohex commented Mar 3, 2016

Which Emacs version do you care about?

24.1 and 24.2.

;; Package-Requires: ((emacs "24.1"))

ivy.el requires 24.1 or higher version.

However I think it is no problem to drop support of 24.1 and 24.2.

@abo-abo abo-abo closed this in f5a21db Mar 3, 2016

@abo-abo

This comment has been minimized.

Show comment
Hide comment
@abo-abo

abo-abo Mar 3, 2016

Owner

Please test.

I found this to work on 24.2, but I didn't manage to compile 24.1 on my system.

Owner

abo-abo commented Mar 3, 2016

Please test.

I found this to work on 24.2, but I didn't manage to compile 24.1 on my system.

@syohex syohex deleted the syohex:older-emacs branch Mar 3, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment