Skip to content
Permalink
master
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time

Installation

Installing/Upgrading From the PyPI

$ pip install polyglot

Dependencies

polyglot depends on numpy, icu and pyicu <https://github.com/ovalhub/pyicu>.

Ubuntu/Debian Linux distribution you can install such packages by executing the following command:

sudo apt-get install python-numpy libicu-dev python-icu

Or if you're using Python 3:

sudo apt-get install python3-numpy libicu-dev python3-icu

Note: If you try to load polyglot and it tells you ImportError: No module named 'icu', then it's pyicu that you're missing.

From Source

polyglot is actively developed on Github.

You can clone the public repo:

git clone https://github.com/aboSamoor/polyglot

Or download one of the following:

Once you have the source, you can install it into your site-packages with:

python setup.py install

Get the bleeding edge version

To get the latest development version of polyglot, run :

$ pip install -U git+https://github.com/aboSamoor/polyglot.git@master

Python

polyglot supports Python >=2.7 or >=3.4.