Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

cannot install Template 2.24 at cygwin #11

Closed
redguardtoo opened this Issue Jul 5, 2012 · 1 comment

Comments

Projects
None yet
2 participants

I ran cpanm Template and failed

Here is the ~/.cpanm/build.log. Please note that latest cygwin has only gcc3.

make[1]: Entering directory `/home/chenbi/.cpanm/work/1341477673.5592/Template-Toolkit-2.24/xs'
gcc-4 -c    -DPERL_USE_SAFE_PUTENV -U__STRICT_ANSI__ -g3 -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -DUSEIMPORTLIB -O3    -DVERSION=\"2.24\"  -DXS_VERSION=\"2.24\"  "-I/usr/lib/perl5/5.10/i686-cygwin/CORE"   Stash.c
/bin/sh: gcc-4: command not found
Makefile:308: recipe for target `Stash.o' failed
make[1]: *** [Stash.o] Error 127
make[1]: Leaving directory `/home/chenbi/.cpanm/work/1341477673.5592/Template-Toolkit-2.24/xs'
Makefile:900: recipe for target `subdirs' failed
make: *** [subdirs] Error 2
-> FAIL Installing . failed. See /home/chenbi/.cpanm/build.log for details.
Contributor

colinmkeith commented Jul 10, 2013

This is not an issue with TT, but with cygwin not installing gcc4 as a dependency of Perl:

http://comments.gmane.org/gmane.os.cygwin/135315

http://stackoverflow.com/questions/10938157/perl-csv-xs-module-installation-failed-using-cygwin

I recommend that this issue be closed as not a TT issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment