Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Compiling with gcc version <6? #17

Closed
zanellia opened this Issue Nov 14, 2016 · 2 comments

Comments

Projects
None yet
3 participants
@zanellia
Copy link
Member

zanellia commented Nov 14, 2016

Installation seems to be broken with gcc-4 mainly due to warnings in compiling qpOASES being treated as errors. Installs fine with gcc-6.

@giaf

This comment has been minimized.

Copy link
Collaborator

giaf commented Nov 14, 2016

ATM as a workaround you need to remove the flag -Werror from
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra -Werror -Wno-unused-function")
in CMakeLists.txt

But it would be nice to have a better solution.

@roversch roversch closed this in 0bae12a Dec 14, 2016

@roversch

This comment has been minimized.

Copy link
Contributor

roversch commented Dec 14, 2016

gcc 4.9 and gcc 5 are now supported

zanellia pushed a commit that referenced this issue Apr 11, 2019

zanellia added a commit that referenced this issue Apr 11, 2019

Merge pull request #17 from jkoendev/docu
Docs for function in ocp_nlp interface and ocp_qp interface
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.