fix boost macros on non-GNU systems #17

Merged
merged 1 commit into from Jan 13, 2013

Conversation

Projects
None yet
2 participants

Both boost_system and boost_filesystem macros rely on the GNU tac tool and sed behaviour which isn't compatible with POSIX systems, like Mac OS X. This updates both files with upstream fixes from autoconf-archive; one patch is already in the repository, the other has been submitted.

I've tested, and this fixes the Gource configure script on OS X.

@mistydemeo Peter Johansson fix boost macros on non-GNU systems
Both boost_system and boost_filesystem macros rely on the GNU `tac`
tool and sed behaviour which isn't compatible with POSIX systems, like
Mac OS X. This updates both files with upstream fixes from
autoconf-archive; one patch is already in the repository, the other
has been submitted.
5513b08

(I applied the upstream commit directly to the Gource repo, hence the slightly wonky credit.)

@acaudwell acaudwell added a commit that referenced this pull request Jan 13, 2013

@acaudwell acaudwell Merge pull request #17 from mistydemeo/boost_m4
fix boost macros on non-GNU systems
ba3df41

@acaudwell acaudwell merged commit ba3df41 into acaudwell:master Jan 13, 2013

Owner

acaudwell commented Jan 13, 2013

Thanks for this.

mistydemeo deleted the mistydemeo:boost_m4 branch Jan 26, 2013

koraktor referenced this pull request in Homebrew/legacy-homebrew Apr 26, 2013

Closed

Update Gource to 0.40 #19444

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment