Skip to content
Permalink
Browse files

Add pyaudio as optional requirement

It is only needed to use the audio module.
  • Loading branch information...
Alexandre Chabot-Leclerc
Alexandre Chabot-Leclerc committed Aug 11, 2014
1 parent 2d90791 commit de75c5f938cad26353e1e6e3d40fb456687f1d34
Showing with 7 additions and 1 deletion.
  1. +4 −1 README.rst
  2. +3 −0 optional-requirements.txt
@@ -36,7 +36,10 @@ The main dependencies are `Numpy <http://www.numpy.org/>`__>= 1.8.0,
codebase for Python 2 and Python 3). Lower versions of these packages
are likely to work as well but have not been thoroughly tested.

For running tests, you will need `pytest <http://pytest.org/>`__.
`pyaudio <http://people.csail.mit.edu/hubert/pyaudio/>`_ is required if you
want to use the ``audio`` module.

For running tests, you will need `pytest <http://pytest.org/>`_.

Install
-------
@@ -0,0 +1,3 @@
--allow-external PyAudio
--allow-unverified PyAudio
PyAudio

0 comments on commit de75c5f

Please sign in to comment.
You can’t perform that action at this time.