Is iTerm2 supported? #3

Open
mattfordham opened this Issue Oct 31, 2011 · 5 comments

2 participants

@mattfordham

I added the OSX core, but I still get a "No valid core was found!. Exiting..." message. Thanks!

@achiu
Owner

I'm still adding in iTerm back in. I'll post back here shortly when I'm finished.

@mattfordham

Great, thanks!

@achiu
Owner

@mattfordham I've added support for iTerm here. Let me know if this works for you. Thanks!

@mattfordham mattfordham reopened this Nov 2, 2011
@mattfordham

Thanks! I installed and gave it a spin. Unfortunately, there seems to be an issue with tabs and panes. Running the following, as outlined in the README, opens a new tab but doesn't create any panes. I am using the latest iTerm2: Build 1.0.0.20111020.

tab do
  pane "gitx"    # first pane
    pane do      # second pane level => horizontal split
      run "irb"
    end
  pane 'ls'      # first pane level => vertical split
end
@achiu
Owner

@mattfordham yeah I'm aware of this issue. I should update the README. to work around it, don't wrap the pane calls in tab. you could do:

pane do
  pane 'hey'
end
pane do
  pane 'ls'
end

and that would work. Alternatively, you can use window instead of tab to wrap the panes as well. I'll see if i can fix that issue though.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment