Skip to content

Compare: 说明

New page
Showing with 197 additions and 15 deletions.
  1. +28 −11 Deploy-ssl-certs-to-apache-server.md
  2. +12 −2 Synology-NAS-Guide.md
  3. +138 −2 dnsapi2.md
  4. +19 −0 说明.md
19 changes: 19 additions & 0 deletions 说明.md
Original file line number Diff line number Diff line change
Expand Up @@ -299,4 +299,23 @@ docker run --rm -it \

上述例子中使用 Cloudflare 的 DNS 来签发证书,并通过把 acme.sh 链接到容器[代理A],来转发 curl 请求(请按照自己实际设定修改)

# 9. acme.sh.log日志文件时间展示问题:
## 问题说明:
证书每 60 天更新一次(可自定义),自己通过`/用户名/.acme.sh/acme.sh.log`路径下的日志实测查看:
会在**中午**检查并生成检查记录:`[12:48:01 AM CST 2025] Running cmd: cron......`
可官方文档明明指出,会在**每日凌晨**自动检查并生成检查记录。自己再次通过linux系统查看`acme.sh.log文件`的更新时间,的确是**每日凌晨**。那就说明.acme.sh【运行或展示】时在中国产生了时差。
## 结论概述:
运行或展示均无问题!
而是中文语境对英文的12小时制时间有些人会有误解,所以正确结论是:
12小时制将一天分为两组12小时(AM和PM),其小时数字范围是 ‌1至12‌,而非24小时制的0至23
* 凌晨00:30 | 00:30(24小时制) | ‌【‌正确】12:30 AM‌ | 【错误】00:30 AM | 混淆24小时制与12小时制的数字规则
* 中午12:30 | 12:30(24小时制) | ‌【‌正确】12:30 PM‌ | 【错误】00:30 PM | 误将正午后的时间归为AM时段

## 原因分析:
如果你的服务器date命令输出是12小时制,那acme.sh.log日志文件也会跟着展示12小时制时间。因为脚本acme.sh本身默认直接调用系统的date命令。
## 详细分析:
请参见本人博客:[12小时制零点半【是】12:30 AM【不是】00:30 AM!](https://a.guoqw.com/%E8%AE%A1%E7%AE%97%E6%9C%BA%E4%B8%8E%E7%BD%91%E7%BB%9C/12%E5%B0%8F%E6%97%B6%E5%88%B6%E9%9B%B6%E7%82%B9%E5%8D%8A%E3%80%90%E6%98%AF%E3%80%9112%EF%BC%9A30%20AM%E3%80%90%E4%B8%8D%E6%98%AF%E3%80%9100%EF%BC%9A30%20AM%EF%BC%81.html#acme-sh%E8%87%AA%E5%8A%A8%E5%8C%96%E6%95%B0%E5%AD%97%E8%AF%81%E4%B9%A6)
***


最后,本文并非完全的使用说明,还有很多高级的功能,更高级的用法请参看 wiki 页面:https://github.com/acmesh-official/acme.sh/wiki/