Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Removing (seemingly) unnecessary dependency on ruby 1.9.3. #5

Closed
wants to merge 1 commit into from

2 participants

@someara

Opscode will be shipping ruby 1.9.2 embedded in it's omnibus builds for both client and server. This gem is awesome and crazy useful, and should be compatible with mainline chef's environment

@someara someara Removing (seemingly) unnecessary dependency on ruby 1.9.3. Opscode wi…
…ll be shipping ruby 1.9.2 embedded in it's omnibus builds for both client and server. This gem is awesome and crazy useful, and should be compatible with mainline chef's environment
6a58929
@acrmp acrmp referenced this pull request from a commit
@acrmp Relax MRI version to 1.9.2, refs #5. cf341bc
@acrmp acrmp referenced this pull request from a commit
@acrmp Bump version for release, refs #5. a085f81
@acrmp
Owner

Hi Sean,

Good call - omnibus compatibility will definitely be the way to go.

The ruby version constraint was there because Ripper (included in the stdlib) was supposed to have had a bunch of bugfixes introduced in 1.9.3.

The features are all green on 1.9.2 though so this looks cool to relax. I'm going to make it 1.9.2+ although with ripper18 in theory we could make it run on the 1.8 series too.

I've pushed it to rubygems as foodcritic 0.5.1.

Thanks!

Andrew.

@acrmp acrmp closed this
@someara
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Dec 14, 2011
  1. @someara

    Removing (seemingly) unnecessary dependency on ruby 1.9.3. Opscode wi…

    someara authored
    …ll be shipping ruby 1.9.2 embedded in it's omnibus builds for both client and server. This gem is awesome and crazy useful, and should be compatible with mainline chef's environment
This page is out of date. Refresh to see the latest.
Showing with 0 additions and 1 deletion.
  1. +0 −1  foodcritic.gemspec
View
1  foodcritic.gemspec
@@ -14,5 +14,4 @@ Gem::Specification.new do |s|
s.add_dependency('gherkin', '~> 2.7.1')
s.add_dependency('nokogiri', '~> 1.5.0')
s.files = Dir['lib/**/*.rb']
- s.required_ruby_version = '>= 1.9.3'
end
Something went wrong with that request. Please try again.