Adding activeadmin to gem file makes bundle install hang. #182

Closed
stewartmatheson opened this Issue Jun 9, 2011 · 13 comments

Projects

None yet

9 participants

@stewartmatheson

Hey,

Really keen to use activeadmin looks amazing. Great work guys. However I cant seem to install the gems for it. When I add activeadmin to my gemfile bundle install just hangs

~/code/rails/activeadmintest $ bundle install
Fetching source index for http://rubygems.org/

If I remove the gem from my gem file then everything works. Any ideas or is this an issue with rubygems?

@guilleiguaran

I'm having same error today

@pcreux
Contributor
pcreux commented Jun 9, 2011

It hangs for more than 5 minutes?

@pcreux
Contributor
pcreux commented Jun 10, 2011

It works fine for me with Bundler version 1.0.7 and the following line in my Gemfile:
gem 'activeadmin', :git => 'git://github.com/gregbell/active_admin', :ref => '6af84dd9f42d0007bcec'

@guilleiguaran

Yes, right now I have more than 15 minutes waiting. Some info:

% bundle --version 
Bundler version 1.0.13

Gemfile:

gem 'activeadmin', :git => 'git://github.com/gregbell/active_admin.git', :branch => 'rails-3-1'
@epochwolf
Contributor

Same issue, same config as guilleiguaran

@webmat
Contributor
webmat commented Jun 10, 2011

+1 on this issue. I've been having it on and off as well.

@webmat
Contributor
webmat commented Jun 10, 2011

I tried it on a brand new Rails 3.1.rc3 app, with only 1 line added to the gemfile:

source 'http://rubygems.org'

gem 'rails', '3.1.0.rc3'
...
gem 'activeadmin', :git => 'git://github.com/gregbell/active_admin.git', :branch => "rails-3-1"

It took a good while of perusing Hacker News to get to:

$ bundle install
Bundling your gems. This may take a few minutes on first run.
Updating git://github.com/gregbell/active_admin.git
Fetching source index for http://rubygems.org/
Bundler could not find compatible versions for gem "arel":
  In Gemfile:
    activeadmin depends on
      arel (~> 1.0.0.rc1)

    rails (= 3.1.0.rc3) depends on
      arel (2.1.1)

Maybe active_admin's dependency on Rails >= 3.0.0 is what's causing this?

@gregbell
Contributor

This only happens in the rails-3-1 branch and is because of a dependency on a pre-release of meta_search. to fix the problem, add this to your Gemfile:

gem "meta_search",    '>= 1.1.0.pre'
@gregbell gregbell closed this Jun 10, 2011
@webmat
Contributor
webmat commented Jun 10, 2011

Awesome, thanks!

@Bivek
Bivek commented Oct 4, 2011

Thanks Greg.

@stewartmatheson

Cheers for this one. Works for me now and made some clients very happy :)

@shoaibmalik786

@gregbell - I am getting the same issue in rails 4,
gem "meta_search", '>= 1.1.0.pre' doesn't resolve my issue..
Any Solution please?

@shekibobo
Contributor

ActiveAdmin (compatible with rails 4) doesn't use meta_search. In your Gemfile you should be including ActiveAdmin like this:

gem 'activeadmin', github: 'gregbell/active_admin'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment