Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

jquery-ui method errors #493

Closed
iwarshak opened this Issue Sep 19, 2011 · 2 comments

Comments

Projects
None yet
3 participants

I just ran into a very subtle bug where I was including jquery and jquery-ui (which came from the jquery-rails) gem into active_admin.js

Since jquery and jquery ui were being included twice (active_admin has it's own version of jquery in vendor.js), I ran into some very strange and issues where jquery-ui methods were failing with no method errors, and type errors. I tried re-ordering the includes, but it still caused issues.

Perhaps instead active_admin could explicitly require the jquery-rails gem and explicitly require them in active_admin.js instead of bundling them into vendor.js.

(As a sidenote, the version of jquery-ui that is bundled is over a year old)

Agreed. It's causing problems for me as well.

Contributor

gregbell commented Nov 24, 2011

This should be fixed on master. It will be released in 0.4.0. The main discussion happened in #468

@gregbell gregbell closed this Nov 24, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment