Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Preparing for 1.20.3 release

  • Loading branch information...
commit e11c1102672459edbacba7d36f53727f6309c1e7 1 parent dac747f
@jduff jduff authored
Showing with 11 additions and 1 deletion.
  1. +10 −0 CHANGELOG
  2. +1 −1  lib/active_merchant/version.rb
View
10 CHANGELOG
@@ -1,5 +1,15 @@
= ActiveMerchant CHANGELOG
+== Version 1.20.3 (February 7, 2012)
+
+* Various fixes to support Ruby 1.9 [wisq]
+* SkipJack: Fix partial capture [jduff]
+* Optimal Payments: submit region when outside North America [jduff]
+* USA ePay: Add void and refund support [duff/ntalbott]
+* Add first digits to credit card [codyfauser]
+* Orbital: fixes to authentication and order id [Soleone]
+* Stripe: fixes to purchase method [duff/ntalbott]
+
== Version 1.20.2 (January 16, 2012)
* Remove authorize/capture support for Stripe [gdb]
View
2  lib/active_merchant/version.rb
@@ -1,3 +1,3 @@
module ActiveMerchant
- VERSION = "1.20.2"
+ VERSION = "1.20.3"
end

1 comment on commit e11c110

@rubys

Note: this release will not work on the upcoming Rails 4.0 master:

http://intertwingly.net/projects/AWDwR4/checkdepot-193-40/section-26.1.html

The problem is that 'active_support/base64' is deprecated in Rails 3.2 and eliminated in Rails 4.0:

https://github.com/Shopify/active_merchant/blob/master/lib/active_merchant.rb#L33

I see a pull request with a potential fix:

#245

Please sign in to comment.
Something went wrong with that request. Please try again.