Permalink
Browse files

Deprecate core extensions

  • Loading branch information...
ernie committed Sep 3, 2012
1 parent b420412 commit df12f2e36d56b1faa73f1ef275712f481b23be0c
Showing with 8 additions and 2 deletions.
  1. +6 −1 CHANGELOG.md
  2. +1 −0 lib/squeel/configuration.rb
  3. +1 −1 lib/squeel/version.rb
View
@@ -1,3 +1,8 @@
+## 1.1.0 (unreleased)
+
+* Deprecated core extensions. In Squeel 2.0, the DSL will be the way to
+ construct queries, and Symbol/Hash extensions will go away.
+
## 1.0.11 (2012-09-03)
* Fixed issue #157, resolving problems when joining the same table twice.
@@ -6,7 +11,7 @@
## 1.0.10 (2012-09-01)
- * Yanked from RubyGems.org due to semantic versioning oversight
+* Yanked from RubyGems.org due to semantic versioning oversight
## 1.0.9 (2012-08-06)
@@ -33,6 +33,7 @@ def configure
# @param [Symbol] sym1 :hash or :symbol
# @param [Symbol] sym2 :hash or :symbol
def load_core_extensions(*exts)
+ deprecate 'Core extensions are deprecated and will be removed in Squeel 2.0.'
exts.each do |ext|
require "squeel/core_ext/#{ext}"
end
View
@@ -1,3 +1,3 @@
module Squeel
- VERSION = "1.0.11"
+ VERSION = '1.1.0'
end

2 comments on commit df12f2e

@parndt

This comment has been minimized.

Show comment
Hide comment
@parndt

parndt Apr 16, 2014

Is there an alternative in version 1.1.x? Can someone please provide an example? (I know it's not maintained)

Is there an alternative in version 1.1.x? Can someone please provide an example? (I know it's not maintained)

@the8472

This comment has been minimized.

Show comment
Hide comment
@the8472

the8472 Apr 16, 2014

use the DSL

use the DSL

Please sign in to comment.