Skip to content

Loading…

Rails 4 support #239

Closed
leh opened this Issue · 9 comments

6 participants

@leh
leh commented

As Rails reached Release Candidate state support for it in Squell would be pretty magnificent.

@TvL2386

:+1: Came here for the exact same request :-)

@canweriotnow

I came here because I was told there would be delicious cake :cake:, but I'm staying for the same request. :+1:

@ernie
ActiveRecord Hackery member
@canweriotnow

@ernie sweet! I may have some time to fork & play with it this weekend, if I'm not bogged down with work stuff.

@ernie ernie added a commit that referenced this issue
@ernie ernie Initial work on 4.0.0 compatibility. Specs pass.
This work will not be backwards compatible with 3.x at the moment.

References #239
c71db6c
@ernie
ActiveRecord Hackery member

Hey folks. Give master a shot and let me know what's broken. A bunch of issues, mostly related to the WhereChain hack, but I think I have most of them ironed out.

@ernie
ActiveRecord Hackery member

Anyone tried master? Anyone had success? Failure?

There will be no :cake: until answers are had.

@vendethiel

ಠ益ಠ give us the cake

@QBD
QBD commented

Hey Ernie, Thanks for the gem,
Just thought I'd let you know that when trying to bundle squeel with rails 4.1.0.beta the following error is given as output:

Bundler could not find compatible versions for gem "activerecord":
    In Gemfile:
        squeel (>= 0) ruby depends on
            activerecord (~> 3.1.0.alpha) ruby

        rails (>= 0) ruby depends on
            activerecord (4.1.0.beta)
@ernie
ActiveRecord Hackery member

Yeah, there's no 4.0-compatible version released in Gem format yet. If you bundle from the master branch you should be OK.

@ernie ernie closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.