Permalink
Browse files

Add gemspec to assert_same library and include bundler's rake tasks

to make it possible to build and install assert_same gem with:
rake build && rake install
or
gem build assert_same.gemspec && gem install assert_same-0.1.gem
  • Loading branch information...
1 parent e508846 commit 213f626e21e907c769745d8a4068ce38aff7dfad @adymo adymo committed Mar 16, 2012
Showing with 23 additions and 0 deletions.
  1. +3 −0 Rakefile
  2. +20 −0 assert_same.gemspec
View
@@ -1,6 +1,9 @@
require 'rake'
require 'rake/testtask'
require 'rake/rdoctask'
+require 'bundler'
+
+Bundler::GemHelper.install_tasks
desc 'Default: run unit tests.'
task :default => :test
View
@@ -0,0 +1,20 @@
+require 'rubygems'
+
+SPEC = Gem::Specification.new do |s|
+ s.name = "assert_same"
+ s.version = "0.1"
+ s.author = "Pluron, Inc."
+ s.email = "support@pluron.com"
+ s.homepage = "http://github.com/acunote/assert_same"
+ s.platform = Gem::Platform::RUBY
+ s.description = "assert_same assertion"
+ s.summary = "Assert which checks that two strings (expected and actual) are same and which can magically replace expected value with the actual in case the new behavior (and new actual value) is correct"
+
+ s.add_development_dependency('bundler', '>= 1.0.0')
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- test/*`.split("\n")
+
+ s.require_path = "lib"
+ s.has_rdoc = true
+end

0 comments on commit 213f626

Please sign in to comment.