can't reach webide after installing SiriProxy #125

Closed
xzentorzx opened this Issue Jan 29, 2013 · 3 comments

Projects

None yet

2 participants

@xzentorzx

After installing SiriProxy following this guide http://www.idownloadblog.com/2011/12/09/how-to-install-siri-proxy-tutorial-video/ I can't reach my Pi neither via IP nor via raspberry.local anymore. I'm pretty new to all that command line magic and therefore have only a faint idea of what those steps installed... Can somebody guess what's wrecked the webide? Deinstall/reinstall, reboot, restart server (restart failed), stop and start server again all failed so far. Any suggestions?

@xzentorzx

BTW. Here's an entry of the errors.log (Error occurs every 20 seconds).

2013-01-29T07:59:20.994Z - error: uncaughtException date=Tue Jan 29 2013 08:59:20 GMT+0100 (CET),
pid=8530, uid=1001, gid=1002, cwd=/, execPath=/usr/share/adafruit/webide/bin/node_hf/node,
version=v0.8.16, argv=[/usr/share/adafruit/webide/bin/node_hf/node, /usr/share/adafruit/webide/server.js],
rss=38207488, heapTotal=37230976, heapUsed=20707468, loadavg=[1.064453125, 0.86181640625, 0.802734375],
uptime=30577.831560565, trace=[column=24, file=/usr/share/adafruit/webide/node_modules/redis/index.js,
function=RedisClient.on_error, line=148, method=on_error, native=false, column=14,
file=/usr/share/adafruit/webide/node_modules/redis/index.js, function=, line=83, method=null, native=false,
column=17, file=events.js, function=Socket.EventEmitter.emit, line=96, method=EventEmitter.emit, native=false,
column=14, file=net.js, function=Socket._destroy.self.errorEmitted, line=329, method=_destroy.self.errorEmitted,
native=false, column=9, file=node.js, function=process.startup.processNextTick.process._tickCallback, line=244,
method=startup.processNextTick.process._tickCallback, native=false],
stack=[Error: Redis connection to 127.0.0.1:6379 failed - connect ECONNREFUSED,
at RedisClient.on_error (/usr/share/adafruit/webide/node_modules/redis/index.js:148:24),
at Socket. (/usr/share/adafruit/webide/node_modules/redis/index.js:83:14),
at Socket.EventEmitter.emit (events.js:96:17),
at Socket._destroy.self.errorEmitted (net.js:329:14),
at process.startup.processNextTick.process._tickCallback (node.js:244:9)]

@jwcooper
Member

In this case, it looks like the redis server isn't started for some reason:
Error: Redis connection to 127.0.0.1:6379 failed - connect ECONNREFUSED

Try typing 'redis-server' at the command line, and try refreshing the webide.

@jwcooper
Member
jwcooper commented Apr 5, 2013

Consolidating this issue to here: #184

@jwcooper jwcooper closed this Apr 5, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment