Permalink
Browse files

Initial commit

  • Loading branch information...
0 parents commit 87036dd7dfb72d588e14b312ceaae7a1a326353b @adamstac committed Nov 26, 2011
@@ -0,0 +1,3 @@
+.sass-cache
+.DS_Store
+*.gem
1 .rvmrc
@@ -0,0 +1 @@
+rvm ruby-1.9.2@animate --create
15 Gemfile
@@ -0,0 +1,15 @@
+source :rubygems
+
+gem 'compass', '~> 0.11.5'
+
+group :development do
+ gem 'rake'
+ gem 'heroku'
+end
+
+group :serve do
+ gem 'serve', '~> 1.5.1'
+ gem 'haml', '~> 3.1.3'
+ gem 'css_parser', '~> 1.2.5'
+ gem 'maruku', '~> 0.6.0'
+end
@@ -0,0 +1,58 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ activesupport (3.1.0)
+ multi_json (~> 1.0)
+ addressable (2.2.6)
+ chunky_png (1.2.1)
+ compass (0.11.5)
+ chunky_png (~> 1.2)
+ fssm (>= 0.2.7)
+ sass (~> 3.1)
+ css_parser (1.2.5)
+ addressable
+ fssm (0.2.7)
+ haml (3.1.3)
+ heroku (2.7.0)
+ launchy (>= 0.3.2)
+ rest-client (~> 1.6.1)
+ rubyzip
+ term-ansicolor (~> 1.0.5)
+ i18n (0.6.0)
+ launchy (2.0.5)
+ addressable (~> 2.2.6)
+ maruku (0.6.0)
+ syntax (>= 1.0.0)
+ mime-types (1.16)
+ multi_json (1.0.3)
+ rack (1.3.2)
+ rack-test (0.6.1)
+ rack (>= 1.0)
+ rake (0.9.2)
+ rest-client (1.6.7)
+ mime-types (>= 1.16)
+ rubyzip (0.9.4)
+ sass (3.1.7)
+ serve (1.5.1)
+ activesupport (~> 3.0)
+ i18n
+ rack (~> 1.2)
+ rack-test (~> 0.5)
+ tilt (~> 1.3)
+ tzinfo
+ syntax (1.0.0)
+ term-ansicolor (1.0.6)
+ tilt (1.3.3)
+ tzinfo (0.3.29)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ compass (~> 0.11.5)
+ css_parser (~> 1.2.5)
+ haml (~> 3.1.3)
+ heroku
+ maruku (~> 0.6.0)
+ rake
+ serve (~> 1.5.1)
@@ -0,0 +1,21 @@
+# Compass Extension Bootstrap
+
+A simple starting point for creating Compass extensions.
+
+## Installation
+
+...
+
+## Usage
+
+...
+
+## License
+
+Copyright (c) 2009-2011 Adam Stacoviak
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
@@ -0,0 +1,25 @@
+require './lib/animate-sass'
+
+namespace :sass do
+
+ desc "Converts the Sass to SCSS"
+ task :convert do
+ puts "*** Converting Sass to SCSS ***"
+ system "sass-convert stylesheets/*.sass stylesheets/*.scss"
+ end
+
+end
+
+namespace :gem do
+
+ desc "Build the gem"
+ task :build do
+ system "gem build *.gemspec"
+ end
+
+ desc "Build and release the gem"
+ task :release => :build do
+ system "gem push animate-sass-#{AnimateSass::VERSION}.gem"
+ end
+
+end
@@ -0,0 +1,28 @@
+require './lib/animate-sass'
+
+Gem::Specification.new do |s|
+ # Release information
+ s.version = AnimateSass::VERSION
+ s.date = AnimateSass::DATE
+
+ # Gem author details
+ s.name = "animate-sass"
+ s.summary = %q{Sass and Compass CSS animations library for WebKit, Firefox and beyond, based on Animate.css} # one-liner
+ s.description = %q{Animate.sass is a Sass and Compass CSS animations library for WebKit, Firefox and beyond based on the work being done in Animate.css} # long-form
+ s.authors = ["Adam Stacoviak"]
+ s.email = ["adam@stacoviak.com"]
+ s.homepage = "https://github.com/adamstac/animate.sass"
+
+ # Gem files
+ # These are the files that get distributated in the gem
+ s.files = ["README.mdown"]
+ s.files += Dir.glob("lib/**/*.*")
+ s.files += Dir.glob("stylesheets/**/*.*")
+ # s.files += Dir.glob("templates/**/*.*")
+
+ # Gem bookkeeping
+ s.required_rubygems_version = ">= 1.3.6"
+ s.rubygems_version = %q{1.3.6}
+ # Adding a dependency for Compass ensures we also install Sass
+ s.add_dependency("compass", [">= 0.11.5"])
+end
@@ -0,0 +1,9 @@
+require 'compass'
+Compass::Frameworks.register("animate-sass", :path => "#{File.dirname(__FILE__)}/..")
+
+module AnimateSass
+
+ VERSION = "0.0.1"
+ DATE = "2011-09-15"
+
+end
@@ -0,0 +1,8 @@
+// Animate mixin
+@import "css3";
+
+@mixin animate($name: fadeIn, $duration: 1s, $delay: 0.2s, $function: ease, $mode: both) {
+ @include experimental(animation, $name $duration $delay $function $mode);
+}
+
+@import "animate/animations";
@@ -0,0 +1,2 @@
+@import "css3/animation";
+@import "css3/transform";
Oops, something went wrong.

0 comments on commit 87036dd

Please sign in to comment.