Browse files

Updated the readme, dropped meyer-reset and the version file

  • Loading branch information...
1 parent 05a73e5 commit 62c22ce921caff38e02a531a1a34625e166711f1 @adamstac committed Jun 1, 2011
Showing with 34 additions and 28 deletions.
  1. +1 −2 Gemfile
  2. +1 −4 Gemfile.lock
  3. +26 −9 README.mdown
  4. +0 −1 VERSION
  5. +6 −11 public/stylesheets/application.css
  6. +0 −1 views/stylesheets/application.sass
View
3 Gemfile
@@ -5,5 +5,4 @@ gem "shotgun", "~> 0.9"
gem "haml", "~> 3.1.1"
gem "sass", "~> 3.1.1"
gem "compass", "~> 0.11.1"
-gem "grid-coordinates", "~> 1.1.4"
-gem "meyer-reset", "~> 2.0.0"
+gem "grid-coordinates", "~> 1.1.4"
View
5 Gemfile.lock
@@ -10,15 +10,13 @@ GEM
grid-coordinates (1.1.4)
compass (>= 0.10.5)
haml (3.1.1)
- meyer-reset (2.0.0)
- compass (>= 0.10.5)
rack (1.3.0)
sass (3.1.2)
shotgun (0.9)
rack (>= 1.0)
sinatra (1.2.6)
rack (~> 1.1)
- tilt (>= 1.2.2, < 2.0)
+ tilt (< 2.0, >= 1.2.2)
tilt (1.3.2)
PLATFORMS
@@ -28,7 +26,6 @@ DEPENDENCIES
compass (~> 0.11.1)
grid-coordinates (~> 1.1.4)
haml (~> 3.1.1)
- meyer-reset (~> 2.0.0)
sass (~> 3.1.1)
shotgun (~> 0.9)
sinatra (~> 1.2.3)
View
35 README.mdown
@@ -18,20 +18,37 @@ I created Sinatra Bootstrap in order to have a consistent starting point for my
## How do I get started?
-First we need to clone Sinatra Bootstrap and run [Bundler](http://gembundler.com/) to get the required gems installed.
+If you're using [RVM](https://rvm.beginrescueend.com/), there's an `.rvmrc` file in the root of the project that automatically sets the Ruby version to 1.9.2 and the gemset to `sinatra-bootstrap`. You'll need to have 1.9.2 in place and a gemset called `sinatra-bootstrap` in place before moving on (only if you are using RVM though). See the [RVM docs](http://beginrescueend.com/rubies/docs/) if you need help or send me message if you get stuck here.
-If you don't have Bundler installed, run the following at the command prompt:
+First you'll need to fork the project and then clone your Sinatra Bootstrap to your local machine.
- gem install bundler
-
-To get started with using Sinatra Bootstrap, fork the repo and pull down a copy from your fork to your local machine. It makes sense to store this where you store your other codes, for example:
+ git clone git@github.com:YOURUSER/sinatra-bootstrap.git
- cd Code/path/to/codes
- git clone git@github.com:USERNAME/sinatra-bootstrap.git
+Then we need to run `bundle install` to install the required gems as specified by the [Gemfile](https://github.com/adamstac/sinatra-bootstrap/blob/master/Gemfile).
-From inside the root of your newly cloned repo, run the following at the command prompt:
+If you're in a fresh gemset or you don't have Bundler installed, run the following at the command prompt:
- bundle install
+ gem install bundler
+
+You should see output like this:
+
+ sinatra-bootstrap :: (master) » gem install bundler
+ Successfully installed bundler-1.0.14
+ 1 gem installed
+ sinatra-bootstrap :: (master) » bundle install
+ Fetching source index for http://rubygems.org/
+ Installing chunky_png (1.2.0)
+ Installing fssm (0.2.7)
+ Installing sass (3.1.2)
+ Installing compass (0.11.1)
+ Installing grid-coordinates (1.1.4)
+ Installing haml (3.1.1)
+ Installing rack (1.3.0)
+ Installing shotgun (0.9)
+ Installing tilt (1.3.2)
+ Installing sinatra (1.2.6)
+ Using bundler (1.0.14)
+ Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.
## How do I start the application?
View
1 VERSION
@@ -1 +0,0 @@
-1.0.1
View
17 public/stylesheets/application.css
@@ -55,25 +55,20 @@ footer, header, hgroup, menu, nav, section {
display: block;
}
-article, aside, details, figcaption, figure,
-footer, header, hgroup, menu, nav, section {
- display: block;
-}
-
a {
- color: #36c;
+ color: #3366cc;
}
a:hover {
- color: #36c;
+ color: #3366cc;
text-decoration: none;
}
a:focus, a:active {
outline: none;
}
body {
- font: 13px Arial,Helvetica,sans-serif;
- background: #fff;
+ font: 13px Arial, Helvetica, sans-serif;
+ background: white;
color: #0d0d0d;
}
body h1 {
@@ -94,7 +89,7 @@ body ul {
-khtml-border-radius: 6px;
border-radius: 6px;
background: #e7e7e7;
- border: 1px solid #ccc;
+ border: 1px solid #cccccc;
margin-top: 10px;
margin-left: 10px;
margin-right: 10px;
@@ -105,7 +100,7 @@ body ul li {
padding: 0 15px;
}
body ul li a {
- color: #000;
+ color: black;
text-decoration: none;
}
body ul li a:hover {
View
1 views/stylesheets/application.sass
@@ -1,5 +1,4 @@
@import compass/reset
-@include reset-html5
@import compass/utilities
@import compass/css3

1 comment on commit 62c22ce

@xlprojects

I think you forgot to remove @require 'meyer-reset'@ from the config.rb l.6 since you've removed meyer-reset...
No?

Please sign in to comment.