Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 26 lines (24 sloc) 1.078 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
<head>
  <title></title>
  <meta http-equiv="content-type" content="text/xhtml; charset=utf-8" />
  <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.1/jquery.js"></script>
</head>
<body>
  <div id="content">
    This file is mean to show multiple versions of jquery on a page. The version loaded by require.js should be isolated from the
    version in the page.
    <div>jQuery Version before loading:<span id="before"></span></div>
    <div>jQuery Version inside main.js should be 1.7.1 is:<span id="inside"></span></div>
    <div>jQuery Version after loading:<span id="after"></span></div>
  </div>
  <script type="text/javascript">
    $('#before').html($.fn.jquery);
  </script>
  <script src="js/libs/require/require.js" data-main="js/main"></script>
  <script type="text/javascript">
    $('#after').html($.fn.jquery);
  </script>
  
</body>
</html>
Something went wrong with that request. Please try again.