Browse files

Merged pull request #1 from AF83/master.

Methopara is not needed for Ruby 1.9.2 and up
  • Loading branch information...
2 parents db0aa8d + ac433ef commit c4c0af13fd70ae40451135a4086a108c6a60b5cb Andy Delcambre committed Apr 25, 2011
Showing with 4 additions and 2 deletions.
  1. +4 −2 lib/rails-action-args/vm_args.rb
View
6 lib/rails-action-args/vm_args.rb
@@ -1,7 +1,9 @@
begin
require "methopara"
-rescue
- puts "make sure you have methora http://github.com/genki/methopara installed if you want to use action args on Ruby 1.9"
+rescue LoadError
+ unless RUBY_VERSION >= "1.9.2"
+ puts "make sure you have methopara (http://github.com/genki/methopara) installed if you want to use action args with Ruby < 1.9.2"
+ end
end
module GetArgs

0 comments on commit c4c0af1

Please sign in to comment.