rcov problem #86

Closed
chytreg opened this Issue Apr 27, 2013 · 1 comment

Comments

Projects
None yet
1 participant
Contributor

chytreg commented Apr 27, 2013

Hi,
I try to run test locally on my machine but it says that:
during bundle install for rcov => Ruby 1.9 is not supported. Please switch to simplecov
Checked the gem github page
https://github.com/relevance/rcov#why-what

Really strage thing for me is: Why Travis CI is working correctly?
In .travis.yml is 1.9.2 and 1.9.3 ruby. Anyone could explain it?

Contributor

chytreg commented Apr 27, 2013

It seems travis use 0.9.11 which don't throw an error during installation but according to this is only for ruby 1.8 https://github.com/relevance/rcov/tree/b5513cae5ea3348d97c21a3c324d8e8a7768e814#why-what

I think we should switch from rcov to simplecov (optional only for ruby 1.9+), nowadays ruby 1.9 is a standard.

@chytreg chytreg closed this Apr 27, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment