Permalink
Browse files

Changed googleearth-6.0.3.2197: explicit dep put on sys-libs/glibc-2.…

…12 and later
  • Loading branch information...
1 parent 3968284 commit 949d9d6e99d3a7d9a287c053173fdc148b41c989 @adessemond committed Aug 23, 2011
View
4 sci-geosciences/googleearth/Manifest
@@ -0,0 +1,4 @@
+DIST GoogleEarthLinux-5.1.3535.3218.bin 25932414 RMD160 46d7a763e835d657798f3cd198f1a7931d31b292 SHA1 3af3c817a587b6bfd6e0fb20de157751a3ea4fda SHA256 f721e4e8db3a7351c77a8aea425ec334ff01e163481cbcf6cdda9dbb0ad422ac
+DIST GoogleEarthLinux-5.2.1.1588.bin 31406473 RMD160 181ed85cb057a2c2eca97f28c07bcda40a2fa0da SHA1 75a458be01c331ac6d4dcd29f91d562fc3dfc604 SHA256 2e6fcbd2384446e2a6eed8ca23173e32c5f3f9ae4d1168e2e348c3924fd2bf30
+DIST GoogleEarthLinux-6.0.2.2074.bin 33685323 RMD160 a00d291279e61a435ee8cb3f89a36cd54b3eb733 SHA1 8eb3a1f5ac607e9dbfc9af67330bcd765227449c SHA256 06cf414d783617a0f7bade21bcc238997140701db6a5cbdf58413cd44f9f5727
+DIST GoogleEarthLinux-6.0.3.2197.bin 33688483 RMD160 a4af85b39bf1f792850aa467a5785e3fe1313382 SHA1 ceb2b16a1cd9ba26c003c8f774054b31a3b53033 SHA256 8c1cabb6a196e93224be05bd8a4786087813075f76e1734a17680c30a9ad972d
View
11 sci-geosciences/googleearth/files/decimal-separator.patch
@@ -0,0 +1,11 @@
+--- googleearth.orig 2009-10-18 15:46:03.000000000 +0200
++++ googleearth 2009-10-18 15:45:39.000000000 +0200
+@@ -41,6 +41,8 @@
+
+ LD_LIBRARY_PATH=.:${GOOGLEEARTH_DATA_PATH}:${LD_LIBRARY_PATH}
+ export LD_LIBRARY_PATH
++export LC_NUMERIC=C
++unset LC_ALL
+
+ # Let's boogie!
+ if [ -x "${GOOGLEEARTH_DATA_PATH}/googleearth-bin" ]
View
12 sci-geosciences/googleearth/files/mime-magic.patch
@@ -0,0 +1,12 @@
+--- usr/share/mime/packages/googleearth-mimetypes.xml 2006-07-22 10:13:03.000000000 +0100
++++ usr/share/mime/packages/googleearth-mimetypes.xml 2006-07-22 10:41:14.584945382 +0100
+@@ -2,6 +2,9 @@
+ <mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/vnd.google-earth.kml+xml">
+ <comment>Keyhole Markup Language data</comment>
++ <magic priority="60">
++ <match value="&lt;kml xmlns=&quot;http://earth.google.com/kml/" type="string" offset="0:64"/>
++ </magic>
+ <glob pattern="*.kml"/>
+ </mime-type>
+
View
157 sci-geosciences/googleearth/googleearth-5.1.3535.3218-r1.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/googleearth-5.1.3535.3218-r1.ebuild,v 1.5 2011/01/31 16:05:44 caster Exp $
+
+EAPI=2
+
+inherit eutils fdo-mime versionator toolchain-funcs
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+# no upstream versioning, version determined from help/about
+# incorrect digest means upstream bumped and thus needs version bump
+SRC_URI="GoogleEarthLinux-${PV}.bin"
+
+LICENSE="googleearth GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="fetch strip"
+IUSE="mdns-bundled qt-bundled"
+
+GCC_NEEDED="4.2"
+
+RDEPEND=">=sys-devel/gcc-${GCC_NEEDED}[-nocxx]
+ x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ sys-libs/zlib
+ dev-libs/glib:2
+ !qt-bundled? (
+ >=x11-libs/qt-core-4.5.3
+ >=x11-libs/qt-gui-4.5.3
+ >=x11-libs/qt-webkit-4.5.3
+ )
+ net-misc/curl
+ sci-libs/gdal
+ !mdns-bundled? ( sys-auth/nss-mdns )
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-20081109
+ >=app-emulation/emul-linux-x86-baselibs-20081109
+ app-emulation/emul-linux-x86-opengl
+ !qt-bundled? (
+ >=app-emulation/emul-linux-x86-qtlibs-20091231-r1
+ )
+ )
+ virtual/ttf-fonts"
+
+S="${WORKDIR}"
+
+QA_TEXTRELS="opt/googleearth/libgps.so
+opt/googleearth/libgooglesearch.so
+opt/googleearth/libevll.so
+opt/googleearth/librender.so
+opt/googleearth/libinput_plugin.so
+opt/googleearth/libflightsim.so
+opt/googleearth/libcollada.so
+opt/googleearth/libminizip.so
+opt/googleearth/libauth.so
+opt/googleearth/libbasicingest.so
+opt/googleearth/libmeasure.so
+opt/googleearth/libgoogleearth_lib.so
+opt/googleearth/libmoduleframework.so
+"
+
+QA_DT_HASH="opt/${PN}/.*"
+
+pkg_setup() {
+ GCC_VER="$(gcc-version)"
+ if ! version_is_at_least ${GCC_NEEDED} ${GCC_VER}; then
+ ewarn "${PN} needs libraries from gcc-${GCC_NEEDED} or higher to run"
+ ewarn "Your active gcc version is only ${GCC_VER}"
+ ewarn "Please consult the GCC upgrade guide to set a higher version:"
+ ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ fi
+}
+
+src_unpack() {
+ unpack_makeself
+
+ cd "${WORKDIR}"/bin || die
+ unpack ./../${PN}-linux-x86.tar
+
+ mkdir "${WORKDIR}"/data && cd "${WORKDIR}"/data || die
+ unpack ./../${PN}-data.tar
+
+ cd "${WORKDIR}"/bin || die
+
+ if ! use qt-bundled; then
+ rm -v libQt{Core,Gui,Network,WebKit}.so.4 ../data/qt.conf || die
+ rm -frv ../data/plugins/imageformats || die
+ fi
+ rm -v libGLU.so.1 libcurl.so.4 || die
+ if ! use mdns-bundled; then
+ rm -v libnss_mdns4_minimal.so.2 || die
+ fi
+
+ if use x86; then
+ # no 32 bit libs for gdal
+ rm -v libgdal.so.1 || die
+ fi
+}
+
+src_prepare() {
+ cd "${WORKDIR}"/bin || die
+ # bug #262780
+ epatch "${FILESDIR}/decimal-separator.patch"
+
+ # make the postinst script only create the files; it's installation
+ # are too complicated and inserting them ourselves is easier than
+ # hacking around it
+ sed -i -e 's:$SETUP_INSTALLPATH/::' \
+ -e 's:$SETUP_INSTALLPATH:1:' \
+ -e "s:^xdg-desktop-icon.*$::" \
+ -e "s:^xdg-desktop-menu.*$::" \
+ -e "s:^xdg-mime.*$::" "${WORKDIR}"/postinstall.sh || die
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+ ./postinstall.sh
+ insinto /usr/share/mime/packages
+ doins ${PN}-mimetypes.xml || die
+ domenu Google-${PN}.desktop || die
+ doicon ${PN}-icon.png || die
+ dodoc README.linux || die
+
+ cd bin || die
+ exeinto /opt/${PN}
+ doexe * || die
+
+ cp -pPR "${WORKDIR}"/data/* "${D}"/opt/${PN} || die
+ fowners -R root:root /opt/${PN}
+ fperms -R a-x,a+X /opt/googleearth/resources
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_nofetch() {
+ elog "This version is no longer available from Google and the license prevents mirroring."
+ elog "This ebuild is intended for users who already downloaded it previously and have problems with 5.2+."
+ elog "If you can get the distfile from e.g. another computer of yours,"
+ elog "copy the file ${SRC_URI} to ${DISTDIR}."
+ elog "Otherwise, you need to unmask 5.2 or higher version."
+# elog "stabilization is tracked at https://bugs.gentoo.org/show_bug.cgi?id=320065"
+}
View
170 sci-geosciences/googleearth/googleearth-5.2.1.1588.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/googleearth-5.2.1.1588.ebuild,v 1.3 2011/01/31 16:05:44 caster Exp $
+
+EAPI=2
+
+inherit eutils fdo-mime versionator toolchain-funcs
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+# no upstream versioning, version determined from help/about
+# incorrect digest means upstream bumped and thus needs version bump
+SRC_URI="http://dl.google.com/earth/client/advanced/previous/GoogleEarthLinux.bin
+ -> GoogleEarthLinux-${PV}.bin"
+
+LICENSE="googleearth GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror strip"
+IUSE="mdns-bundled +qt-bundled"
+
+GCC_NEEDED="4.2"
+
+RDEPEND=">=sys-devel/gcc-${GCC_NEEDED}[-nocxx]
+ x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ sys-libs/zlib
+ dev-libs/glib:2
+ !qt-bundled? (
+ >=x11-libs/qt-core-4.5.3
+ >=x11-libs/qt-gui-4.5.3
+ >=x11-libs/qt-webkit-4.5.3
+ )
+ net-misc/curl
+ sci-libs/gdal
+ !mdns-bundled? ( sys-auth/nss-mdns )
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-20081109
+ >=app-emulation/emul-linux-x86-baselibs-20081109
+ app-emulation/emul-linux-x86-opengl
+ !qt-bundled? (
+ >=app-emulation/emul-linux-x86-qtlibs-20091231-r1
+ )
+ )
+ virtual/ttf-fonts"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Wrong checksum or file size means that Google silently replaced the distfile with a newer version."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for googleearth first!)."
+ einfo "By redigesting the file yourself, you will install a different version than the ebuild says, untested!"
+}
+
+QA_TEXTRELS="opt/googleearth/libflightsim.so
+opt/googleearth/libwebbrowser.so
+opt/googleearth/libinput_plugin.so
+opt/googleearth/libIGGfx.so
+opt/googleearth/liblayer.so
+opt/googleearth/libbase.so
+opt/googleearth/libevll.so
+opt/googleearth/libmoduleframework.so
+opt/googleearth/libcommon_webbrowser.so
+opt/googleearth/libbasicingest.so
+opt/googleearth/libsgutil.so
+opt/googleearth/libnavigate.so
+opt/googleearth/librender.so
+opt/googleearth/libauth.so
+opt/googleearth/libgeobaseutils.so
+opt/googleearth/libcommon.so
+opt/googleearth/libQtGui.so.4
+opt/googleearth/libcommon_platform.so
+opt/googleearth/libgoogleearth_free.so
+opt/googleearth/libcollada.so
+opt/googleearth/libviewsync.so
+opt/googleearth/libgps.so
+opt/googleearth/libgooglesearch.so
+opt/googleearth/plugins/imageformats/libqjpeg.so
+opt/googleearth/libmeasure.so
+"
+
+pkg_setup() {
+ GCC_VER="$(gcc-version)"
+ if ! version_is_at_least ${GCC_NEEDED} ${GCC_VER}; then
+ ewarn "${PN} needs libraries from gcc-${GCC_NEEDED} or higher to run"
+ ewarn "Your active gcc version is only ${GCC_VER}"
+ ewarn "Please consult the GCC upgrade guide to set a higher version:"
+ ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ fi
+}
+
+src_unpack() {
+ unpack_makeself
+
+ cd "${WORKDIR}"/bin || die
+ unpack ./../${PN}-linux-x86.tar
+
+ mkdir "${WORKDIR}"/data && cd "${WORKDIR}"/data || die
+ unpack ./../${PN}-data.tar
+
+ cd "${WORKDIR}"/bin || die
+
+ if ! use qt-bundled; then
+ rm -v libQt{Core,Gui,Network,WebKit}.so.4 ../data/qt.conf || die
+ rm -frv ../data/plugins/imageformats || die
+ fi
+ rm -v libGLU.so.1 libcurl.so.4 || die
+ if ! use mdns-bundled; then
+ rm -v libnss_mdns4_minimal.so.2 || die
+ fi
+
+ if use x86; then
+ # no 32 bit libs for gdal
+ rm -v libgdal.so.1 || die
+ fi
+}
+
+src_prepare() {
+ cd "${WORKDIR}"/bin || die
+ # bug #262780
+ epatch "${FILESDIR}/decimal-separator.patch"
+
+ # make the postinst script only create the files; it's installation
+ # are too complicated and inserting them ourselves is easier than
+ # hacking around it
+ sed -i -e 's:$SETUP_INSTALLPATH/::' \
+ -e 's:$SETUP_INSTALLPATH:1:' \
+ -e "s:^xdg-desktop-icon.*$::" \
+ -e "s:^xdg-desktop-menu.*$::" \
+ -e "s:^xdg-mime.*$::" "${WORKDIR}"/postinstall.sh || die
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+ ./postinstall.sh
+ insinto /usr/share/mime/packages
+ doins ${PN}-mimetypes.xml || die
+ domenu Google-${PN}.desktop || die
+ doicon ${PN}-icon.png || die
+ dodoc README.linux || die
+
+ cd bin || die
+ exeinto /opt/${PN}
+ doexe * || die
+
+ cp -pPR "${WORKDIR}"/data/* "${D}"/opt/${PN} || die
+ fowners -R root:root /opt/${PN}
+ fperms -R a-x,a+X /opt/googleearth/resources
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ elog "The qt-bundled flag is now enabled by default due to crashes on startup with system Qt."
+ elog "Testing and reporting outcome with/without the flag is welcome (bug #319813)."
+ elog "If it crashes in both cases, put this version in your package.mask and revert to the stable 5.1.*"
+}
View
185 sci-geosciences/googleearth/googleearth-6.0.2.2074.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Copyright 2011 Funtoo Technologies
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+inherit eutils fdo-mime versionator toolchain-funcs
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+# no upstream versioning, version determined from help/about
+# incorrect digest means upstream bumped and thus needs version bump
+SRC_URI="GoogleEarthLinux-${PV}.bin"
+
+LICENSE="googleearth GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch strip"
+IUSE="mdns-bundled +qt-bundled"
+
+GCC_NEEDED="4.2"
+
+RDEPEND=">=sys-devel/gcc-${GCC_NEEDED}[-nocxx]
+ x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ sys-libs/zlib
+ dev-libs/glib:2
+ !qt-bundled? (
+ >=x11-libs/qt-core-4.5.3
+ >=x11-libs/qt-gui-4.5.3
+ >=x11-libs/qt-webkit-4.5.3
+ )
+ net-misc/curl
+ sci-libs/gdal
+ !mdns-bundled? ( sys-auth/nss-mdns )
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-20081109
+ >=app-emulation/emul-linux-x86-baselibs-20081109
+ app-emulation/emul-linux-x86-opengl
+ !qt-bundled? (
+ >=app-emulation/emul-linux-x86-qtlibs-20091231-r1
+ )
+ )
+ virtual/ttf-fonts"
+
+DEPEND="dev-util/patchelf"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ elog "This version is no longer available from Google and the license prevents mirroring."
+ elog "This ebuild is intended for users who already downloaded it previously and have problems with newer versions."
+ elog "If you can get the distfile from e.g. another computer of yours,"
+ elog "copy the file ${SRC_URI} to ${DISTDIR}."
+}
+
+pkg_nofetch() {
+ einfo "Wrong checksum or file size means that Google silently replaced the distfile with a newer version."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for googleearth first!)."
+ einfo "By redigesting the file yourself, you will install a different version than the ebuild says, untested!"
+}
+
+QA_TEXTRELS="opt/googleearth/libflightsim.so
+opt/googleearth/libwebbrowser.so
+opt/googleearth/libinput_plugin.so
+opt/googleearth/libIGGfx.so
+opt/googleearth/liblayer.so
+opt/googleearth/libbase.so
+opt/googleearth/libevll.so
+opt/googleearth/libmoduleframework.so
+opt/googleearth/libcommon_webbrowser.so
+opt/googleearth/libbasicingest.so
+opt/googleearth/libsgutil.so
+opt/googleearth/libnavigate.so
+opt/googleearth/librender.so
+opt/googleearth/libauth.so
+opt/googleearth/libgeobaseutils.so
+opt/googleearth/libcommon.so
+opt/googleearth/libQtGui.so.4
+opt/googleearth/libcommon_platform.so
+opt/googleearth/libgoogleearth_free.so
+opt/googleearth/libcollada.so
+opt/googleearth/libviewsync.so
+opt/googleearth/libgps.so
+opt/googleearth/libgooglesearch.so
+opt/googleearth/plugins/imageformats/libqjpeg.so
+opt/googleearth/libmeasure.so
+opt/googleearth/libspatial.so
+"
+
+QA_DT_HASH="opt/googleearth/.*"
+
+pkg_setup() {
+ GCC_VER="$(gcc-version)"
+ if ! version_is_at_least ${GCC_NEEDED} ${GCC_VER}; then
+ ewarn "${PN} needs libraries from gcc-${GCC_NEEDED} or higher to run"
+ ewarn "Your active gcc version is only ${GCC_VER}"
+ ewarn "Please consult the GCC upgrade guide to set a higher version:"
+ ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ fi
+}
+
+src_unpack() {
+ unpack_makeself
+
+ cd "${WORKDIR}"/bin || die
+ unpack ./../${PN}-linux-x86.tar
+
+ mkdir "${WORKDIR}"/data && cd "${WORKDIR}"/data || die
+ unpack ./../${PN}-data.tar
+
+ cd "${WORKDIR}"/bin || die
+
+ if ! use qt-bundled; then
+ rm -v libQt{Core,Gui,Network,WebKit}.so.4 ../data/qt.conf || die
+ rm -frv ../data/plugins/imageformats || die
+ fi
+ rm -v libcurl.so.4 || die
+ if ! use mdns-bundled; then
+ rm -v libnss_mdns4_minimal.so.2 || die
+ fi
+
+ if use x86; then
+ # no 32 bit libs for gdal
+ rm -v libgdal.so.1 || die
+ fi
+}
+
+src_prepare() {
+ cd "${WORKDIR}"/bin || die
+ # bug #262780
+ epatch "${FILESDIR}/decimal-separator.patch"
+
+ # we have no ld-lsb.so.3 symlink
+ # thanks to Nathan Phillip Brink <ohnobinki@ohnopublishing.net> for suggesting patchelf
+ patchelf --set-interpreter /lib/ld-linux.so.2 googleearth-bin || die "patchelf failed"
+
+ # make the postinst script only create the files; it's installation
+ # are too complicated and inserting them ourselves is easier than
+ # hacking around it
+ sed -i -e 's:$SETUP_INSTALLPATH/::' \
+ -e 's:$SETUP_INSTALLPATH:1:' \
+ -e "s:^xdg-desktop-icon.*$::" \
+ -e "s:^xdg-desktop-menu.*$::" \
+ -e "s:^xdg-mime.*$::" "${WORKDIR}"/postinstall.sh || die
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+ ./postinstall.sh
+ insinto /usr/share/mime/packages
+ doins ${PN}-mimetypes.xml || die
+ domenu Google-${PN}.desktop || die
+ doicon ${PN}-icon.png || die
+ dodoc README.linux || die
+
+ cd bin || die
+ exeinto /opt/${PN}
+ doexe * || die
+
+ cp -pPR "${WORKDIR}"/data/* "${D}"/opt/${PN} || die
+ fowners -R root:root /opt/${PN}
+ fperms -R a-x,a+X /opt/googleearth/resources
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ elog "The qt-bundled flag is now enabled by default due to crashes on startup with system Qt."
+ elog "Testing and reporting outcome with/without the flag is welcome (bug #319813)."
+ elog "If it crashes in both cases, disabling tips is reported to help (bug #354281)."
+}
View
181 sci-geosciences/googleearth/googleearth-6.0.3.2197.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/googleearth-6.0.3.2197.ebuild,v 1.1 2011/05/24 16:29:44 caster Exp $
+
+EAPI=2
+
+inherit eutils fdo-mime versionator toolchain-funcs
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+# no upstream versioning, version determined from help/about
+# incorrect digest means upstream bumped and thus needs version bump
+SRC_URI="http://dl.google.com/earth/client/current/GoogleEarthLinux.bin
+ -> GoogleEarthLinux-${PV}.bin"
+
+LICENSE="googleearth GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror strip"
+IUSE="mdns-bundled +qt-bundled"
+
+GCC_NEEDED="4.2"
+
+RDEPEND=">=sys-devel/gcc-${GCC_NEEDED}[-nocxx]
+ x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ sys-libs/zlib
+ dev-libs/glib:2
+ !qt-bundled? (
+ >=x11-libs/qt-core-4.5.3
+ >=x11-libs/qt-gui-4.5.3
+ >=x11-libs/qt-webkit-4.5.3
+ )
+ net-misc/curl
+ sci-libs/gdal
+ !mdns-bundled? ( sys-auth/nss-mdns )
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-20081109
+ >=app-emulation/emul-linux-x86-baselibs-20081109
+ app-emulation/emul-linux-x86-opengl
+ !qt-bundled? (
+ >=app-emulation/emul-linux-x86-qtlibs-20091231-r1
+ )
+ )
+ virtual/ttf-fonts
+ >=sys-libs/glibc-2.12
+ "
+
+DEPEND="dev-util/patchelf"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Wrong checksum or file size means that Google silently replaced the distfile with a newer version."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for googleearth first!)."
+ einfo "By redigesting the file yourself, you will install a different version than the ebuild says, untested!"
+}
+
+QA_TEXTRELS="opt/googleearth/libflightsim.so
+opt/googleearth/libwebbrowser.so
+opt/googleearth/libinput_plugin.so
+opt/googleearth/libIGGfx.so
+opt/googleearth/liblayer.so
+opt/googleearth/libbase.so
+opt/googleearth/libevll.so
+opt/googleearth/libmoduleframework.so
+opt/googleearth/libcommon_webbrowser.so
+opt/googleearth/libbasicingest.so
+opt/googleearth/libsgutil.so
+opt/googleearth/libnavigate.so
+opt/googleearth/librender.so
+opt/googleearth/libauth.so
+opt/googleearth/libgeobaseutils.so
+opt/googleearth/libcommon.so
+opt/googleearth/libQtGui.so.4
+opt/googleearth/libcommon_platform.so
+opt/googleearth/libgoogleearth_free.so
+opt/googleearth/libcollada.so
+opt/googleearth/libviewsync.so
+opt/googleearth/libgps.so
+opt/googleearth/libgooglesearch.so
+opt/googleearth/plugins/imageformats/libqjpeg.so
+opt/googleearth/libmeasure.so
+opt/googleearth/libspatial.so
+"
+
+QA_DT_HASH="opt/googleearth/.*"
+
+pkg_setup() {
+ GCC_VER="$(gcc-version)"
+ if ! version_is_at_least ${GCC_NEEDED} ${GCC_VER}; then
+ ewarn "${PN} needs libraries from gcc-${GCC_NEEDED} or higher to run"
+ ewarn "Your active gcc version is only ${GCC_VER}"
+ ewarn "Please consult the GCC upgrade guide to set a higher version:"
+ ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ fi
+}
+
+src_unpack() {
+ unpack_makeself
+
+ cd "${WORKDIR}"/bin || die
+ unpack ./../${PN}-linux-x86.tar
+
+ mkdir "${WORKDIR}"/data && cd "${WORKDIR}"/data || die
+ unpack ./../${PN}-data.tar
+
+ cd "${WORKDIR}"/bin || die
+
+ if ! use qt-bundled; then
+ rm -v libQt{Core,Gui,Network,WebKit}.so.4 ../data/qt.conf || die
+ rm -frv ../data/plugins/imageformats || die
+ fi
+ rm -v libcurl.so.4 || die
+ if ! use mdns-bundled; then
+ rm -v libnss_mdns4_minimal.so.2 || die
+ fi
+
+ if use x86; then
+ # no 32 bit libs for gdal
+ rm -v libgdal.so.1 || die
+ fi
+}
+
+src_prepare() {
+ cd "${WORKDIR}"/bin || die
+ # bug #262780
+ epatch "${FILESDIR}/decimal-separator.patch"
+
+ # we have no ld-lsb.so.3 symlink
+ # thanks to Nathan Phillip Brink <ohnobinki@ohnopublishing.net> for suggesting patchelf
+ patchelf --set-interpreter /lib/ld-linux.so.2 googleearth-bin || die "patchelf failed"
+
+ # make the postinst script only create the files; it's installation
+ # are too complicated and inserting them ourselves is easier than
+ # hacking around it
+ sed -i -e 's:$SETUP_INSTALLPATH/::' \
+ -e 's:$SETUP_INSTALLPATH:1:' \
+ -e "s:^xdg-desktop-icon.*$::" \
+ -e "s:^xdg-desktop-menu.*$::" \
+ -e "s:^xdg-mime.*$::" "${WORKDIR}"/postinstall.sh || die
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+ ./postinstall.sh
+ insinto /usr/share/mime/packages
+ doins ${PN}-mimetypes.xml || die
+ domenu Google-${PN}.desktop || die
+ doicon ${PN}-icon.png || die
+ dodoc README.linux || die
+
+ cd bin || die
+ exeinto /opt/${PN}
+ doexe * || die
+
+ cp -pPR "${WORKDIR}"/data/* "${D}"/opt/${PN} || die
+ fowners -R root:root /opt/${PN}
+ fperms -R a-x,a+X /opt/googleearth/resources
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ elog "The qt-bundled flag is now enabled by default due to crashes on startup with system Qt."
+ elog "Testing and reporting outcome with/without the flag is welcome (bug #319813)."
+ elog "If it crashes in both cases, disabling tips is reported to help (bug #354281)."
+}
View
14 sci-geosciences/googleearth/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+ <maintainer>
+ <email>caster@gentoo.org</email>
+ <name>Vlastimil Babka</name>
+ <description>Assign bugs to me for now</description>
+ </maintainer>
+ <use>
+ <flag name="qt-bundled">Use bundled Qt4 libraries instead of system ones. Recommended only for troubleshooting.</flag>
+ <flag name="mdns-bundled">Use bundled nss-mdns library instead of depending on sys-auth/nss-mdns. Enable this if you want to avoid the deptree.</flag>
+ </use>
+</pkgmetadata>

0 comments on commit 949d9d6

Please sign in to comment.