Skip to content

Loading…

[BUGFIX] Fixed the 'source' in the app generator to use 'https' explicitly #274

Merged
merged 1 commit into from

2 participants

@srushti

Fixing the warning that comes while running bundle install on newly generated projects.

The source :rubygems is deprecated because HTTP requests are insecure.
Please change your source to 'https://rubygems.org' if possible, or 'http://rubygems.org' if not.

@benlangfeld
Adhearsion member

Thanks!

@benlangfeld benlangfeld merged commit 1c665ff into adhearsion:develop

1 check failed

Details default The Travis build failed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Showing with 2 additions and 2 deletions.
  1. +1 −1 features/app_generator.feature
  2. +1 −1 lib/adhearsion/generators/app/templates/Gemfile.erb
View
2 features/app_generator.feature
@@ -42,7 +42,7 @@ Feature: Adhearsion App Generator
And the file "Rakefile" should contain "adhearsion/tasks"
And the file "Gemfile" should contain each of these content parts:
"""
- source :rubygems
+ source 'https://rubygems.org
gem 'adhearsion-asterisk'
"""
And the file "lib/simon_game.rb" should contain "class SimonGame"
View
2 lib/adhearsion/generators/app/templates/Gemfile.erb
@@ -1,4 +1,4 @@
-source :rubygems
+source 'https://rubygems.org'
gem "adhearsion", "~> <%= Adhearsion::VERSION.split('.')[0,2].join('.') %>"
Something went wrong with that request. Please try again.