Permalink
Browse files

Merge branch 'release/0.3.3' into develop

  • Loading branch information...
benlangfeld committed Dec 16, 2011
2 parents 99ce9fc + a448bb0 commit aa5dc1cf686fc5c6870022105421db7b8f8314c3
View
@@ -1,3 +1,7 @@
+# 0.3.3
+ * Allow `SSML::Element.import` and `GRXML::Element.import` to take a string as well as a Nokogiri::XML::Node
+ * Allow importing GRXML/SSML documents via their respective modules (eg `RubySpeech::GRXML.import '<grammar ... />'`)
+
# 0.3.2
* Fix inheriting an `SSML::Speak`'s language. Previously an imported `<speak/>` would end up with a `lang` attribute in addition to `xml:lang`, and `xml:lang` would have the default value (`en-US`). This required a Niceogiri dependency update.
View
@@ -21,5 +21,9 @@ def self.draw(attributes = {}, &block)
grammar << block_return if block_return.is_a?(String)
end
end
+
+ def self.import(other)
+ Element.import other
+ end
end # GRXML
end # RubySpeech
View
@@ -21,5 +21,9 @@ def self.draw(&block)
speak << block_return if block_return.is_a?(String)
end
end
+
+ def self.import(other)
+ Element.import other
+ end
end # SSML
end # RubySpeech
@@ -1,3 +1,3 @@
module RubySpeech
- VERSION = "0.3.2"
+ VERSION = "0.3.3"
end
@@ -229,7 +229,7 @@ module RubySpeech
GRXML::Grammar.new.tap { |doc| doc << rule }.to_s
end
- let(:import) { GRXML::Element.import document }
+ let(:import) { GRXML.import document }
subject { import }
@@ -238,7 +238,7 @@ module RubySpeech
SSML::Speak.new.tap { |doc| doc << voice }.to_s
end
- let(:import) { SSML::Element.import document }
+ let(:import) { SSML.import document }
subject { import }

0 comments on commit aa5dc1c

Please sign in to comment.