New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't install ruby_speech gem, checking for pcre.h... no #11

Closed
scarver2 opened this Issue May 22, 2013 · 5 comments

Comments

Projects
None yet
3 participants
@scarver2

scarver2 commented May 22, 2013

For anyone attempting to gem install ruby_speech, you must have the pcre library installed first.

On OSX with Homebrew,
brew install pcre

On Ubuntu,
sudo apt-get install libpcre3 libpcre3-dev

If you `gem install ruby_speech and get the following error, this applies to you:

/Users/username/.rvm/rubies/ruby-2.0.0-p0/bin/ruby extconf.rb
checking for pcre.h... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
    --with-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/username/.rvm/rubies/ruby-2.0.0-p0/bin/ruby
extconf.rb:5:in `<main>': undefined local variable or method `lib' for main:Object (NameError)
@benlangfeld

This comment has been minimized.

Show comment
Hide comment
@benlangfeld

benlangfeld May 22, 2013

Member

Thanks Stan, I'll make sure this is mentioned in the docs and see if we can make the build error any more friendly.

Member

benlangfeld commented May 22, 2013

Thanks Stan, I'll make sure this is mentioned in the docs and see if we can make the build error any more friendly.

@benlangfeld

This comment has been minimized.

Show comment
Hide comment
@benlangfeld

benlangfeld Jun 20, 2013

Member

I think documenting this is all we can do, I don't think there's a way to make the error friendlier :(

Member

benlangfeld commented Jun 20, 2013

I think documenting this is all we can do, I don't think there's a way to make the error friendlier :(

@scarver2

This comment has been minimized.

Show comment
Hide comment
@scarver2

scarver2 Jun 20, 2013

Thanks, Ben. Now that we have dialoged about this, Google will help anyone searching for "can't install ruby speech gem"

On Jun 20, 2013, at 12:14 PM, Ben Langfeld notifications@github.com wrote:

I think documenting this is all we can do, I don't think there's a way to make the error friendlier :(


Reply to this email directly or view it on GitHub.

scarver2 commented Jun 20, 2013

Thanks, Ben. Now that we have dialoged about this, Google will help anyone searching for "can't install ruby speech gem"

On Jun 20, 2013, at 12:14 PM, Ben Langfeld notifications@github.com wrote:

I think documenting this is all we can do, I don't think there's a way to make the error friendlier :(


Reply to this email directly or view it on GitHub.

@benlangfeld

This comment has been minimized.

Show comment
Hide comment
@benlangfeld

benlangfeld Jun 21, 2013

Member

Fixed :)

Member

benlangfeld commented Jun 21, 2013

Fixed :)

@wyaldalex

This comment has been minimized.

Show comment
Hide comment
@wyaldalex

wyaldalex May 8, 2018

Thanks a lot 👍

wyaldalex commented May 8, 2018

Thanks a lot 👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment