Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Fetching contributors…
Cannot retrieve contributors at this time
109 lines (81 sloc) 2.63 KB
# Generated from rubyzip-0.9.1.gem by gem2rpm -*- rpm-spec -*-
%global gemdir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)
%global gemname rubyzip
%global geminstdir %{gemdir}/gems/%{gemname}-%{version}
Summary: A ruby module for reading and writing zip files
Name: rubygem-%{gemname}
Version: 0.9.4
Release: 2%{?dist}
Group: Development/Languages
License: GPLv2+ or Ruby
Source0: Source0:{gemname}-%{version}.gem
Patch0: rubyzip-commentsize.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: ruby(abi) = 1.8
Requires: rubygems
BuildRequires: rubygems
BuildArch: noarch
Provides: rubygem(%{gemname}) = %{version}
rubyzip is a ruby module for reading and writing zip files
%package doc
Summary: Documentation for %{name}
Group: Documentation
Requires: %{name} = %{version}-%{release}
%description doc
This package contains documentation for %{name}.
rm -rf %{buildroot}
mkdir -p %{buildroot}%{gemdir}
gem install --local --install-dir %{buildroot}%{gemdir} \
--force --rdoc %{SOURCE0}
pushd %{buildroot}
patch -p0 < %{PATCH0}
chmod 755 %{buildroot}%{geminstdir}/install.rb
for SCRIPT in example_filesystem gtkRubyzip example write_simple qtzip zipfind
chmod 755 %{buildroot}%{geminstdir}/samples/$SCRIPT.rb
for RB in stdrubyext zip tempfile_bugfixed ioextras zipfilesystem ziprequire
chmod 644 %{buildroot}%{geminstdir}/lib/zip/$RB.rb
chmod 644 %{buildroot}%{geminstdir}/Rakefile
# These aren't executables
sed -i -e '/^#!\/usr\/bin\/env ruby/d' \
# CRLF is sprinkled throughout the files
find %{buildroot}%{geminstdir} -type f -print0 | xargs -0 -n1 sed -i 's/\r//'
rm -rf %{buildroot}
%defattr(-, root, root, -)
%doc %{geminstdir}/[A-Z]*
%dir %{geminstdir}
%doc %{gemdir}/doc/%{gemname}-%{version}
%files doc
* Thu May 13 2010 Adam Young <> - 0.9.4-2
- Upgraded to 0.9.4, with a patch to make buildr run
* Tue May 11 2010 Adam Young <> - 0.9.1-2
- Split documentation out into separate rpm
- Fixed rpmlint errors
* Tue May 11 2010 Adam Young <> - 0.9.1-2
- Fixed License
- Added ABI Dependency
- changed define to global
* Tue Apr 06 2010 Adam Young <> - 0.9.1-1
- Initial package
Jump to Line
Something went wrong with that request. Please try again.