Skip to content
A suite of tools to modernize your AEM Sites implementations off legacy features.
Java JavaScript HTML CSS
Branch: develop
Clone or download
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
bundles/aem-modernize-tools
content
parent @releng [maven-scm] :prepare for next development iteration Jun 17, 2019
.gitignore Adding Initial code. This will replace component converter. Jan 22, 2019
.travis.yml
CHANGELOG.md Preparing Changelog new development. Jun 17, 2019
CODE_OF_CONDUCT.md
CONTRIBUTING.md Adding required CLA entry. Mar 27, 2019
COPYRIGHT
Jenkinsfile Fix reference to API docs folder. Jun 16, 2019
LICENSE Adding necessary OSS release files as per request. Feb 8, 2019
README.md
pom.xml @releng [maven-scm] :prepare for next development iteration Jun 17, 2019

README.md

AEM Modernize Tools Suite

This suite of tools provides AEM Development teams with converting legacy AEM features to the current capabilities. It consists of:

  • Template Conversion Tool (Static -> Editable)
  • Policy Conversion Tool (Design Configurations -> Policies)
  • Component Conversion Tool (Legacy -> Modern/Core)
  • Dialog Conversion Tool (Classic -> Touch Enabled UI)

Goals

The goal of this project is to provide development teams with a framework for updating their AEM implementations. Consumers of this project should be able to execute conversions by providing the minimally necessary rewrite rules for their sites

Install

The tool should work on instances of AEM 6.3 or newer. To install it, do one of the following:

  • Download and install the latest released version of aem-modernize-tools-content
  • Clone this git repository, then build and install the content package located in /content

Usage

Documentation for the tools contained within this project can be found on Adobe's HelpX Documentation site.

Contributing

Contributions are welcomed! Read the Contributing Guide for more information.

Licensing

This project is licensed under the Apache V2 License. See LICENSE for more information.

You can’t perform that action at this time.