Permalink
Browse files

Merge pull request #13019 from ficristo/less

Upgrade less from 2.5.1 to 2.7.2
  • Loading branch information...
2 parents 565f0c8 + bf41dc1 commit 034215c4fb036a4851e9ef3416749dd94735ae96 @zaggino zaggino committed on GitHub Jan 9, 2017
Showing with 463 additions and 25 deletions.
  1. +2 −1 .gitignore
  2. +14 −2 Gruntfile.js
  3. +1 −1 package.json
  4. +1 −1 src/config.json
  5. +1 −1 src/index.html
  6. +441 −0 src/npm-shrinkwrap.json
  7. +2 −1 src/package.json
  8. +0 −17 src/thirdparty/less-2.5.1.min.js
  9. +1 −1 test/SpecRunner.html
View
@@ -10,8 +10,9 @@ Thumbs.db
# ignore node_modules inside src
/src/node_modules
-#ignore file copied from node_modules to src/thirdparty
+# ignore files copied from node_modules to src/thirdparty
/src/thirdparty/CodeMirror
+/src/thirdparty/less.min.js
# ignore compiled files
/dist
View
@@ -130,6 +130,15 @@ module.exports = function (grunt) {
'mode/{,*/}*',
'theme/{,*/}*',
]
+ },
+ {
+ expand: true,
+ flatten: true,
+ dest: 'src/thirdparty',
+ cwd: 'src/node_modules',
+ src: [
+ 'less/dist/less.min.js'
+ ]
}
]
}
@@ -286,9 +295,12 @@ module.exports = function (grunt) {
specs : '<%= meta.specs %>',
/* Keep in sync with test/SpecRunner.html dependencies */
vendor : [
- 'test/polyfills.js', /* For reference to why this polyfill is needed see Issue #7951. The need for this should go away once the version of phantomjs gets upgraded to 2.0 */
+ // For reference to why this polyfill is needed see Issue #7951.
+ // The need for this should go away once the version of phantomjs gets upgraded to 2.0
+ 'test/polyfills.js',
+
'src/thirdparty/jquery-2.1.3.min.js',
- 'src/thirdparty/less-2.5.1.min.js'
+ 'src/thirdparty/less.min.js'
],
helpers : [
'test/spec/PhantomHelper.js'
View
@@ -33,7 +33,7 @@
"grunt-contrib-clean": "0.4.1",
"grunt-contrib-copy": "0.4.1",
"grunt-contrib-htmlmin": "0.1.3",
- "grunt-contrib-less": "1.0.1",
+ "grunt-contrib-less": "1.4.0",
"grunt-contrib-requirejs": "0.4.1",
"grunt-contrib-uglify": "0.2.0",
"grunt-contrib-concat": "0.3.0",
View
@@ -56,7 +56,7 @@
"grunt-contrib-clean": "0.4.1",
"grunt-contrib-copy": "0.4.1",
"grunt-contrib-htmlmin": "0.1.3",
- "grunt-contrib-less": "1.0.1",
+ "grunt-contrib-less": "1.4.0",
"grunt-contrib-requirejs": "0.4.1",
"grunt-contrib-uglify": "0.2.0",
"grunt-contrib-concat": "0.3.0",
View
@@ -46,7 +46,7 @@
<!-- Pre-load third party scripts that cannot be async loaded. -->
<!-- build:js thirdparty/thirdparty.min.js -->
- <script src="thirdparty/less-2.5.1.min.js"></script>
+ <script src="thirdparty/less.min.js"></script>
<script src="thirdparty/jquery-2.1.3.min.js"></script>
<!-- endbuild -->
</head>
Oops, something went wrong.

0 comments on commit 034215c

Please sign in to comment.