Upgrade less from 2.5.1 to 2.7.2 #13019

Merged
merged 1 commit into from Jan 9, 2017

Projects

None yet

2 participants

@ficristo
Member
ficristo commented Jan 2, 2017

I would like to upgrade grunt related dependencies and this was in the way: updating only the grunt dep without the thirdparty didn't seem good.
I renamed less-2.5.1.min.js to simply less.min.js, you can see the version in the comments inside the file.

@zaggino
Member
zaggino commented Jan 2, 2017

could we maybe switch to npm dependency instead?

@ficristo
Member
ficristo commented Jan 2, 2017

I'm all for moving to npm.
But has pointed out before by @busykai, we need to do something about the increase size of the bundle.
For example less 2.7.1 from npm is about 3MB, but the minified file is only 140kB.
I have some random thought but still nothing good.
So WDYT?

@zaggino
Member
zaggino commented Jan 2, 2017

Is it about npm not providing minified file or about npm providing too many files that we don't need?

@ficristo
Member
ficristo commented Jan 3, 2017

Too many files, I've opened #13020 as a possible solution

@ficristo
Member
ficristo commented Jan 8, 2017

Now it is fetched from npm.

@ficristo ficristo changed the title from Upgrade less from 2.5.1 to 2.7.1 to Upgrade less from 2.5.1 to 2.7.2 Jan 8, 2017
@zaggino
zaggino approved these changes Jan 9, 2017 View changes
@zaggino zaggino merged commit 034215c into adobe:master Jan 9, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@zaggino
Member
zaggino commented Jan 9, 2017

👍 cool

@ficristo ficristo deleted the ficristo:less branch Jan 9, 2017
@ficristo
Member
ficristo commented Jan 9, 2017

Thank you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment