Permalink
Fetching contributors…
Cannot retrieve contributors at this time
96 lines (88 sloc) 3.24 KB
use Mix.Config
# For production, we often load configuration from external
# sources, such as your system environment. For this reason,
# you won't find the :http configuration below, but set inside
# PicapeWeb.Endpoint.load_from_system_env/1 dynamically.
# Any dynamic configuration should be moved to such function.
#
# Don't forget to configure the url host to something meaningful,
# Phoenix uses this information when generating URLs.
#
# Finally, we also include the path to a cache manifest
# containing the digested version of static files. This
# manifest is generated by the mix phoenix.digest task
# which you typically run after static files are built.
config :picape, PicapeWeb.Endpoint,
http: [port: {:system, "PORT"}],
url: [scheme: "https", host: {:system, "HOST"}, port: 443],
# Not needed because this is handled by a proxy
# force_ssl: [rewrite_on: [:x_forwarded_proto]],
cache_static_manifest: "priv/static/cache_manifest.json",
secret_key_base: System.get_env("SECRET_KEY_BASE"),
watchers: [
bash: [
"../bin/spawn_execute.sh",
"node",
"node_modules/next/dist/bin/next-start",
"-p",
"4001",
cd: Path.expand("../assets", __DIR__)
]
]
config :picape, Picape.Repo,
adapter: Ecto.Adapters.Postgres,
url: System.get_env("DATABASE_URL"),
pool_size: String.to_integer(System.get_env("POOL_SIZE") || "10"),
ssl: true
# Do not print debug messages in production
config :logger, level: :info
config :picape, Picape.Supermarket,
base_url: System.get_env("SUPERMARKET_BASE_URL"),
static_url: System.get_env("SUPERMARKET_STATIC_URL"),
headers: [
"Accept-Language": "nl-NL",
"x-#{System.get_env("SUPERMARKET_HEADER")}-agent": System.get_env("SUPERMARKET_AGENT"),
"x-#{System.get_env("SUPERMARKET_HEADER")}-did": System.get_env("SUPERMARKET_DID"),
"x-#{System.get_env("SUPERMARKET_HEADER")}-auth": System.get_env("SUPERMARKET_AUTH"),
"User-Agent": System.get_env("SUPERMARKET_USER_AGENT")
],
cookie: System.get_env("SUPERMARKET_COOKIE")
# config :picape, Picape.Mailer,
# adapter: Swoosh.Adapters.Sendgrid,
# api_key: {:system, "SENDGRID_API_KEY"}
# ## SSL Support
#
# To get SSL working, you will need to add the `https` key
# to the previous section and set your `:url` port to 443:
#
# config :picape, PicapeWeb.Endpoint,
# ...
# url: [host: "example.com", port: 443],
# https: [:inet6,
# port: 443,
# keyfile: System.get_env("SOME_APP_SSL_KEY_PATH"),
# certfile: System.get_env("SOME_APP_SSL_CERT_PATH")]
#
# Where those two env variables return an absolute path to
# the key and cert in disk or a relative path inside priv,
# for example "priv/ssl/server.key".
#
# We also recommend setting `force_ssl`, ensuring no data is
# ever sent via http, always redirecting to https:
#
# config :picape, PicapeWeb.Endpoint,
# force_ssl: [hsts: true]
#
# Check `Plug.SSL` for all available options in `force_ssl`.
# ## Using releases
#
# If you are doing OTP releases, you need to instruct Phoenix
# to start the server for all endpoints:
#
# config :phoenix, :serve_endpoints, true
#
# Alternatively, you can configure exactly which server to
# start per endpoint:
#
# config :picape, PicapeWeb.Endpoint, server: true
#